kiss-mfavila-large/ports/aewm/patches/05-source-changes.patch

71 lines
1.7 KiB
Diff

From: Decklin Foster <decklin@red-bean.com>
Subject: Changes to original sources
---
Makefile | 14 +++++++-------
aewm.h | 2 +-
doc/aewmrc.ex | 2 +-
3 files changed, 9 insertions(+), 9 deletions(-)
--- a/Makefile
+++ b/Makefile
@@ -3,15 +3,15 @@
# Set this to the location where you want to install
DESTDIR =
-XROOT = /usr/X11R6
+XROOT = /usr
# Uncomment to enable Shape extension support
-#OPT_WMFLAGS += -DSHAPE
-#OPT_WMLIB += -lXext
+OPT_WMFLAGS += -DSHAPE
+OPT_WMLIB += -lXext
# Uncomment to add Xft support
-#OPT_WMFLAGS += -DXFT `pkg-config --cflags xft`
-#OPT_WMLIB += `pkg-config --libs xft` -lXext
+OPT_WMFLAGS += -DXFT `pkg-config --cflags xft`
+OPT_WMLIB += `pkg-config --libs xft` -lXext
# Uncomment for debugging (abandon all hope, ye who enter here)
#OPT_WMFLAGS += -DDEBUG
@@ -21,7 +21,7 @@
CFLAGS = -g -O2 -Wall
BINDIR = $(DESTDIR)$(XROOT)/bin
-MANDIR = $(DESTDIR)$(XROOT)/man/man1
+MANDIR = $(DESTDIR)$(XROOT)/share/man/man1
CFGDIR = $(DESTDIR)/etc/X11/aewm
PLAINOBJ = aesession.o parser.o
@@ -62,7 +62,7 @@
X11LIB = -L$(XROOT)/lib -lX11
WMLIB = $(X11LIB) $(OPT_WMLIB)
-GTKLIB = `pkg-config --libs gtk+-2.0`
+GTKLIB = `pkg-config --libs gtk+-2.0` -lX11
$(PLAINBIN): %: %.o
$(CC) $^ -o $@
--- a/aewm.h
+++ b/aewm.h
@@ -29,7 +29,7 @@
#define DEF_IMAP 0
#define DEF_NEW1 "aemenu --switch"
-#define DEF_NEW2 "xterm"
+#define DEF_NEW2 "x-terminal-emulator"
#define DEF_NEW3 "aemenu --launch"
#define DEF_NEW4 "aedesk -1"
#define DEF_NEW5 "aedesk +1"
--- a/doc/aewmrc.ex
+++ b/doc/aewmrc.ex
@@ -19,5 +19,5 @@
# Clients to launch when the root window is clicked
button1 "aemenu"
-button2 "xterm"
+button2 "x-terminal-emulator"
button3 "aemenu --switch"