gnu: pulseaudio: Update to 12.0.
* gnu/packages/patches/pulseaudio-glibc-2.27.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/pulseaudio.scm (pulseaudio): Update to 12.0. [source](patches): Remove 'pulseaudio-glibc-2.27.patch'. [arguments]: Remove related 'bootstrap' phase. [native-inputs]: Remove AUTOCONF, AUTOMAKE and LIBTOOL. Add GLIB:BIN.
This commit is contained in:
parent
19bb999a50
commit
bf77a2c87a
@ -1043,7 +1043,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/psm-ldflags.patch \
|
||||
%D%/packages/patches/psm-repro.patch \
|
||||
%D%/packages/patches/pulseaudio-fix-mult-test.patch \
|
||||
%D%/packages/patches/pulseaudio-glibc-2.27.patch \
|
||||
%D%/packages/patches/pulseaudio-longer-test-timeout.patch \
|
||||
%D%/packages/patches/pybugz-encode-error.patch \
|
||||
%D%/packages/patches/pybugz-stty.patch \
|
||||
|
@ -1,67 +0,0 @@
|
||||
Copied from:
|
||||
https://cgit.freedesktop.org/pulseaudio/pulseaudio/commit/?id=dfb0460fb4743aec047cdf755a660a9ac2d0f3fb
|
||||
|
||||
|
||||
From dfb0460fb4743aec047cdf755a660a9ac2d0f3fb Mon Sep 17 00:00:00 2001
|
||||
From: Tanu Kaskinen <tanuk@iki.fi>
|
||||
Date: Wed, 24 Jan 2018 03:51:49 +0200
|
||||
Subject: [PATCH] memfd-wrappers: only define memfd_create() if not already
|
||||
defined
|
||||
|
||||
glibc 2.27 is to be released soon, and it will provide memfd_create().
|
||||
If glibc provides the function, we must not define it ourselves,
|
||||
otherwise building fails due to conflict between the two implementations
|
||||
of the same function.
|
||||
|
||||
BugLink: https://bugs.freedesktop.org/show_bug.cgi?id=104733
|
||||
---
|
||||
configure.ac | 3 +++
|
||||
src/pulsecore/memfd-wrappers.h | 7 ++++---
|
||||
2 files changed, 7 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 0084c86e..0eb44b08 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -610,6 +610,9 @@ AS_IF([test "x$enable_memfd" = "xyes" && test "x$HAVE_MEMFD" = "x0"],
|
||||
[AC_MSG_ERROR([*** Your Linux kernel does not support memfd shared memory.
|
||||
*** Use linux v3.17 or higher for such a feature.])])
|
||||
|
||||
+AS_IF([test "x$HAVE_MEMFD" = "x1"],
|
||||
+ AC_CHECK_FUNCS([memfd_create]))
|
||||
+
|
||||
AC_SUBST(HAVE_MEMFD)
|
||||
AM_CONDITIONAL([HAVE_MEMFD], [test "x$HAVE_MEMFD" = x1])
|
||||
AS_IF([test "x$HAVE_MEMFD" = "x1"], AC_DEFINE([HAVE_MEMFD], 1, [Have memfd shared memory.]))
|
||||
diff --git a/src/pulsecore/memfd-wrappers.h b/src/pulsecore/memfd-wrappers.h
|
||||
index 3bed9b2b..c7aadfd3 100644
|
||||
--- a/src/pulsecore/memfd-wrappers.h
|
||||
+++ b/src/pulsecore/memfd-wrappers.h
|
||||
@@ -20,13 +20,14 @@
|
||||
License along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
|
||||
***/
|
||||
|
||||
-#ifdef HAVE_MEMFD
|
||||
+#if defined(HAVE_MEMFD) && !defined(HAVE_MEMFD_CREATE)
|
||||
|
||||
#include <sys/syscall.h>
|
||||
#include <fcntl.h>
|
||||
|
||||
/*
|
||||
- * No glibc wrappers exist for memfd_create(2), so provide our own.
|
||||
+ * Before glibc version 2.27 there was no wrapper for memfd_create(2),
|
||||
+ * so we have to provide our own.
|
||||
*
|
||||
* Also define memfd fcntl sealing macros. While they are already
|
||||
* defined in the kernel header file <linux/fcntl.h>, that file as
|
||||
@@ -63,6 +64,6 @@ static inline int memfd_create(const char *name, unsigned int flags) {
|
||||
#define F_SEAL_WRITE 0x0008 /* prevent writes */
|
||||
#endif
|
||||
|
||||
-#endif /* HAVE_MEMFD */
|
||||
+#endif /* HAVE_MEMFD && !HAVE_MEMFD_CREATE */
|
||||
|
||||
#endif
|
||||
--
|
||||
2.16.2
|
||||
|
@ -122,7 +122,7 @@ rates.")
|
||||
(define-public pulseaudio
|
||||
(package
|
||||
(name "pulseaudio")
|
||||
(version "11.1")
|
||||
(version "12.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
@ -130,7 +130,7 @@ rates.")
|
||||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"17ndr6kc7hpv4ih4gygwlcpviqifbkvnk4fbwf4n25kpb991qlpj"))
|
||||
"0i248rmwwlfx1r22aiy1wf5lmhixlznyasgqdb5w04gxr6yjshkf"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
;; Disable console-kit support by default since it's deprecated
|
||||
@ -141,7 +141,6 @@ rates.")
|
||||
(string-append "#" all "\n")))
|
||||
#t))
|
||||
(patches (search-patches
|
||||
"pulseaudio-glibc-2.27.patch"
|
||||
"pulseaudio-fix-mult-test.patch"
|
||||
"pulseaudio-longer-test-timeout.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
@ -153,13 +152,6 @@ rates.")
|
||||
(assoc-ref %outputs "out")
|
||||
"/lib/udev/rules.d"))
|
||||
#:phases (modify-phases %standard-phases
|
||||
(replace 'bootstrap
|
||||
;; TODO: Remove this custom bootstrap phase when
|
||||
;; pulseaudio-glibc-2.27.patch is removed.
|
||||
(lambda _
|
||||
(patch-shebang "git-version-gen")
|
||||
(setenv "NOCONFIGURE" "1")
|
||||
(invoke "bash" "bootstrap.sh")))
|
||||
(add-before 'check 'pre-check
|
||||
(lambda _
|
||||
;; 'tests/lock-autospawn-test.c' wants to create a file
|
||||
@ -188,11 +180,7 @@ rates.")
|
||||
("check" ,check)))
|
||||
(native-inputs
|
||||
`(("pkg-config" ,pkg-config)
|
||||
;; TODO: Remove "autoconf", "automake", and "libtool" from
|
||||
;; native-inputs when pulseaudio-glibc-2.27.patch is removed.
|
||||
("autoconf" ,autoconf)
|
||||
("automake" ,automake)
|
||||
("libtool" ,libtool)))
|
||||
("glib:bin" ,glib "bin")))
|
||||
(propagated-inputs
|
||||
;; 'libpulse*.la' contain `-lgdbm' and `-lcap', so propagate them.
|
||||
`(("libcap" ,libcap)
|
||||
|
Loading…
Reference in New Issue
Block a user