gnu: gnumach: Update to 1.8+git20220827.

* gnu/packages/hurd.scm (gnumach-headers): Do it.

* gnu/packages/patches/gnumach-add-missing-const_mach_port_name_array_t-type.patch:
New file.
* gnu/local.mk (dist_patch_DATA): Register it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Josselin Poiret 2023-03-20 23:10:43 +01:00 committed by Ludovic Courtès
parent c78fd5a25d
commit 6cd532c9f4
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 71 additions and 39 deletions

View File

@ -1251,6 +1251,7 @@ dist_patch_DATA = \
%D%/packages/patches/gnome-settings-daemon-gc.patch \ %D%/packages/patches/gnome-settings-daemon-gc.patch \
%D%/packages/patches/gnome-session-support-elogind.patch \ %D%/packages/patches/gnome-session-support-elogind.patch \
%D%/packages/patches/gnome-tweaks-search-paths.patch \ %D%/packages/patches/gnome-tweaks-search-paths.patch \
%D%/packages/patches/gnumach-add-missing-const_mach_port_name_array_t-type.patch \
%D%/packages/patches/gnupg-default-pinentry.patch \ %D%/packages/patches/gnupg-default-pinentry.patch \
%D%/packages/patches/gnupg-1-build-with-gcc10.patch \ %D%/packages/patches/gnupg-1-build-with-gcc10.patch \
%D%/packages/patches/gnutls-skip-trust-store-test.patch \ %D%/packages/patches/gnutls-skip-trust-store-test.patch \

View File

@ -66,21 +66,20 @@ GNU/Hurd."
version ".tar.gz")) version ".tar.gz"))
(define-public gnumach-headers (define-public gnumach-headers
(let ((commit "097f9cf735ffa1212b828682ad92f0f6c5f1c552")
(revision "1"))
(package (package
(name "gnumach-headers") (name "gnumach-headers")
(version (git-version "1.8" revision commit)) (version "1.8+git20220827") ;; This is an upstream tag
(source (source
(origin (origin
(method git-fetch) (method git-fetch)
(uri (git-reference (uri (git-reference
(url "https://git.savannah.gnu.org/git/hurd/gnumach.git") (url "https://git.savannah.gnu.org/git/hurd/gnumach.git")
(commit commit))) (commit (string-append "v" version))))
(file-name (git-file-name "gnumach" version)) (file-name (git-file-name "gnumach" version))
(sha256 (sha256
(base32 (base32
"0q36z7k02bykrld90zaxbhyzxlmwlqqs4divgir6ix38zsp6icqk")))) "07qlaf8vw029y7xdnhjyiiyn788zjzwmyzj79inz7idpswqsnyhf"))
(patches (search-patches "gnumach-add-missing-const_mach_port_name_array_t-type.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments
`(#:phases `(#:phases
@ -106,7 +105,7 @@ GNU/Hurd."
(synopsis "GNU Mach kernel headers") (synopsis "GNU Mach kernel headers")
(description (description
"Headers of the GNU Mach kernel.") "Headers of the GNU Mach kernel.")
(license gpl2+)))) (license gpl2+)))
(define-public mig (define-public mig
(package (package

View File

@ -0,0 +1,32 @@
From 17335d49a3c9e866a81abc051420d73a59d669bf Mon Sep 17 00:00:00 2001
Message-Id: <17335d49a3c9e866a81abc051420d73a59d669bf.1678745341.git.dev@jpoiret.xyz>
From: Josselin Poiret <dev@jpoiret.xyz>
Date: Sun, 28 Aug 2022 01:17:34 +0200
Subject: [PATCH] Add missing const_mach_port_name_array_t type
From: Samuel Thibault <samuel.thibault@ens-lyon.org>
---
include/mach/port.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/include/mach/port.h b/include/mach/port.h
index 3c226f6c..d25eb0b4 100644
--- a/include/mach/port.h
+++ b/include/mach/port.h
@@ -43,6 +43,7 @@
*/
typedef unsigned int mach_port_name_t;
typedef mach_port_name_t *mach_port_name_array_t;
+typedef const mach_port_name_t *const_mach_port_name_array_t;
/*
* A port is represented
base-commit: 3e1702a65fb3caf50c8d09a1b383b0056a5efc82
prerequisite-patch-id: 4688654277aef235ccd1797a72dce27d52b04616
prerequisite-patch-id: 8f1e7dd6429c15cc8ed1d411dba0a75b6e745236
prerequisite-patch-id: 605553ee086473ad9bc24e59c91d49a12dbf8631
--
2.39.1