gnu: mig: Update to 1.8+git20220827.

* gnu/packages/hurd.scm (mig): Do it.
* gnu/packages/patches/mig-cpu.h-generation.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Josselin Poiret 2023-03-20 23:10:42 +01:00 committed by Ludovic Courtès
parent 5661f75d49
commit c78fd5a25d
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 31 additions and 9 deletions

View File

@ -1542,6 +1542,7 @@ dist_patch_DATA = \
%D%/packages/patches/mia-vtk9.patch \
%D%/packages/patches/mia-vtk92.patch \
%D%/packages/patches/mia-vtk-version.patch \
%D%/packages/patches/mig-cpu.h-generation.patch \
%D%/packages/patches/mingw-w64-6.0.0-gcc.patch \
%D%/packages/patches/mingw-w64-dlltool-temp-prefix.patch \
%D%/packages/patches/mingw-w64-reproducible-gendef.patch \

View File

@ -111,15 +111,20 @@ GNU/Hurd."
(define-public mig
(package
(name "mig")
(version "1.8")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnu/mig/mig-"
version ".tar.gz"))
(sha256
(base32
"1gyda8sq6b379nx01hkpbd85lz39irdvz2b9wbr63gicicx8i706"))))
(version "1.8+git20220827")
(source (origin
(method url-fetch)
;; XXX: Version 2.35 of glibc can only be built with an
;; unreleased version of MiG:
;; <https://lists.gnu.org/archive/html/bug-hurd/2023-03/msg00025.html>.
;; It cannot be fetched from Git though, as the extra dependency
;; on Autoconf/Automake would complicate bootstrapping.
(uri (string-append "mirror://gnu/guix/mirror/mig-"
version ".tar.gz"))
(sha256
(base32
"163d37s9lscd6zxyfng421m9nl857464mgjj90xsrcl5ykbng5p2"))
(patches (search-patches "mig-cpu.h-generation.patch"))))
(build-system gnu-build-system)
;; Flex is needed both at build and run time.
(inputs (list gnumach-headers flex))

View File

@ -0,0 +1,16 @@
Backport MiG commit 73fbf2504ae606dda81372701a67dad6fee0865e:
From: Flavio Cruz <flaviocruz@gmail.com>
Subject: Generate cpu.h with -ffreestanding
--- a/Makefile.in 2023-03-26 23:02:51.384318331 +0200
+++ b/Makefile.in 2023-03-26 23:03:03.300329369 +0200
@@ -1051,7 +1051,7 @@ uninstall-am: uninstall-binSCRIPTS unins
.sym.symc:
$(AWK_V) $(AWK) -f $(srcdir)/gensym.awk $< > $@
.symc.symo:
- $(AM_V_CC) $(TARGET_CC) -S $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -x c -o $@ $<
+ $(AM_V_CC) $(TARGET_CC) -S $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -ffreestanding -x c -o $@ $<
.symo.h:
$(AM_V_GEN) sed -e '/^[^*].*$$/d' -e 's/^[*]/#define/' -e 's/mAgIc[^-0-9]*//' \
$< > $@