1
0
Fork 0
flewkey-overlay/dev-libs/libcyaml/libcyaml-1.3.1.ebuild

30 lines
629 B
Bash

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/tlsa/libcyaml.git"
else
SRC_URI="https://github.com/tlsa/libcyaml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
DESCRIPTION="C library for reading and writing YAML"
HOMEPAGE="https://github.com/tlsa/libcyaml/"
LICENSE="ISC"
SLOT="0"
DEPEND=""
RDEPEND="${DEPEND}"
BDEPEND=""
src_compile() {
emake VARIANT=release
}
src_install() {
emake DESTDIR="${D}" PREFIX="/usr" LIBDIR="$(get_libdir)" VARIANT=release install
}