23 lines
675 B
Plaintext
23 lines
675 B
Plaintext
--- ./lib/Makefile.SH.orig Wed Jun 7 23:33:02 2000
|
|
+++ ./lib/Makefile.SH Sat Apr 19 16:41:15 2003
|
|
@@ -157,6 +157,7 @@
|
|
$(RANLIB) $@
|
|
|
|
install:: libwais.a
|
|
+ if test ! -d $(PRIVLIB); then mkdir $(PRIVLIB); else true; fi
|
|
$(INSTALL) -c -m 644 libwais.a $(PRIVLIB)
|
|
$(RANLIB) $(PRIVLIB)/libwais.a
|
|
chmod 444 $(PRIVLIB)/libwais.a
|
|
@@ -186,9 +187,10 @@
|
|
-perl $(MKINC) $(CFLAGS) $(EINC) > wais.h
|
|
|
|
install:: wais.h
|
|
+ if test ! -d $(PRIVINC); then mkdir $(PRIVINC); else true; fi
|
|
@case '${MFLAGS}' in *[i]*) set +e;; esac; \
|
|
for i in wais.h; do \
|
|
- (set -x; $(INSTALL) -c -m 664 $$i $(PRIVINC)); \
|
|
+ (set -x; $(INSTALL) -c -m 644 $$i $(PRIVINC)); \
|
|
done
|
|
|
|
deinstall::
|