Don't install the wais.h header mode 664

This commit is contained in:
Kris Kennaway 2003-04-19 23:41:53 +00:00
parent 9dfccaf13c
commit 9af4200221
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=79325
2 changed files with 9 additions and 5 deletions

View File

@ -29,7 +29,7 @@ MAN3= ftw.3 regexp.3 scandir.3
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500035
BROKEN= "Does not compile on 5.0"
#BROKEN= "Does not compile on 5.0"
.endif
post-extract:

View File

@ -1,5 +1,5 @@
--- lib/Makefile.SH.orig Tue Oct 5 01:46:11 1999
+++ lib/Makefile.SH Tue Oct 5 02:00:50 1999
--- ./lib/Makefile.SH.orig Wed Jun 7 23:33:02 2000
+++ ./lib/Makefile.SH Sat Apr 19 16:41:15 2003
@@ -157,6 +157,7 @@
$(RANLIB) $@
@ -8,11 +8,15 @@
$(INSTALL) -c -m 644 libwais.a $(PRIVLIB)
$(RANLIB) $(PRIVLIB)/libwais.a
chmod 444 $(PRIVLIB)/libwais.a
@@ -188,6 +189,7 @@
@@ -186,9 +187,10 @@
-perl $(MKINC) $(CFLAGS) $(EINC) > wais.h
install:: wais.h
+ if test ! -d $(PRIVINC); then mkdir $(PRIVINC); else true; fi
@case '${MFLAGS}' in *[i]*) set +e;; esac; \
for i in wais.h; do \
(set -x; $(INSTALL) -c -m 664 $$i $(PRIVINC)); \
- (set -x; $(INSTALL) -c -m 664 $$i $(PRIVINC)); \
+ (set -x; $(INSTALL) -c -m 644 $$i $(PRIVINC)); \
done
deinstall::