freebsd-ports/databases/firebird30-server/files/patch-extern_cloop_Makefile
Muhammad Moinur Rahman 54ce503f0a databases/firebird30-*: Fix consumers build
After firebird25-* was removed from the tree firebird30-* bacem the new
default. And some consumers of firebird started failing to build with
the error "/usr/local/include/ibase.h:6:10: fatal error:
'../jrd/ibase.h' file not found".

In previous the src headers files were installed which were not
sanitized and required other header files from the source tree. This
patch properly installs the sanitized header files and fixes the
consumer builds.

While I am here fix the patches to be makepatch compatible.

Approved by:	portmgr(just-fix-it)
2023-01-01 01:43:51 +01:00

24 lines
749 B
Plaintext

--- extern/cloop/Makefile.orig 2022-06-07 08:18:52 UTC
+++ extern/cloop/Makefile
@@ -6,7 +6,7 @@ TARGET := release
CC := $(CC)
CXX := $(CXX)
-LD := $(CXX)
+LD := $(CXX) $(LDFLAGS)
SRC_DIR := src
BUILD_DIR := build
@@ -27,8 +27,9 @@ SRCS_CPP := $(foreach sdir,$(SRC_DIRS),$(wildcard $(sd
OBJS_C := $(patsubst $(SRC_DIR)/%.c,$(OBJ_DIR)/%.o,$(SRCS_C))
OBJS_CPP := $(patsubst $(SRC_DIR)/%.cpp,$(OBJ_DIR)/%.o,$(SRCS_CPP))
-C_FLAGS := -ggdb -fPIC -MMD -MP -W -Wall -Wno-unused-parameter
-CXX_FLAGS := $(C_FLAGS)
+COMMON_C_FLAGS := -ggdb -fPIC -MMD -MP -W -Wall -Wno-unused-parameter
+C_FLAGS := $(COMMON_C_FLAGS) $(CFLAGS) $(CPPFLAGS)
+CXX_FLAGS := $(COMMON_C_FLAGS) $(CXXFLAGS) $(CPPFLAGS)
FPC_FLAGS := -Mdelphi
ifeq ($(TARGET),release)