databases/firebird30-*: Fix consumers build

After firebird25-* was removed from the tree firebird30-* bacem the new
default. And some consumers of firebird started failing to build with
the error "/usr/local/include/ibase.h:6:10: fatal error:
'../jrd/ibase.h' file not found".

In previous the src headers files were installed which were not
sanitized and required other header files from the source tree. This
patch properly installs the sanitized header files and fixes the
consumer builds.

While I am here fix the patches to be makepatch compatible.

Approved by:	portmgr(just-fix-it)
This commit is contained in:
Muhammad Moinur Rahman 2023-01-01 01:43:51 +01:00
parent 726250273b
commit 54ce503f0a
13 changed files with 33 additions and 55 deletions

View File

@ -1,6 +1,6 @@
PORTNAME= firebird
PORTVERSION= 3.0.10
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES?= databases
MASTER_SITES= https://github.com/FirebirdSQL/${PORTNAME}/releases/download/v${PORTVERSION}/
PKGNAMESUFFIX?= ${PORTVERSION:R:S/.//}-server
@ -96,7 +96,7 @@ CONFIGURE_ENV+= ac_cv_lib_edit_readline="yes"
USE_LDCONFIG= yes
CLIENT_BIN= gpre isql-fb qli
CLIENT_HEADER= extlib/ib_util.h include/ibase.h include/iberror.h yvalve/perf.h
CLIENT_HEADER= ib_util.h ibase.h iberror.h perf.h
OPTIONS_DEFINE= DOCS
@ -120,7 +120,7 @@ CFLAGS+= -DAMD64
USERS= ${PORTNAME}
GROUPS= ${USERS}
MAKE_ENV+= IsServer=Y
#MAKE_ENV+= IsServer=Y
.endif
post-patch:
@ -177,12 +177,12 @@ do-install:
${LN} -fs libfbclient.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libfbclient.so
@${MKDIR} ${STAGEDIR}${PREFIX}/include/firebird
${INSTALL_DATA} ${CLIENT_HEADER:S!^!${WRKSRC}/src/!} ${STAGEDIR}${PREFIX}/include
${INSTALL_DATA} ${CLIENT_HEADER:S!^!${WRKSRC}/gen/Release/firebird/include/!} ${STAGEDIR}${PREFIX}/include
@cd ${WRKSRC}/src/include/firebird && \
@cd ${WRKSRC}/gen/Release/firebird/include/firebird && \
${FIND} * -type d -exec ${MKDIR} "${STAGEDIR}${PREFIX}/include/firebird/{}" \;
@cd ${WRKSRC}/src/include/firebird && \
@cd ${WRKSRC}/gen/Release/firebird/include/firebird && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${PREFIX}/include/firebird/{}" \;
@${MKDIR} ${STAGEDIR}${DATADIR}

View File

@ -1,12 +1,11 @@
--- builds/install/misc/firebird.conf.in.orig 2020-10-12 00:02:22 UTC
--- builds/install/misc/firebird.conf.in.orig 2022-06-07 08:18:52 UTC
+++ builds/install/misc/firebird.conf.in
@@ -189,7 +189,7 @@
#
# Type: string (special format)
#
-#UdfAccess = Restrict UDF
+UdfAccess = Restrict %%PREFIX%%/libexec/firebird/udf
+UdfAccess = Restrict /usr/local/libexec/firebird/udf
# ----------------------------

View File

@ -1,6 +1,6 @@
--- builds/posix/Makefile.in 2020-10-20 03:40:05.000000000 -0500
+++ builds/posix/Makefile.in 2021-06-25 00:25:25.389776000 -0500
@@ -186,16 +186,18 @@
--- builds/posix/Makefile.in.orig 2022-06-07 08:18:52 UTC
+++ builds/posix/Makefile.in
@@ -191,16 +191,16 @@ master_process:
$(MAKE) preliminaryCheck
$(MAKE) boot
$(MAKE) yvalve
@ -10,10 +10,8 @@
$(MAKE) ids
endif
- $(MAKE) engine
+ifeq ($(IsServer), Y)
$(MAKE) fbintl
$(MAKE) utilities
+endif
# Now having ready such useful tools as gbak and isql, we may restore / create
# required databases and switch to full-featured gpre
- $(MAKE) gpre
@ -21,14 +19,3 @@
# Pay attention - after build force gpre_current to point to gpre
# even if gpre itself was not rebuilt
-$(RM) $(GPRE_CURRENT)
@@ -204,8 +206,10 @@
# In developer mode we must regenerate various files in include/gen
$(MAKE) codes
endif
+ifeq ($(IsServer), Y)
$(MAKE) plugins
$(MAKE) examples
+endif
$(MAKE) rest

View File

@ -1,4 +1,4 @@
--- builds/posix/Makefile.in.plugins_examples.orig 2021-03-27 11:14:37 UTC
--- builds/posix/Makefile.in.plugins_examples.orig 2022-06-07 08:18:52 UTC
+++ builds/posix/Makefile.in.plugins_examples
@@ -99,7 +99,7 @@ AllObjects += $(CA_Objects)
crypt_app: $(CRYPT_APP)
@ -9,4 +9,3 @@
include $(ROOT)/gen/make.shared.targets

View File

@ -1,4 +1,4 @@
--- builds/posix/empty.vers.orig 2020-10-12 00:02:22 UTC
--- builds/posix/empty.vers.orig 2022-06-07 08:18:52 UTC
+++ builds/posix/empty.vers
@@ -21,3 +21,5 @@
# Contributor(s): ______________________________________.
@ -6,4 +6,3 @@
main
+__progname
+environ

View File

@ -1,6 +1,6 @@
--- builds/posix/make.defaults 2020-10-20 03:40:05.000000000 -0500
+++ builds/posix/make.defaults 2021-06-25 00:23:49.718147000 -0500
@@ -134,7 +134,7 @@
--- builds/posix/make.defaults.orig 2022-06-07 08:18:52 UTC
+++ builds/posix/make.defaults
@@ -134,7 +134,7 @@ CAS_OPTIONS=@CAS_OPTIONS@
MATHLIB=@MATHLIB@
# switch to make sed edit files inplace
@ -9,7 +9,7 @@
# Default programs and tools to be used in the build process
@@ -144,7 +144,7 @@
@@ -144,7 +144,7 @@ RM_R= rm -rf
CHMOD= chmod
CHMOD_6= chmod 666
CHMOD_7= chmod 777
@ -18,7 +18,7 @@
MV= mv -f
TOUCH= touch
CP= cp
@@ -219,7 +219,7 @@
@@ -219,7 +219,7 @@ vpath %.dll $(LIB)
#LibraryFileName=libfbclient
LibraryFileName=libfbclient
LibraryFullName=$(LibraryFileName).${SHRLIB_EXT}.${FirebirdVersion}
@ -27,7 +27,7 @@
LibraryBaseName=$(LibraryFileName).${SHRLIB_EXT}
LIBFIREBIRD_FULLNAME = $(LIB)/$(LibraryFullName)
@@ -240,7 +240,7 @@
@@ -240,7 +240,7 @@ LIBFBINTL_SO = $(FB_BUILD)/intl/$(LIB_PREFIX)fbintl.$(
ifeq ($(EDITLINE_FLG),Y)
ifeq ($(STD_EDITLINE), true)
@ -36,7 +36,7 @@
else
LIBEDITLINE := $(LIB)/libedit.a
endif
@@ -362,7 +362,7 @@
@@ -362,7 +362,7 @@ CREATE_DB = $(RBIN)/create_db$(EXEC_EXT)
GDS_DROP = $(BIN)/gds_drop$(EXEC_EXT)
FBSVCMGR = $(BIN)/fbsvcmgr$(EXEC_EXT)
FBTRACEMGR = $(BIN)/fbtracemgr$(EXEC_EXT)
@ -45,7 +45,7 @@
NBACKUP = $(BIN)/nbackup$(EXEC_EXT)
LOCKPRINT = $(BIN)/fb_lock_print$(EXEC_EXT)
GSEC = $(BIN)/gsec$(EXEC_EXT)
@@ -383,13 +383,13 @@
@@ -383,13 +383,13 @@ SECURITY_FDB = $(FIREBIRD)/security3.fdb
QLI = $(BIN)/qli$(EXEC_EXT)
# From isql

View File

@ -1,4 +1,4 @@
--- builds/posix/prefix.freebsd.orig 2021-03-27 18:59:05 UTC
--- builds/posix/prefix.freebsd.orig 2022-06-07 08:18:52 UTC
+++ builds/posix/prefix.freebsd
@@ -20,5 +20,14 @@
@ -17,4 +17,3 @@
+%/array.o %/blob.o %/alice_meta.o %/restore.o %/backup.o: COMMON_FLAGS += -Wno-narrowing
+%/OdsDetection.o %/dba.o: COMMON_FLAGS += -Wno-narrowing
+

View File

@ -1,4 +1,4 @@
--- builds/posix/prefix.freebsd_amd64.orig 2020-10-20 08:40:05 UTC
--- builds/posix/prefix.freebsd_amd64.orig 2022-06-07 08:18:52 UTC
+++ builds/posix/prefix.freebsd_amd64
@@ -20,5 +20,13 @@
@ -16,4 +16,3 @@
+# These files are generated incorrectly (e.g. array.epp => array.cpp)
+%/array.o %/blob.o %/alice_meta.o %/restore.o %/backup.o: COMMON_FLAGS += -Wno-narrowing
+%/OdsDetection.o %/dba.o: COMMON_FLAGS += -Wno-narrowing

View File

@ -1,4 +1,4 @@
--- extern/btyacc/Makefile.orig 2020-10-12 00:02:22 UTC
--- extern/btyacc/Makefile.orig 2022-06-07 08:18:52 UTC
+++ extern/btyacc/Makefile
@@ -42,7 +42,7 @@ OTHERS = README README.BYACC \
all: $(PROGRAM)
@ -9,4 +9,3 @@
clean:; rm -f $(OBJS)

View File

@ -1,4 +1,4 @@
--- extern/cloop/Makefile 2020-10-12 00:02:22 UTC
--- extern/cloop/Makefile.orig 2022-06-07 08:18:52 UTC
+++ extern/cloop/Makefile
@@ -6,7 +6,7 @@ TARGET := release
@ -9,7 +9,7 @@
SRC_DIR := src
BUILD_DIR := build
@@ -27,8 +27,9 @@ SRCS_CPP := $(foreach sdir,$(SRC_DIRS),$
@@ -27,8 +27,9 @@ SRCS_CPP := $(foreach sdir,$(SRC_DIRS),$(wildcard $(sd
OBJS_C := $(patsubst $(SRC_DIR)/%.c,$(OBJ_DIR)/%.o,$(SRCS_C))
OBJS_CPP := $(patsubst $(SRC_DIR)/%.cpp,$(OBJ_DIR)/%.o,$(SRCS_CPP))
@ -21,4 +21,3 @@
FPC_FLAGS := -Mdelphi
ifeq ($(TARGET),release)

View File

@ -1,4 +1,4 @@
--- src/common/os/posix/SyncSignals.cpp.orig 2020-10-12 00:02:22 UTC
--- src/common/os/posix/SyncSignals.cpp.orig 2022-06-07 08:18:52 UTC
+++ src/common/os/posix/SyncSignals.cpp
@@ -54,9 +54,6 @@
#include <errno.h>
@ -10,4 +10,3 @@
namespace {

View File

@ -1,5 +1,5 @@
--- src/jrd/os/posix/unix.cpp 2021-06-22 00:38:07.434896000 -0500
+++ src/jrd/os/posix/unix.cpp 2021-06-22 00:43:54.988645000 -0500
--- src/jrd/os/posix/unix.cpp.orig 2022-06-07 08:18:52 UTC
+++ src/jrd/os/posix/unix.cpp
@@ -56,6 +56,13 @@
#include <linux/fs.h>
#endif
@ -14,7 +14,7 @@
#endif //SUPPORT_RAW_DEVICES
#include "../jrd/jrd.h"
@@ -495,7 +502,7 @@
@@ -496,7 +503,7 @@ ULONG PIO_get_number_of_pages(const jrd_file* file, co
// Looks like any OS needs own ioctl() to determine raw device size
#undef HAS_RAW_SIZE

View File

@ -1,6 +1,6 @@
--- src/remote/inet.cpp.orig 2020-10-20 08:40:05 UTC
--- src/remote/inet.cpp.orig 2022-06-07 08:18:52 UTC
+++ src/remote/inet.cpp
@@ -962,7 +962,7 @@ rem_port* INET_connect(const TEXT* name,
@@ -960,7 +960,7 @@ rem_port* INET_connect(const TEXT* name,
gai_hints.ai_family = ((host.hasData() || !ipv6) ? AF_UNSPEC : AF_INET6);
gai_hints.ai_socktype = SOCK_STREAM;
@ -9,7 +9,7 @@
gai_hints.ai_protocol = SOL_TCP;
#else
gai_hints.ai_protocol = IPPROTO_TCP;
@@ -1176,6 +1176,12 @@ static rem_port* listener_socket(rem_port* port, USHOR
@@ -1174,6 +1174,12 @@ static rem_port* listener_socket(rem_port* port, USHOR
setFastLoopbackOption(port);
inet_ports->registerPort(port);
@ -22,4 +22,3 @@
if (flag & SRVR_multi_client)
{