freebsd-ports/devel/opendht/files/patch-CMakeLists.txt
Adam Weinberger 07b61611e9 multiple: Fix msgpack cmake package name
msgpack-c's cmake package name changed to `msgpackc'
msgpack-cxx's cmake package named to `msgpackc-cxx' because I guess
that's how msgpack's developers roll.

Fix the two instances I could find where a CMakeLists.txt was looking
for msgpack through its cmake package name. There are probably others.
2023-01-10 10:13:15 -07:00

23 lines
970 B
Plaintext

--- CMakeLists.txt.orig 2023-01-10 16:45:50 UTC
+++ CMakeLists.txt
@@ -61,7 +61,7 @@ if (NOT MSVC)
pkg_search_module (Nettle REQUIRED nettle)
check_include_file_cxx(msgpack.hpp HAVE_MSGPACKCXX)
if (NOT HAVE_MSGPACKCXX)
- find_package (msgpack REQUIRED)
+ find_package (msgpackc-cxx REQUIRED)
endif()
if (OPENDHT_TOOLS)
find_package (Readline 6 REQUIRED)
@@ -91,8 +91,8 @@ if (NOT MSVC)
endif()
if (OPENDHT_PROXY_OPENSSL)
# https://cmake.org/cmake/help/latest/module/FindOpenSSL.html
- pkg_search_module(OPENSSL REQUIRED openssl)
- if (OPENSSL_FOUND)
+ #pkg_search_module(OPENSSL REQUIRED openssl)
+ if (TRUE OR OPENSSL_FOUND)
message(STATUS "Found OpenSSL ${OPENSSL_VERSION} ${OPENSSL_INCLUDE_DIRS}")
include_directories(SYSTEM ${OPENSSL_INCLUDE_DIRS})
link_directories (${OPENSSL_LIBRARY_DIRS})