multiple: Fix msgpack cmake package name

msgpack-c's cmake package name changed to `msgpackc'
msgpack-cxx's cmake package named to `msgpackc-cxx' because I guess
that's how msgpack's developers roll.

Fix the two instances I could find where a CMakeLists.txt was looking
for msgpack through its cmake package name. There are probably others.
This commit is contained in:
Adam Weinberger 2023-01-10 10:09:52 -07:00
parent e494d5c395
commit 07b61611e9
2 changed files with 12 additions and 1 deletions

View File

@ -1,5 +1,14 @@
--- CMakeLists.txt.orig 2022-11-06 06:47:13 UTC
--- CMakeLists.txt.orig 2023-01-10 16:45:50 UTC
+++ CMakeLists.txt
@@ -61,7 +61,7 @@ if (NOT MSVC)
pkg_search_module (Nettle REQUIRED nettle)
check_include_file_cxx(msgpack.hpp HAVE_MSGPACKCXX)
if (NOT HAVE_MSGPACKCXX)
- find_package (msgpack REQUIRED)
+ find_package (msgpackc-cxx REQUIRED)
endif()
if (OPENDHT_TOOLS)
find_package (Readline 6 REQUIRED)
@@ -91,8 +91,8 @@ if (NOT MSVC)
endif()
if (OPENDHT_PROXY_OPENSSL)

View File

@ -30,6 +30,8 @@ post-patch: # correct paths of test data to be accessible to the test executable
s|\.\./submodules/mmtf_spec|${WRKSRC}/submodules/mmtf_spec|g; \
s|\.\./temporary_test_data|${WRKSRC}/temporary_test_data|g' \
${WRKSRC}/tests/mmtf_tests.cpp
@${REINPLACE_CMD} -e '/find_package/s|msgpack|msgpackc-cxx|' \
${WRKSRC}/CMakeLists.txt
do-install:
cd ${WRKSRC} && ${COPYTREE_SHARE} include ${STAGEDIR}${PREFIX}