devel/caf: Merge into devel/actor-framework and remove

Reported by:	vanilla@fatpipi.com; fluffy@
This commit is contained in:
Yuri Victorovich 2023-01-08 02:03:14 -08:00
parent d726e22a21
commit f8cdacd4b6
9 changed files with 21 additions and 620 deletions

1
MOVED
View File

@ -17747,3 +17747,4 @@ textproc/elasticsearch6||2023-01-01|Has expired: No longer maintained and suppor
japanese/ja-tex-xdvik|print/tex-xdvik|2023-01-02|pTeX support has been integrated japanese/ja-tex-xdvik|print/tex-xdvik|2023-01-02|pTeX support has been integrated
math/cvc4|math/cvc5|2023-01-03|CVC4 was succeeded by CVC5 math/cvc4|math/cvc5|2023-01-03|CVC4 was succeeded by CVC5
math/cvc3|math/cvc5|2023-01-04|CVC3 was succeeded by CVC4 and CVC5 math/cvc3|math/cvc5|2023-01-04|CVC3 was succeeded by CVC4 and CVC5
devel/caf|devel/actor-framework|2023-01-08|Merge duplicates into devel/actor-framework that is a full software name

View File

@ -315,7 +315,6 @@
SUBDIR += byaccj SUBDIR += byaccj
SUBDIR += c2mdoc SUBDIR += c2mdoc
SUBDIR += c4core SUBDIR += c4core
SUBDIR += caf
SUBDIR += calibrator SUBDIR += calibrator
SUBDIR += caliper SUBDIR += caliper
SUBDIR += capnproto SUBDIR += capnproto

View File

@ -1,5 +1,6 @@
PORTNAME= actor-framework PORTNAME= actor-framework
DISTVERSION= 0.19.0-rc.1 DISTVERSION= 0.19.0-rc.1
PORTREVISION= 1
CATEGORIES= devel CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org MAINTAINER= yuri@FreeBSD.org
@ -17,4 +18,23 @@ USE_GITHUB= yes
CMAKE_OFF= CAF_ENABLE_TESTING CMAKE_OFF= CAF_ENABLE_TESTING
CMAKE_TESTING_ON= CAF_ENABLE_TESTING CMAKE_TESTING_ON= CAF_ENABLE_TESTING
OPTIONS_DEFINE= DEBUG
OPTIONS_RADIO= LOG_LEVEL
OPTIONS_RADIO_LOG_LEVEL= LOG_LEVEL_ERROR LOG_LEVEL_WARN LOG_LEVEL_INFO LOG_LEVEL_DEBUG LOG_LEVEL_TRACE
DEBUG_DESC= Build with extra runtime assertions
DEBUG_CMAKE_BOOL= CAF_ENABLE_RUNTIME_CHECKS
LOG_LEVEL_DEBUG_DESC= Use log level DEBUG for console output
LOG_LEVEL_ERROR_DESC= Use log level ERROR for console output
LOG_LEVEL_INFO_DESC= Use log level INFO for console output
LOG_LEVEL_TRACE_DESC= Use log level TRACE for console output
LOG_LEVEL_WARN_DESC= Use log level WARN for console output
LOG_LEVEL_ERROR_CMAKE_ON= -DCAF_LOG_LEVEL:STRING=ERROR
LOG_LEVEL_WARN_CMAKE_ON= -DCAF_LOG_LEVEL:STRING=WARN
LOG_LEVEL_INFO_CMAKE_ON= -DCAF_LOG_LEVEL:STRING=INFO
LOG_LEVEL_DEBUG_CMAKE_ON= -DCAF_LOG_LEVEL:STRING=DEBUG
LOG_LEVEL_TRACE_CMAKE_ON= -DCAF_LOG_LEVEL:STRING=TRACE
.include <bsd.port.mk> .include <bsd.port.mk>

View File

@ -1,52 +0,0 @@
PORTNAME= caf
PORTVERSION= 0.18.6
CATEGORIES= devel
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ actor framework
WWW= https://www.actor-framework.org
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake compiler:c++11-lang ssl
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= actor-framework
GH_PROJECT= ${GH_ACCOUNT}
OPTIONS_DEFINE= DEBUG TEST STATIC
OPTIONS_RADIO= LOG_LEVEL
OPTIONS_RADIO_LOG_LEVEL= LOG_LEVEL_ERROR LOG_LEVEL_WARN LOG_LEVEL_INFO LOG_LEVEL_DEBUG LOG_LEVEL_TRACE
OPTIONS_SUB= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}
LOG_LEVEL_DEBUG_DESC= Use log level DEBUG for console output
LOG_LEVEL_ERROR_DESC= Use log level ERROR for console output
LOG_LEVEL_INFO_DESC= Use log level INFO for console output
LOG_LEVEL_TRACE_DESC= Use log level TRACE for console output
LOG_LEVEL_WARN_DESC= Use log level WARN for console output
STATIC_DESC= Additionally build static version of library
TEST_DESC= Build with unit tests
TEST_TARGET= test
CXXFLAGS+= -std=c++11 -Wextra -Wall -pedantic
LDFLAGS+= -pthread
# Until we cannot automatically disentangle examples from other binaries, we do
# not support an EXAMPLES option. We also disable a few components that are
# still quite experimental.
CMAKE_ARGS+= -DCAF_NO_EXAMPLES:BOOL=yes -DCAF_NO_OPENCL:BOOL=yes
DEBUG_CMAKE_ON= -DCAF_ENABLE_RUNTIME_CHECKS:BOOL=yes
STATIC_CMAKE_ON= -DCAF_BUILD_STATIC:BOOL=yes
TEST_CMAKE_OFF= -DCAF_NO_UNIT_TESTS:BOOL=yes
LOG_LEVEL_ERROR_CMAKE_ON= -DCAF_LOG_LEVEL:STRING=ERROR
LOG_LEVEL_WARN_CMAKE_ON= -DCAF_LOG_LEVEL:STRING=WARN
LOG_LEVEL_INFO_CMAKE_ON= -DCAF_LOG_LEVEL:STRING=INFO
LOG_LEVEL_DEBUG_CMAKE_ON= -DCAF_LOG_LEVEL:STRING=DEBUG
LOG_LEVEL_TRACE_CMAKE_ON= -DCAF_LOG_LEVEL:STRING=TRACE
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
TIMESTAMP = 1648323549
SHA256 (actor-framework-actor-framework-0.18.6_GH0.tar.gz) = c2ead63a0322d992fea8813a7f7d15b4d16cbb8bbe026722f2616a79109b91cc
SIZE (actor-framework-actor-framework-0.18.6_GH0.tar.gz) = 2824066

View File

@ -1,12 +0,0 @@
--- libcaf_io/src/io/network/default_multiplexer.cpp.orig 2020-04-05 00:30:36 UTC
+++ libcaf_io/src/io/network/default_multiplexer.cpp
@@ -59,6 +59,9 @@
# include <ws2ipdef.h>
# include <ws2tcpip.h>
#else
+# ifdef __FreeBSD__
+# include <sys/types.h>
+# endif
# include <arpa/inet.h>
# include <cerrno>
# include <fcntl.h>

View File

@ -1,12 +0,0 @@
--- libcaf_io/src/io/network/native_socket.cpp.orig 2020-04-05 00:18:01 UTC
+++ libcaf_io/src/io/network/native_socket.cpp
@@ -44,6 +44,9 @@
# include <ws2ipdef.h>
# include <ws2tcpip.h>
#else
+# ifdef __FreeBSD__
+# include <sys/types.h>
+# endif
# include <arpa/inet.h>
# include <cerrno>
# include <fcntl.h>

View File

@ -1,14 +0,0 @@
An Open Source Implementation of the Actor Model in C++.
Actors in CAF are lightweight, consist of only a few hundred bytes, and
are cooperatively managed by a state-of-the-art, work-stealing
scheduler. You can spawn millions of actors if you want to.
CAF offers a network-transparent message passing. Actors can talk to
each other, no matter where they've been spawned. You do the hard part
of implementing your app, CAF takes care of the low-level side of
things. CAF allows you to transparently connect actors running on
different machines and OSes via the network. It integrates multiple
computing devices such as multi-core CPUs, GPGPUs, and even embedded
hardware. You can also create message passing interface for your OpenCL
backends.

View File

@ -1,526 +0,0 @@
include/caf/abstract_actor.hpp
include/caf/abstract_channel.hpp
include/caf/abstract_group.hpp
include/caf/action.hpp
include/caf/actor.hpp
include/caf/actor_addr.hpp
include/caf/actor_cast.hpp
include/caf/actor_clock.hpp
include/caf/actor_companion.hpp
include/caf/actor_config.hpp
include/caf/actor_control_block.hpp
include/caf/actor_factory.hpp
include/caf/actor_ostream.hpp
include/caf/actor_pool.hpp
include/caf/actor_profiler.hpp
include/caf/actor_proxy.hpp
include/caf/actor_registry.hpp
include/caf/actor_storage.hpp
include/caf/actor_system.hpp
include/caf/actor_system_config.hpp
include/caf/actor_traits.hpp
include/caf/after.hpp
include/caf/all.hpp
include/caf/allowed_unsafe_message_type.hpp
include/caf/atom.hpp
include/caf/attach_continuous_stream_source.hpp
include/caf/attach_continuous_stream_stage.hpp
include/caf/attach_stream_sink.hpp
include/caf/attach_stream_source.hpp
include/caf/attach_stream_stage.hpp
include/caf/attachable.hpp
include/caf/behavior.hpp
include/caf/behavior_policy.hpp
include/caf/binary_deserializer.hpp
include/caf/binary_serializer.hpp
include/caf/blocking_actor.hpp
include/caf/broadcast_downstream_manager.hpp
include/caf/buffered_downstream_manager.hpp
include/caf/byte.hpp
include/caf/byte_address.hpp
include/caf/byte_buffer.hpp
include/caf/byte_span.hpp
include/caf/caf_main.hpp
include/caf/callback.hpp
include/caf/catch_all.hpp
include/caf/check_typed_input.hpp
include/caf/composed_type.hpp
include/caf/config.hpp
include/caf/config_option.hpp
include/caf/config_option_adder.hpp
include/caf/config_option_set.hpp
include/caf/config_value.hpp
include/caf/config_value_reader.hpp
include/caf/config_value_writer.hpp
include/caf/const_typed_message_view.hpp
include/caf/cow_tuple.hpp
include/caf/credit_controller.hpp
include/caf/decorator/sequencer.hpp
include/caf/decorator/splitter.hpp
include/caf/deduce_mpi.hpp
include/caf/deep_to_string.hpp
include/caf/default_attachable.hpp
include/caf/default_downstream_manager.hpp
include/caf/default_enum_inspect.hpp
include/caf/default_sum_type_access.hpp
include/caf/defaults.hpp
include/caf/delegated.hpp
include/caf/deserializer.hpp
include/caf/detail/abstract_worker.hpp
include/caf/detail/abstract_worker_hub.hpp
include/caf/detail/algorithms.hpp
include/caf/detail/append_hex.hpp
include/caf/detail/append_percent_encoded.hpp
include/caf/detail/apply_args.hpp
include/caf/detail/arg_wrapper.hpp
include/caf/detail/as_mutable_ref.hpp
include/caf/detail/assign_inspector_try_result.hpp
include/caf/detail/base64.hpp
include/caf/detail/behavior_impl.hpp
include/caf/detail/behavior_stack.hpp
include/caf/detail/blocking_behavior.hpp
include/caf/detail/bounds_checker.hpp
include/caf/detail/build_config.hpp
include/caf/detail/call_cfun.hpp
include/caf/detail/cas_weak.hpp
include/caf/detail/comparable.hpp
include/caf/detail/config_consumer.hpp
include/caf/detail/consumer.hpp
include/caf/detail/core_export.hpp
include/caf/detail/default_invoke_result_visitor.hpp
include/caf/detail/delegate_serialize.hpp
include/caf/detail/dispose_on_call.hpp
include/caf/detail/double_ended_queue.hpp
include/caf/detail/enqueue_result.hpp
include/caf/detail/functor_attachable.hpp
include/caf/detail/gcd.hpp
include/caf/detail/get_mac_addresses.hpp
include/caf/detail/get_process_id.hpp
include/caf/detail/get_root_uuid.hpp
include/caf/detail/glob_match.hpp
include/caf/detail/group_tunnel.hpp
include/caf/detail/ieee_754.hpp
include/caf/detail/implicit_conversions.hpp
include/caf/detail/init_fun_factory.hpp
include/caf/detail/int_list.hpp
include/caf/detail/invoke_result_visitor.hpp
include/caf/detail/io_export.hpp
include/caf/detail/is_complete.hpp
include/caf/detail/is_one_of.hpp
include/caf/detail/json.hpp
include/caf/detail/latch.hpp
include/caf/detail/limited_vector.hpp
include/caf/detail/local_group_module.hpp
include/caf/detail/log_level.hpp
include/caf/detail/make_meta_object.hpp
include/caf/detail/make_unique.hpp
include/caf/detail/mask_bits.hpp
include/caf/detail/message_builder_element.hpp
include/caf/detail/message_data.hpp
include/caf/detail/meta_object.hpp
include/caf/detail/monotonic_buffer_resource.hpp
include/caf/detail/move_if_not_ptr.hpp
include/caf/detail/mtl_util.hpp
include/caf/detail/network_order.hpp
include/caf/detail/offset_at.hpp
include/caf/detail/openssl_export.hpp
include/caf/detail/optional_message_visitor.hpp
include/caf/detail/overload.hpp
include/caf/detail/padded_size.hpp
include/caf/detail/parse.hpp
include/caf/detail/parser/add_ascii.hpp
include/caf/detail/parser/ascii_to_int.hpp
include/caf/detail/parser/chars.hpp
include/caf/detail/parser/fsm.hpp
include/caf/detail/parser/fsm_undef.hpp
include/caf/detail/parser/is_char.hpp
include/caf/detail/parser/is_digit.hpp
include/caf/detail/parser/read_bool.hpp
include/caf/detail/parser/read_config.hpp
include/caf/detail/parser/read_floating_point.hpp
include/caf/detail/parser/read_ipv4_address.hpp
include/caf/detail/parser/read_ipv6_address.hpp
include/caf/detail/parser/read_number.hpp
include/caf/detail/parser/read_number_or_timespan.hpp
include/caf/detail/parser/read_signed_integer.hpp
include/caf/detail/parser/read_string.hpp
include/caf/detail/parser/read_timespan.hpp
include/caf/detail/parser/read_unsigned_integer.hpp
include/caf/detail/parser/read_uri.hpp
include/caf/detail/parser/sub_ascii.hpp
include/caf/detail/path_state.hpp
include/caf/detail/pp.hpp
include/caf/detail/pretty_type_name.hpp
include/caf/detail/print.hpp
include/caf/detail/private_thread.hpp
include/caf/detail/private_thread_pool.hpp
include/caf/detail/profiled_send.hpp
include/caf/detail/prometheus_broker.hpp
include/caf/detail/pseudo_tuple.hpp
include/caf/detail/raw_access.hpp
include/caf/detail/remote_group_module.hpp
include/caf/detail/ringbuffer.hpp
include/caf/detail/ripemd_160.hpp
include/caf/detail/safe_equal.hpp
include/caf/detail/scope_guard.hpp
include/caf/detail/select_all.hpp
include/caf/detail/select_integer_type.hpp
include/caf/detail/serialized_size.hpp
include/caf/detail/set_thread_name.hpp
include/caf/detail/shared_spinlock.hpp
include/caf/detail/size_based_credit_controller.hpp
include/caf/detail/socket_guard.hpp
include/caf/detail/spawn_fwd.hpp
include/caf/detail/spawnable.hpp
include/caf/detail/split_join.hpp
include/caf/detail/squashed_int.hpp
include/caf/detail/stream_distribution_tree.hpp
include/caf/detail/stream_sink_driver_impl.hpp
include/caf/detail/stream_sink_impl.hpp
include/caf/detail/stream_source_driver_impl.hpp
include/caf/detail/stream_source_impl.hpp
include/caf/detail/stream_stage_driver_impl.hpp
include/caf/detail/stream_stage_impl.hpp
include/caf/detail/stringification_inspector.hpp
include/caf/detail/sync_request_bouncer.hpp
include/caf/detail/tail_argument_token.hpp
include/caf/detail/tbind.hpp
include/caf/detail/test_actor_clock.hpp
include/caf/detail/thread_safe_actor_clock.hpp
include/caf/detail/tick_emitter.hpp
include/caf/detail/token_based_credit_controller.hpp
include/caf/detail/try_serialize.hpp
include/caf/detail/type_id_list_builder.hpp
include/caf/detail/type_list.hpp
include/caf/detail/type_pair.hpp
include/caf/detail/type_traits.hpp
include/caf/detail/typed_actor_util.hpp
include/caf/detail/unique_function.hpp
include/caf/detail/unordered_flat_map.hpp
include/caf/detail/variant_data.hpp
include/caf/detail/worker_hub.hpp
include/caf/dictionary.hpp
include/caf/disposable.hpp
include/caf/downstream.hpp
include/caf/downstream_manager.hpp
include/caf/downstream_manager_base.hpp
include/caf/downstream_msg.hpp
include/caf/error.hpp
include/caf/error_code.hpp
include/caf/event_based_actor.hpp
include/caf/exec_main.hpp
include/caf/execution_unit.hpp
include/caf/exit_reason.hpp
include/caf/expected.hpp
include/caf/extend.hpp
include/caf/forwarding_actor_proxy.hpp
include/caf/function_view.hpp
include/caf/fused_downstream_manager.hpp
include/caf/fwd.hpp
include/caf/group.hpp
include/caf/group_manager.hpp
include/caf/group_module.hpp
include/caf/hash/fnv.hpp
include/caf/hash/sha1.hpp
include/caf/illegal_message_element.hpp
include/caf/inbound_path.hpp
include/caf/infer_handle.hpp
include/caf/init_global_meta_objects.hpp
include/caf/input_range.hpp
include/caf/inspector_access.hpp
include/caf/inspector_access_base.hpp
include/caf/inspector_access_type.hpp
include/caf/interface_mismatch.hpp
include/caf/intrusive/drr_cached_queue.hpp
include/caf/intrusive/drr_queue.hpp
include/caf/intrusive/fifo_inbox.hpp
include/caf/intrusive/forward_iterator.hpp
include/caf/intrusive/inbox_result.hpp
include/caf/intrusive/lifo_inbox.hpp
include/caf/intrusive/new_round_result.hpp
include/caf/intrusive/singly_linked.hpp
include/caf/intrusive/task_queue.hpp
include/caf/intrusive/task_result.hpp
include/caf/intrusive/wdrr_dynamic_multiplexed_queue.hpp
include/caf/intrusive/wdrr_fixed_multiplexed_queue.hpp
include/caf/intrusive_cow_ptr.hpp
include/caf/intrusive_ptr.hpp
include/caf/invalid_stream.hpp
include/caf/invoke_message_result.hpp
include/caf/io/abstract_broker.hpp
include/caf/io/accept_handle.hpp
include/caf/io/all.hpp
include/caf/io/basp/all.hpp
include/caf/io/basp/connection_state.hpp
include/caf/io/basp/endpoint_context.hpp
include/caf/io/basp/fwd.hpp
include/caf/io/basp/header.hpp
include/caf/io/basp/instance.hpp
include/caf/io/basp/message_queue.hpp
include/caf/io/basp/message_type.hpp
include/caf/io/basp/remote_message_handler.hpp
include/caf/io/basp/routing_table.hpp
include/caf/io/basp/version.hpp
include/caf/io/basp/worker.hpp
include/caf/io/basp_broker.hpp
include/caf/io/broker.hpp
include/caf/io/broker_servant.hpp
include/caf/io/close.hpp
include/caf/io/connect.hpp
include/caf/io/connection_handle.hpp
include/caf/io/connection_helper.hpp
include/caf/io/datagram_handle.hpp
include/caf/io/datagram_servant.hpp
include/caf/io/doorman.hpp
include/caf/io/fwd.hpp
include/caf/io/handle.hpp
include/caf/io/middleman.hpp
include/caf/io/middleman_actor.hpp
include/caf/io/middleman_actor_impl.hpp
include/caf/io/network/acceptor.hpp
include/caf/io/network/acceptor_impl.hpp
include/caf/io/network/acceptor_manager.hpp
include/caf/io/network/datagram_handler.hpp
include/caf/io/network/datagram_handler_impl.hpp
include/caf/io/network/datagram_manager.hpp
include/caf/io/network/datagram_servant_impl.hpp
include/caf/io/network/default_multiplexer.hpp
include/caf/io/network/doorman_impl.hpp
include/caf/io/network/event_handler.hpp
include/caf/io/network/interfaces.hpp
include/caf/io/network/ip_endpoint.hpp
include/caf/io/network/manager.hpp
include/caf/io/network/multiplexer.hpp
include/caf/io/network/native_socket.hpp
include/caf/io/network/operation.hpp
include/caf/io/network/pipe_reader.hpp
include/caf/io/network/protocol.hpp
include/caf/io/network/receive_buffer.hpp
include/caf/io/network/rw_state.hpp
include/caf/io/network/scribe_impl.hpp
include/caf/io/network/stream.hpp
include/caf/io/network/stream_impl.hpp
include/caf/io/network/stream_manager.hpp
include/caf/io/network/test_multiplexer.hpp
include/caf/io/open.hpp
include/caf/io/publish.hpp
include/caf/io/publish_local_groups.hpp
include/caf/io/receive_policy.hpp
include/caf/io/remote_actor.hpp
include/caf/io/remote_group.hpp
include/caf/io/scribe.hpp
include/caf/io/system_messages.hpp
include/caf/io/typed_broker.hpp
include/caf/io/unpublish.hpp
include/caf/ip_address.hpp
include/caf/ip_endpoint.hpp
include/caf/ip_subnet.hpp
include/caf/ipv4_address.hpp
include/caf/ipv4_endpoint.hpp
include/caf/ipv4_subnet.hpp
include/caf/ipv6_address.hpp
include/caf/ipv6_endpoint.hpp
include/caf/ipv6_subnet.hpp
include/caf/is_actor_handle.hpp
include/caf/is_error_code_enum.hpp
include/caf/is_message_sink.hpp
include/caf/is_timeout_or_catch_all.hpp
include/caf/is_typed_actor.hpp
include/caf/json_reader.hpp
include/caf/json_writer.hpp
include/caf/load_inspector.hpp
include/caf/load_inspector_base.hpp
include/caf/local_actor.hpp
include/caf/locks.hpp
include/caf/logger.hpp
include/caf/mailbox_element.hpp
include/caf/make_actor.hpp
include/caf/make_config_option.hpp
include/caf/make_copy_on_write.hpp
include/caf/make_counted.hpp
include/caf/make_message.hpp
include/caf/make_sink_result.hpp
include/caf/make_source_result.hpp
include/caf/make_stage_result.hpp
include/caf/may_have_timeout.hpp
include/caf/message.hpp
include/caf/message_builder.hpp
include/caf/message_handler.hpp
include/caf/message_id.hpp
include/caf/message_priority.hpp
include/caf/mixin/actor_widget.hpp
include/caf/mixin/behavior_changer.hpp
include/caf/mixin/requester.hpp
include/caf/mixin/sender.hpp
include/caf/mixin/subscriber.hpp
include/caf/monitorable_actor.hpp
include/caf/mtl.hpp
include/caf/no_stages.hpp
include/caf/node_id.hpp
include/caf/none.hpp
include/caf/openssl/all.hpp
include/caf/openssl/manager.hpp
include/caf/openssl/middleman_actor.hpp
include/caf/openssl/publish.hpp
include/caf/openssl/remote_actor.hpp
include/caf/openssl/session.hpp
include/caf/openssl/unpublish.hpp
include/caf/optional.hpp
include/caf/others.hpp
include/caf/outbound_path.hpp
include/caf/parser_state.hpp
include/caf/pec.hpp
include/caf/policy/arg.hpp
include/caf/policy/categorized.hpp
include/caf/policy/downstream_messages.hpp
include/caf/policy/normal_messages.hpp
include/caf/policy/scheduler_policy.hpp
include/caf/policy/select_all.hpp
include/caf/policy/select_any.hpp
include/caf/policy/single_response.hpp
include/caf/policy/tcp.hpp
include/caf/policy/udp.hpp
include/caf/policy/unprofiled.hpp
include/caf/policy/upstream_messages.hpp
include/caf/policy/urgent_messages.hpp
include/caf/policy/work_sharing.hpp
include/caf/policy/work_stealing.hpp
include/caf/prohibit_top_level_spawn_marker.hpp
include/caf/proxy_registry.hpp
include/caf/raise_error.hpp
include/caf/ref_counted.hpp
include/caf/replies_to.hpp
include/caf/response_handle.hpp
include/caf/response_promise.hpp
include/caf/response_type.hpp
include/caf/result.hpp
include/caf/resumable.hpp
include/caf/save_inspector.hpp
include/caf/save_inspector_base.hpp
include/caf/scheduled_actor.hpp
include/caf/scheduler.hpp
include/caf/scheduler/abstract_coordinator.hpp
include/caf/scheduler/coordinator.hpp
include/caf/scheduler/profiled_coordinator.hpp
include/caf/scheduler/test_coordinator.hpp
include/caf/scheduler/worker.hpp
include/caf/scoped_actor.hpp
include/caf/scoped_execution_unit.hpp
include/caf/sec.hpp
include/caf/send.hpp
include/caf/serializer.hpp
include/caf/settings.hpp
include/caf/skip.hpp
include/caf/span.hpp
include/caf/spawn_options.hpp
include/caf/stateful_actor.hpp
include/caf/static_visitor.hpp
include/caf/stream.hpp
include/caf/stream_aborter.hpp
include/caf/stream_finalize_trait.hpp
include/caf/stream_manager.hpp
include/caf/stream_priority.hpp
include/caf/stream_sink.hpp
include/caf/stream_sink_driver.hpp
include/caf/stream_sink_trait.hpp
include/caf/stream_slot.hpp
include/caf/stream_source.hpp
include/caf/stream_source_driver.hpp
include/caf/stream_source_trait.hpp
include/caf/stream_stage.hpp
include/caf/stream_stage_driver.hpp
include/caf/stream_stage_trait.hpp
include/caf/string_algorithms.hpp
include/caf/string_view.hpp
include/caf/sum_type.hpp
include/caf/sum_type_access.hpp
include/caf/sum_type_token.hpp
include/caf/system_messages.hpp
include/caf/tag/boxing_type.hpp
include/caf/telemetry/collector/prometheus.hpp
include/caf/telemetry/counter.hpp
include/caf/telemetry/dbl_gauge.hpp
include/caf/telemetry/gauge.hpp
include/caf/telemetry/histogram.hpp
include/caf/telemetry/importer/process.hpp
include/caf/telemetry/int_gauge.hpp
include/caf/telemetry/label.hpp
include/caf/telemetry/label_view.hpp
include/caf/telemetry/metric.hpp
include/caf/telemetry/metric_family.hpp
include/caf/telemetry/metric_family_impl.hpp
include/caf/telemetry/metric_impl.hpp
include/caf/telemetry/metric_registry.hpp
include/caf/telemetry/metric_type.hpp
include/caf/telemetry/timer.hpp
include/caf/term.hpp
include/caf/test/bdd_dsl.hpp
include/caf/test/dsl.hpp
include/caf/test/io_dsl.hpp
include/caf/test/unit_test.hpp
include/caf/test/unit_test_impl.hpp
include/caf/thread_hook.hpp
include/caf/timeout_definition.hpp
include/caf/timespan.hpp
include/caf/timestamp.hpp
include/caf/tracing_data.hpp
include/caf/tracing_data_factory.hpp
include/caf/type_erased_value.hpp
include/caf/type_id.hpp
include/caf/type_id_list.hpp
include/caf/typed_actor.hpp
include/caf/typed_actor_pointer.hpp
include/caf/typed_actor_view.hpp
include/caf/typed_actor_view_base.hpp
include/caf/typed_behavior.hpp
include/caf/typed_event_based_actor.hpp
include/caf/typed_message_view.hpp
include/caf/typed_response_promise.hpp
include/caf/unifyn.hpp
include/caf/unit.hpp
include/caf/unsafe_behavior_init.hpp
include/caf/upstream_msg.hpp
include/caf/uri.hpp
include/caf/uri_builder.hpp
include/caf/uuid.hpp
include/caf/variant.hpp
include/caf/weak_intrusive_ptr.hpp
lib/cmake/CAF/CAFConfig.cmake
lib/cmake/CAF/CAFConfigVersion.cmake
lib/cmake/CAF/CAFTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/CAF/CAFTargets.cmake
lib/libcaf_core.so
lib/libcaf_core.so.%%PORTVERSION%%
lib/libcaf_io.so
lib/libcaf_io.so.%%PORTVERSION%%
lib/libcaf_openssl.so
lib/libcaf_openssl.so.%%PORTVERSION%%
%%DATADIR%%/examples/aout.cpp
%%DATADIR%%/examples/broker/simple_broker.cpp
%%DATADIR%%/examples/broker/simple_http_broker.cpp
%%DATADIR%%/examples/config/read-json.cpp
%%DATADIR%%/examples/custom_type/custom_types_1.cpp
%%DATADIR%%/examples/custom_type/custom_types_2.cpp
%%DATADIR%%/examples/custom_type/custom_types_3.cpp
%%DATADIR%%/examples/custom_type/custom_types_4.cpp
%%DATADIR%%/examples/dynamic_behavior/dining_philosophers.cpp
%%DATADIR%%/examples/dynamic_behavior/skip_messages.cpp
%%DATADIR%%/examples/hello_world.cpp
%%DATADIR%%/examples/message_passing/calculator.cpp
%%DATADIR%%/examples/message_passing/cell.cpp
%%DATADIR%%/examples/message_passing/dancing_kirby.cpp
%%DATADIR%%/examples/message_passing/delegating.cpp
%%DATADIR%%/examples/message_passing/divider.cpp
%%DATADIR%%/examples/message_passing/fan_out_request.cpp
%%DATADIR%%/examples/message_passing/fixed_stack.cpp
%%DATADIR%%/examples/message_passing/promises.cpp
%%DATADIR%%/examples/message_passing/request.cpp
%%DATADIR%%/examples/message_passing/typed_calculator.cpp
%%DATADIR%%/examples/remoting/distributed_calculator.cpp
%%DATADIR%%/examples/remoting/group_chat.cpp
%%DATADIR%%/examples/remoting/group_server.cpp
%%DATADIR%%/examples/remoting/remote_spawn.cpp
%%DATADIR%%/examples/streaming/integer_stream.cpp
%%DATADIR%%/examples/testing/ping_pong.cpp
%%DATADIR%%/tools/caf-run
%%DATADIR%%/tools/caf-vec