This plugin makes particles dance. Very pretty neon colors.

WWW: http://tardyp.free.fr/dancingparticles/

PR:		87471
Submitted by:	Alejandro Pulver <alejandro@varnet.biz>
This commit is contained in:
Marcus Alves Grando 2005-10-16 00:37:09 +00:00
parent b3cd987b53
commit f45f63500e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=145486
7 changed files with 98 additions and 0 deletions

View File

@ -599,6 +599,7 @@
SUBDIR += xmedcon
SUBDIR += xmfract
SUBDIR += xmms-blursk
SUBDIR += xmms-dancingparticles
SUBDIR += xmms-dflowers
SUBDIR += xmms-dscope
SUBDIR += xmms-dspectogram

View File

@ -0,0 +1,34 @@
# New ports collection makefile for: xmms-dancingparticles
# Date created: 14 Oct 2005
# Whom: Alejandro Pulver <alejandro@varnet.biz>
#
# $FreeBSD$
#
PORTNAME= dancingparticles
PORTVERSION= 0.6
CATEGORIES= graphics
MASTER_SITES= http://tardyp.free.fr/dancingparticles/
PKGNAMEPREFIX= xmms-
DISTNAME= ${PORTNAME}${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= alejandro@varnet.biz
COMMENT= Makes particles dance with very pretty neon colors
LIB_DEPENDS= t1.5:${PORTSDIR}/devel/t1lib \
glut.3:${PORTSDIR}/graphics/libglut \
xmms.4:${PORTSDIR}/multimedia/xmms
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GL= yes
USE_GNOME= gtk12
USE_SDL= sdl
CFLAGS+= -I${PREFIX}/include
post-patch:
@${REINPLACE_CMD} -e 's|\(#include.*\)SDL/\(SDL.*\)|\1\2| ; \
s|/usr/local|${PREFIX}|' ${WRKSRC}/*.cc ${WRKSRC}/*.h
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (dancingparticles0.6.tgz) = c780e55d8b1c350d1fb4c09685e33fd2
SIZE (dancingparticles0.6.tgz) = 69299

View File

@ -0,0 +1,42 @@
--- Makefile.orig Sat Jan 31 08:05:51 2004
+++ Makefile Fri Oct 14 20:53:22 2005
@@ -1,14 +1,13 @@
-CC = gcc
#OPT = -m486 -O2
#OPT = -mpentium -O6
-OPT = -mcpu=k6 -march=k6 -O6
-CFLAGS = $(OPT) -Wall -fPIC `gtk-config --cflags gthread`
-LFLAGS = -shared -fPIC -L/usr/local/lib -lm -lstdc++ -lGL -lGLU -L/usr/X11R6/lib -lt1 -lSDL
-LFLAGS2 = -L/usr/local/lib -lm -lstdc++ -lGL -lGLU -L/usr/X11R6/lib -lpthread -lgtk -lgdk -lglut -lt1
+CFLAGS += -fPIC `gtk-config --cflags gthread` `${SDL_CONFIG} --cflags`
+LFLAGS = -shared -fPIC -L${LOCALBASE}/lib -lm -lstdc++ -lGL -lGLU -L${X11BASE}/lib -lt1 `${SDL_CONFIG} --libs`
+LFLAGS2 = -L${LOCALBASE}/lib -lm -lstdc++ -lGL -lGLU -L${X11BASE}/lib -lgtk -lgdk -lglut -lt1
OBJ = plugin.o gl.o etoile.o readme.o parameters.o epic.o config.o signal.o t1font.o
INSTALL-DIR=`xmms-config --visualization-plugin-dir`
XMMS_DATADIR=`xmms-config --data-dir`
+DATADIR=${PREFIX}/share/dancingparticles
BIN=libdancingparticles2.so
all: $(BIN)
@@ -33,14 +32,12 @@
rm -f *.o core *~
install: $(BIN)
- strip $(BIN)
- install $(BIN) $(INSTALL-DIR)
- rm -Rf /usr/local/share/dancingparticles
- mkdir /usr/local/share/dancingparticles
- install dance.epic /usr/local/share/dancingparticles/
- install dancingparticles.conf /usr/local/share/dancingparticles/
- install xmms.epic /usr/local/share/dancingparticles/
- install font.pfb /usr/local/share/dancingparticles/
+ $(BSD_INSTALL_PROGRAM) $(BIN) $(INSTALL-DIR)
+ mkdir $(DATADIR)
+ $(BSD_INSTALL_DATA) dance.epic $(DATADIR)
+ $(BSD_INSTALL_DATA) dancingparticles.conf $(DATADIR)
+ $(BSD_INSTALL_DATA) xmms.epic $(DATADIR)
+ $(BSD_INSTALL_DATA) font.pfb $(DATADIR)
plugin.o: plugin.cc etoile.h

View File

@ -0,0 +1,10 @@
--- parameters.cc.orig Sat Oct 15 21:31:18 2005
+++ parameters.cc Sat Oct 15 21:31:39 2005
@@ -2,6 +2,7 @@
#include "etoile.h"
#include <stdio.h>
#include <stdlib.h>
+#include <locale.h>
#include "t1font.h"
// or why use lex when..

View File

@ -0,0 +1,3 @@
This plugin makes particles dance. Very pretty neon colors.
WWW: http://tardyp.free.fr/dancingparticles/

View File

@ -0,0 +1,6 @@
lib/xmms/Visualization/libdancingparticles2.so
%%DATADIR%%/dance.epic
%%DATADIR%%/dancingparticles.conf
%%DATADIR%%/font.pfb
%%DATADIR%%/xmms.epic
@dirrm %%DATADIR%%