Scivi is a visualization plugin for XMMS, uses 3D

Accelerated hardware, but is not actually 3D.

Features:

Low CPU Usage because of 3D accelerated hardware.
All effects including potentially expensive complex
image transformations are done in hardware. So, if
you have a fast video card, your CPU most of a time
will be idle!

Powerful C-style Scripting Language will help you to
program your own nice presets! The visualization is
under your control!

Root-window rendering supported. Put a nice video
effects on your desktop! This feature is window-manager
dependent. KDE and GNOME probably won't work
Press 'V' to switch to root-window mode.

Full-screen rendering. Planned.

WWW: http://xmms-scivi.sourceforge.net/

PR:		87488
Submitted by:	Alejandro Pulver <alejandro@varnet.biz>
This commit is contained in:
Marcus Alves Grando 2005-10-16 00:09:24 +00:00
parent 9b836cde7d
commit b3cd987b53
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=145484
7 changed files with 138 additions and 0 deletions

View File

@ -613,6 +613,7 @@
SUBDIR += xmms-nebulus
SUBDIR += xmms-paranormal
SUBDIR += xmms-plazma
SUBDIR += xmms-scivi
SUBDIR += xmms-vumeter
SUBDIR += xmms-waterfall
SUBDIR += xmms-xvs

View File

@ -0,0 +1,44 @@
# New ports collection makefile for: xmms-scivi
# Date created: 15 Oct 2005
# Whom: Alejandro Pulver <alejandro@varnet.biz>
#
# $FreeBSD$
#
PORTNAME= scivi
DISTVERSION= 0.2.0-rc3
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
PKGNAMEPREFIX= xmms-
MAINTAINER= alejandro@varnet.biz
COMMENT= Scivi is a visualization plugin for XMMS
LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
USE_X_PREFIX= yes
USE_BZIP2= yes
USE_REINPLACE= yes
USE_GL= yes
USE_GNOME= gtk12
USE_LIBTOOL_VER=15
post-patch:
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" \
${WRKSRC}/configure ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e "s|<stdint.h>|<inttypes.h>|g" \
${WRKSRC}/src/dynam.c ${WRKSRC}/src/glstuff.c \
${WRKSRC}/src/gui.c ${WRKSRC}/src/plugin.c \
${WRKSRC}/src/presets.c ${WRKSRC}/src/scivi.c \
${WRKSRC}/src/utilx.c ${WRKSRC}/src/utilf.c \
${WRKSRC}/src/utilsnd.c
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (scivi-0.2.0-rc3.tar.bz2) = 1de22e25ea5dde0aa655ecc4910156aa
SIZE (scivi-0.2.0-rc3.tar.bz2) = 304802

View File

@ -0,0 +1,25 @@
--- src/presets.c.orig Sat Nov 1 21:06:51 2003
+++ src/presets.c Sat Oct 15 20:54:03 2005
@@ -20,6 +20,8 @@
#include <config.h>
#endif
+#include <sys/cdefs.h>
+#include <sys/syslimits.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
@@ -162,10 +164,10 @@
line = 1;
while (1) {
- glr = getline(&linebuffer, &linebuffersize, f);
-
- if (glr < 0)
+ if (fgets(linebuffer, linebuffersize, f) == NULL)
break;
+
+ glr = strlen(linebuffer);
line++;

View File

@ -0,0 +1,10 @@
--- src/scivi.h.orig Wed Jan 28 17:28:55 2004
+++ src/scivi.h Fri Oct 14 21:46:01 2005
@@ -19,6 +19,7 @@
#ifndef SCIVI_H
#define SCIVI_H
+#include <pthread.h>
#include <X11/Xlib.h>
#include <gtk/gtk.h>
#include "glstuff.h"

View File

@ -0,0 +1,23 @@
Scivi is a visualization plugin for XMMS, uses 3D
Accelerated hardware, but is not actually 3D.
Features:
Low CPU Usage because of 3D accelerated hardware.
All effects including potentially expensive complex
image transformations are done in hardware. So, if
you have a fast video card, your CPU most of a time
will be idle!
Powerful C-style Scripting Language will help you to
program your own nice presets! The visualization is
under your control!
Root-window rendering supported. Put a nice video
effects on your desktop! This feature is window-manager
dependent. KDE and GNOME probably won't work
Press 'V' to switch to root-window mode.
Full-screen rendering. Planned.
WWW: http://xmms-scivi.sourceforge.net/

View File

@ -0,0 +1,33 @@
lib/xmms/Visualization/scivi.so
%%DATADIR%%/presets/array1.scv
%%DATADIR%%/presets/mines.scv
%%DATADIR%%/presets/randot.scv
%%DATADIR%%/presets/simple.scv
%%DATADIR%%/presets/simple10.scv
%%DATADIR%%/presets/simple11.scv
%%DATADIR%%/presets/simple12.scv
%%DATADIR%%/presets/simple2.scv
%%DATADIR%%/presets/simple3.scv
%%DATADIR%%/presets/simple4.scv
%%DATADIR%%/presets/simple5.scv
%%DATADIR%%/presets/simple6.scv
%%DATADIR%%/presets/simple7.scv
%%DATADIR%%/presets/simple8.scv
%%DATADIR%%/presets/simple9.scv
%%DATADIR%%/presets/simplefc.scv
%%DATADIR%%/presets/simpleso.scv
%%DATADIR%%/presets/solariz.scv
%%DATADIR%%/presets/trans1.scv
%%DATADIR%%/presets/trans2.scv
%%DATADIR%%/presets/trans3.scv
%%DATADIR%%/presets/trans4.scv
%%DATADIR%%/presets/trans5.scv
%%DATADIR%%/presets/trans6.scv
%%DATADIR%%/presets/trans7.scv
%%DATADIR%%/presets/trans8.scv
%%DATADIR%%/presets/trans9.scv
%%DATADIR%%/scivi-warn.xpm
%%PORTDOCS%%%%DOCSDIR%%/README
@dirrm %%DATADIR%%/presets
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%