add vcdimager
GNU VCDImager/VCDRip -- The GNU VideoCD Image Maker/Ripping Tool PR: 26606 Submitted by: Harold Gutch <logix@foobar.franken.de>
This commit is contained in:
parent
d651014437
commit
ed9f99a59e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41477
@ -228,6 +228,7 @@
|
||||
SUBDIR += urt
|
||||
SUBDIR += utah-glx
|
||||
SUBDIR += vcdgear
|
||||
SUBDIR += vcdimager
|
||||
SUBDIR += vcdpad
|
||||
SUBDIR += vcdtools
|
||||
SUBDIR += vcg
|
||||
|
22
graphics/vcdimager/Makefile
Normal file
22
graphics/vcdimager/Makefile
Normal file
@ -0,0 +1,22 @@
|
||||
# New ports collection makefile for: vcdimager
|
||||
# Date created: 16 April 2001
|
||||
# Whom: Harold Gutch <logix@foobar.franken.de>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= vcdimager
|
||||
PORTVERSION= 0.6.0
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.hvrlab.org/pub/vcdimager/vcdimager-0.6/
|
||||
|
||||
MAINTAINER= logix@foobar.franken.de
|
||||
|
||||
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
MAN1= vcdimager.1 vcdrip.1
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/vcdimager/distinfo
Normal file
1
graphics/vcdimager/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (vcdimager-0.6.0.tar.gz) = 1ac3dac3efc0fd629fada495ee839837
|
10
graphics/vcdimager/files/patch-aa
Normal file
10
graphics/vcdimager/files/patch-aa
Normal file
@ -0,0 +1,10 @@
|
||||
--- frontends/cli/vcdimager.c.orig Sun Mar 18 01:13:01 2001
|
||||
+++ frontends/cli/vcdimager.c Mon Apr 16 01:12:00 2001
|
||||
@@ -32,6 +32,7 @@
|
||||
#include <string.h>
|
||||
#include <sys/mman.h>
|
||||
#include <sys/types.h>
|
||||
+#include <sys/stat.h>
|
||||
#include <unistd.h>
|
||||
|
||||
#include "vcd_types.h"
|
18
graphics/vcdimager/files/patch-ab
Normal file
18
graphics/vcdimager/files/patch-ab
Normal file
@ -0,0 +1,18 @@
|
||||
--- libvcd/vcd_types.h.orig Fri Mar 9 02:02:38 2001
|
||||
+++ libvcd/vcd_types.h Mon Apr 16 01:22:17 2001
|
||||
@@ -44,6 +44,15 @@
|
||||
/* fixme */
|
||||
#endif /* HAVE_STDINT_H */
|
||||
|
||||
+# define INT8_C(c) c
|
||||
+# define INT16_C(c) c
|
||||
+# define INT32_C(c) c
|
||||
+# define INT64_C(c) c ## LL
|
||||
+# define UINT8_C(c) c ## U
|
||||
+# define UINT16_C(c) c ## U
|
||||
+# define UINT32_C(c) c ## U
|
||||
+# define UINT64_C(c) c ## ULL
|
||||
+
|
||||
#if defined(HAVE_STDBOOL_H)
|
||||
#include <stdbool.h>
|
||||
#else
|
1
graphics/vcdimager/pkg-comment
Normal file
1
graphics/vcdimager/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
GNU VCDImager/VCDRip -- The GNU VideoCD Image Maker/Ripping Tool
|
19
graphics/vcdimager/pkg-descr
Normal file
19
graphics/vcdimager/pkg-descr
Normal file
@ -0,0 +1,19 @@
|
||||
VCDImager is a "little" program which allows direct making of VideoCD
|
||||
BIN/CUE CD images from MPEG files, which can be played on standalone
|
||||
VCD players or DVD players. BIN/CUE images can be burned with cdrdao.
|
||||
|
||||
VCDImager supports the VideoCD 1.1, VideoCD 2.0 audn Super VideoCD 2.0
|
||||
standards.
|
||||
|
||||
Also included in the package is the vcdrip-tool, which performs the
|
||||
opposite task.
|
||||
|
||||
This set actually consists of a backend library and a commandline
|
||||
frontend for it.
|
||||
|
||||
|
||||
WWW: http://www.gnu.org/vcdimager
|
||||
http://www.hvrlab.org/~hvr/vcdimager/
|
||||
|
||||
- Harold Gutch
|
||||
logix@foobar.franken.de
|
5
graphics/vcdimager/pkg-plist
Normal file
5
graphics/vcdimager/pkg-plist
Normal file
@ -0,0 +1,5 @@
|
||||
bin/vcdimager
|
||||
bin/vcdrip
|
||||
@unexec install-info --delete %D/info/vcdimager.info %D/info/dir
|
||||
info/vcdimager.info
|
||||
@exec install-info %D/info/vcdimager.info %D/info/dir
|
22
multimedia/vcdimager/Makefile
Normal file
22
multimedia/vcdimager/Makefile
Normal file
@ -0,0 +1,22 @@
|
||||
# New ports collection makefile for: vcdimager
|
||||
# Date created: 16 April 2001
|
||||
# Whom: Harold Gutch <logix@foobar.franken.de>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= vcdimager
|
||||
PORTVERSION= 0.6.0
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.hvrlab.org/pub/vcdimager/vcdimager-0.6/
|
||||
|
||||
MAINTAINER= logix@foobar.franken.de
|
||||
|
||||
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
MAN1= vcdimager.1 vcdrip.1
|
||||
|
||||
.include <bsd.port.mk>
|
1
multimedia/vcdimager/distinfo
Normal file
1
multimedia/vcdimager/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (vcdimager-0.6.0.tar.gz) = 1ac3dac3efc0fd629fada495ee839837
|
10
multimedia/vcdimager/files/patch-aa
Normal file
10
multimedia/vcdimager/files/patch-aa
Normal file
@ -0,0 +1,10 @@
|
||||
--- frontends/cli/vcdimager.c.orig Sun Mar 18 01:13:01 2001
|
||||
+++ frontends/cli/vcdimager.c Mon Apr 16 01:12:00 2001
|
||||
@@ -32,6 +32,7 @@
|
||||
#include <string.h>
|
||||
#include <sys/mman.h>
|
||||
#include <sys/types.h>
|
||||
+#include <sys/stat.h>
|
||||
#include <unistd.h>
|
||||
|
||||
#include "vcd_types.h"
|
18
multimedia/vcdimager/files/patch-ab
Normal file
18
multimedia/vcdimager/files/patch-ab
Normal file
@ -0,0 +1,18 @@
|
||||
--- libvcd/vcd_types.h.orig Fri Mar 9 02:02:38 2001
|
||||
+++ libvcd/vcd_types.h Mon Apr 16 01:22:17 2001
|
||||
@@ -44,6 +44,15 @@
|
||||
/* fixme */
|
||||
#endif /* HAVE_STDINT_H */
|
||||
|
||||
+# define INT8_C(c) c
|
||||
+# define INT16_C(c) c
|
||||
+# define INT32_C(c) c
|
||||
+# define INT64_C(c) c ## LL
|
||||
+# define UINT8_C(c) c ## U
|
||||
+# define UINT16_C(c) c ## U
|
||||
+# define UINT32_C(c) c ## U
|
||||
+# define UINT64_C(c) c ## ULL
|
||||
+
|
||||
#if defined(HAVE_STDBOOL_H)
|
||||
#include <stdbool.h>
|
||||
#else
|
1
multimedia/vcdimager/pkg-comment
Normal file
1
multimedia/vcdimager/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
GNU VCDImager/VCDRip -- The GNU VideoCD Image Maker/Ripping Tool
|
19
multimedia/vcdimager/pkg-descr
Normal file
19
multimedia/vcdimager/pkg-descr
Normal file
@ -0,0 +1,19 @@
|
||||
VCDImager is a "little" program which allows direct making of VideoCD
|
||||
BIN/CUE CD images from MPEG files, which can be played on standalone
|
||||
VCD players or DVD players. BIN/CUE images can be burned with cdrdao.
|
||||
|
||||
VCDImager supports the VideoCD 1.1, VideoCD 2.0 audn Super VideoCD 2.0
|
||||
standards.
|
||||
|
||||
Also included in the package is the vcdrip-tool, which performs the
|
||||
opposite task.
|
||||
|
||||
This set actually consists of a backend library and a commandline
|
||||
frontend for it.
|
||||
|
||||
|
||||
WWW: http://www.gnu.org/vcdimager
|
||||
http://www.hvrlab.org/~hvr/vcdimager/
|
||||
|
||||
- Harold Gutch
|
||||
logix@foobar.franken.de
|
5
multimedia/vcdimager/pkg-plist
Normal file
5
multimedia/vcdimager/pkg-plist
Normal file
@ -0,0 +1,5 @@
|
||||
bin/vcdimager
|
||||
bin/vcdrip
|
||||
@unexec install-info --delete %D/info/vcdimager.info %D/info/dir
|
||||
info/vcdimager.info
|
||||
@exec install-info %D/info/vcdimager.info %D/info/dir
|
Loading…
Reference in New Issue
Block a user