A scanner/parser generator
This commit is contained in:
Ying-Chieh Liao 2001-04-16 19:40:59 +00:00
parent 0ff8ac6584
commit d651014437
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41476
10 changed files with 429 additions and 0 deletions

View File

@ -432,6 +432,7 @@
SUBDIR += st
SUBDIR += stlport
SUBDIR += str
SUBDIR += styx
SUBDIR += swarm
SUBDIR += swigruby
SUBDIR += t1lib

39
devel/styx/Makefile Normal file
View File

@ -0,0 +1,39 @@
# ex:ts=8
# New ports collection makefile for: styx
# Date created: Apr 17, 2001
# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= styx
PORTVERSION= 1.3
CATEGORIES= devel
MASTER_SITES= http://www.speculate.de/styx/
EXTRACT_SUFX= .tgz
MAINTAINER= ijliao@FreeBSD.org
LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${PREFIX}/include" \
LIBS="-L${PREFIX}/lib -lgiconv"
CONFIGURE_ARGS= --includedir=${PREFIX}/include/styx \
--datadir=${PREFIX}/share/doc/styx
USE_GMAKE= yes
post-patch:
.for file in config.h.in configure libbase/styconf0.h
@${PERL} -pi -e "s,iconv.h,giconv.h,g" ${WRKSRC}/${file}
.endfor
.for file in config.h.in libbase/styconf0.h libbase/gstream.c
@${PERL} -pi -e "s,ICONV_H,GICONV_H,g" ${WRKSRC}/${file}
.endfor
pre-configure:
@${RM} -f ${WRKSRC}/config.cache
.include <bsd.port.mk>

1
devel/styx/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (styx-1.3.tgz) = af44ccf854039232012cadf5342c4cf0

View File

@ -0,0 +1,19 @@
--- Makefile.in.orig Mon Mar 5 03:45:44 2001
+++ Makefile.in Tue Apr 17 03:21:27 2001
@@ -528,12 +528,12 @@
install-data-local:
- install -d $(prefix)/include
- for i in $(iHEADERS); do install -m 444 $$i $(prefix)/include; done
+ install -d $(includedir)
+ for i in $(iHEADERS); do install -m 444 $$i $(includedir); done
if [ -d man ] ; then install -d $(prefix)/man; fi
if [ -d man ] ; then for i in man/* ; do if [ $$i != "man/*" ]; then install $$i $(prefix)/man; fi; done; fi
- if [ -d tutorial ] ; then cp -r tutorial $(prefix); fi;
- if [ -d doc ] ; then cp -r doc $(prefix); fi;
+ if [ -d tutorial ] ; then cp -r tutorial $(datadir); fi;
+ if [ -d doc ] ; then cp -r doc $(datadir); fi;
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.

View File

@ -0,0 +1,11 @@
--- inc/sysbase1.h.orig Tue Apr 17 00:55:58 2001
+++ inc/sysbase1.h Tue Apr 17 00:57:17 2001
@@ -178,7 +178,7 @@
#define DL_LOAD_LAZY 0
-#if !defined(STYX_CONFIG_OSMS) && (!defined(HAVE_CONFIG_H) || (defined(HAVE_LIBDL) && defined(HAVE_DLFCN_H)))
+#if defined(__FreeBSD__) || (!defined(STYX_CONFIG_OSMS) && (!defined(HAVE_CONFIG_H) || (defined(HAVE_LIBDL) && defined(HAVE_DLFCN_H))))
#define DL_LAZY RTLD_LAZY
#define DL_NOW RTLD_NOW
#define DL_BINDING_MASK RTLD_BINDING_MASK

View File

@ -0,0 +1,11 @@
--- libbase/gstream.c.orig Tue Apr 17 01:04:58 2001
+++ libbase/gstream.c Tue Apr 17 01:05:13 2001
@@ -485,7 +485,7 @@
#else
-#if !defined(MSDOS) && ( !defined(HAVE_CONFIG_H) || defined(HAVE_ICONV_H) )
+#if defined(__FreeBSD__) || (!defined(MSDOS) && ( !defined(HAVE_CONFIG_H) || defined(HAVE_ICONV_H) ) )
ConcreteType(CDIConv_T) // ICONV conversion description type
{

View File

@ -0,0 +1,20 @@
--- libbase/sysbase1.c.orig Sun Feb 25 22:36:20 2001
+++ libbase/sysbase1.c Tue Apr 17 01:25:49 2001
@@ -526,7 +526,7 @@
#define DL_LOAD_LAZY 0
/*DOC_INTERFACE*/
-#if !defined(STYX_CONFIG_OSMS) && (!defined(HAVE_CONFIG_H) || (defined(HAVE_LIBDL) && defined(HAVE_DLFCN_H)))
+#if defined(__FreeBSD__) || (!defined(STYX_CONFIG_OSMS) && (!defined(HAVE_CONFIG_H) || (defined(HAVE_LIBDL) && defined(HAVE_DLFCN_H))))
#define DL_LAZY RTLD_LAZY
#define DL_NOW RTLD_NOW
#define DL_BINDING_MASK RTLD_BINDING_MASK
@@ -570,7 +570,7 @@
}
#else
-#if !defined(MSDOS) && ( !defined(HAVE_CONFIG_H) || ( defined(HAVE_LIBDL) && defined(HAVE_DLFCN_H) ) )
+#if defined(__FreeBSD__) || (!defined(MSDOS) && ( !defined(HAVE_CONFIG_H) || ( defined(HAVE_LIBDL) && defined(HAVE_DLFCN_H) ) ) )
DL_Hdl DL_open(string dlname, int flag)
/* loads dll 'dlname' in mode 'flag' ( ERROR: NULL )

1
devel/styx/pkg-comment Normal file
View File

@ -0,0 +1 @@
A scanner/parser generator

13
devel/styx/pkg-descr Normal file
View File

@ -0,0 +1,13 @@
Styx is a scanner/parser generator designed to address some
shortcomings of the traditional lex/yacc combination.
It has unique features like automatic derivation of depth grammar,
production of the derivation tree including it's C interface,
preservation of full source information and pretty printing to
faciliate source-source translation, persistence to aid rapid
interpreter writing.
For application in contemporary computing environments, it supports
unicode, reentrancy and offers thread-safeness.
WWW: http://www.speculate.de/styx/

313
devel/styx/pkg-plist Normal file
View File

@ -0,0 +1,313 @@
bin/ctoh
bin/lim_test
bin/pim_test
bin/stydoc
bin/stypp
bin/styx
include/styx/binimg.h
include/styx/ccnv_lim.h
include/styx/cfg_abs.h
include/styx/cfg_dfn.h
include/styx/com_get.h
include/styx/ctoh_cim.h
include/styx/ctx.h
include/styx/ctx_app.h
include/styx/ctx_dfn.h
include/styx/dicts.h
include/styx/gls.h
include/styx/gstream.h
include/styx/hmap.h
include/styx/hpat.h
include/styx/hpat_int.h
include/styx/hset.h
include/styx/lim__cim.h
include/styx/line_scn.h
include/styx/list.h
include/styx/literal.h
include/styx/mem_base.h
include/styx/memosx.h
include/styx/otab.h
include/styx/pathes.h
include/styx/pim__cim.h
include/styx/prim.h
include/styx/prs.h
include/styx/prs_dfn.h
include/styx/prs_gen.h
include/styx/prs_imp.h
include/styx/prs_io.h
include/styx/ptm.h
include/styx/ptm_gen.h
include/styx/ptm_pp.h
include/styx/scn_base.h
include/styx/scn_gen.h
include/styx/scn_imp.h
include/styx/scn_io.h
include/styx/scn_pre.h
include/styx/sink.h
include/styx/standard.h
include/styx/stdosx.h
include/styx/styconf0.h
include/styx/styd_cim.h
include/styx/styp_cim.h
include/styx/styx_cim.h
include/styx/styx_int.h
include/styx/styx_lim.h
include/styx/styx_pim.h
include/styx/symbols.h
include/styx/sysbase0.h
include/styx/sysbase1.h
include/styx/syscbhdl.h
share/doc/styx/doc/STYX_ANT.HTM
share/doc/styx/doc/STYX_CFG.HTM
share/doc/styx/doc/STYX_CIM.HTM
share/doc/styx/doc/bin__cim.htm
share/doc/styx/doc/binimg.htm
share/doc/styx/doc/binset.htm
share/doc/styx/doc/bnf.htm
share/doc/styx/doc/c
share/doc/styx/doc/c2sgml
share/doc/styx/doc/ccnv_lim.htm
share/doc/styx/doc/cdps_lim.htm
share/doc/styx/doc/cfg_abs.htm
share/doc/styx/doc/cfg_dfn.htm
share/doc/styx/doc/charlib.htm
share/doc/styx/doc/cmd__cim.htm
share/doc/styx/doc/cmd_ant.htm
share/doc/styx/doc/cmd_ctoh.htm
share/doc/styx/doc/cmd_int.htm
share/doc/styx/doc/cmd_lim.htm
share/doc/styx/doc/cmd_lim_test.htm
share/doc/styx/doc/cmd_pim.htm
share/doc/styx/doc/cmd_pim_test.htm
share/doc/styx/doc/cmd_stydoc.htm
share/doc/styx/doc/cmd_stypp.htm
share/doc/styx/doc/cmd_styx.htm
share/doc/styx/doc/cmda_cim.htm
share/doc/styx/doc/cmdd_cim.htm
share/doc/styx/doc/cmdlib.htm
share/doc/styx/doc/com_cim.htm
share/doc/styx/doc/com_get.htm
share/doc/styx/doc/cprj_ant.htm
share/doc/styx/doc/cprj_int.htm
share/doc/styx/doc/cprj_lim.htm
share/doc/styx/doc/cprj_pim.htm
share/doc/styx/doc/ctoh_cim.htm
share/doc/styx/doc/ctx.htm
share/doc/styx/doc/ctx_app.htm
share/doc/styx/doc/ctx_dfn.htm
share/doc/styx/doc/ctx_imp.htm
share/doc/styx/doc/date.htm
share/doc/styx/doc/dict.htm
share/doc/styx/doc/dicts.htm
share/doc/styx/doc/dps_cim.htm
share/doc/styx/doc/esty_ant.htm
share/doc/styx/doc/esty_int.htm
share/doc/styx/doc/esty_lim.htm
share/doc/styx/doc/esty_pim.htm
share/doc/styx/doc/genm_cim.htm
share/doc/styx/doc/glo_tab.htm
share/doc/styx/doc/gls.htm
share/doc/styx/doc/gls_abs.htm
share/doc/styx/doc/gstream.htm
share/doc/styx/doc/hmap.htm
share/doc/styx/doc/hpat.htm
share/doc/styx/doc/hpat_ant.htm
share/doc/styx/doc/hpat_int.htm
share/doc/styx/doc/hpat_lim.htm
share/doc/styx/doc/hpat_pim.htm
share/doc/styx/doc/hset.htm
share/doc/styx/doc/integer.htm
share/doc/styx/doc/lim__cim.htm
share/doc/styx/doc/line_scn.htm
share/doc/styx/doc/list.htm
share/doc/styx/doc/literal.htm
share/doc/styx/doc/m
share/doc/styx/doc/mem_base.htm
share/doc/styx/doc/meta_ant.htm
share/doc/styx/doc/meta_cim.htm
share/doc/styx/doc/meta_exp.htm
share/doc/styx/doc/meta_int.htm
share/doc/styx/doc/meta_lim.htm
share/doc/styx/doc/meta_pim.htm
share/doc/styx/doc/meta_prs.htm
share/doc/styx/doc/nmk_cim.htm
share/doc/styx/doc/olist.htm
share/doc/styx/doc/otab.htm
share/doc/styx/doc/pathes.htm
share/doc/styx/doc/pim__cim.htm
share/doc/styx/doc/pl0.abs.sgml
share/doc/styx/doc/pl0.c.sgml
share/doc/styx/doc/pl0.sty.sgml
share/doc/styx/doc/prdp_cim.htm
share/doc/styx/doc/pre.htm
share/doc/styx/doc/prim.htm
share/doc/styx/doc/prjfun.htm
share/doc/styx/doc/prs.htm
share/doc/styx/doc/prs_dfn.htm
share/doc/styx/doc/prs_gen.htm
share/doc/styx/doc/prs_imp.htm
share/doc/styx/doc/prs_io.htm
share/doc/styx/doc/ptm.htm
share/doc/styx/doc/ptm__cim.htm
share/doc/styx/doc/ptm_gen.htm
share/doc/styx/doc/ptm_pp.htm
share/doc/styx/doc/rational.htm
share/doc/styx/doc/refo_cim.htm
share/doc/styx/doc/reg_exp.htm
share/doc/styx/doc/rexp_lim.htm
share/doc/styx/doc/scn_base.htm
share/doc/styx/doc/scn_gen.htm
share/doc/styx/doc/scn_imp.htm
share/doc/styx/doc/scn_io.htm
share/doc/styx/doc/scn_pre.htm
share/doc/styx/doc/shmain.htm
share/doc/styx/doc/sink.htm
share/doc/styx/doc/standard.htm
share/doc/styx/doc/stdosx.htm
share/doc/styx/doc/styconf0.htm
share/doc/styx/doc/styd_cim.htm
share/doc/styx/doc/styp_cim.htm
share/doc/styx/doc/styx-1.html
share/doc/styx/doc/styx-10.html
share/doc/styx/doc/styx-11.html
share/doc/styx/doc/styx-12.html
share/doc/styx/doc/styx-2.html
share/doc/styx/doc/styx-3.html
share/doc/styx/doc/styx-4.html
share/doc/styx/doc/styx-5.html
share/doc/styx/doc/styx-6.html
share/doc/styx/doc/styx-7.html
share/doc/styx/doc/styx-8.html
share/doc/styx/doc/styx-9.html
share/doc/styx/doc/styx-todo
share/doc/styx/doc/styx.html
share/doc/styx/doc/styx.sgml
share/doc/styx/doc/styx_int.htm
share/doc/styx/doc/styx_lim.htm
share/doc/styx/doc/styx_pim.htm
share/doc/styx/doc/symbols.htm
share/doc/styx/doc/sysbase0.htm
share/doc/styx/doc/sysbase1.htm
share/doc/styx/doc/syscbhdl.htm
share/doc/styx/doc/term.htm
share/doc/styx/doc/testpl0.pl.sgml
share/doc/styx/doc/udp_ant.htm
share/doc/styx/doc/udp_int.htm
share/doc/styx/doc/udp_lim.htm
share/doc/styx/doc/udp_pim.htm
share/doc/styx/doc/xc-doc-new/c
share/doc/styx/doc/xc-doc-new/inc/xm_new.h
share/doc/styx/doc/xc-doc-new/m
share/doc/styx/doc/xc-doc-new/memory-1.html
share/doc/styx/doc/xc-doc-new/memory-2.html
share/doc/styx/doc/xc-doc-new/memory-3.html
share/doc/styx/doc/xc-doc-new/memory-4.html
share/doc/styx/doc/xc-doc-new/memory-5.html
share/doc/styx/doc/xc-doc-new/memory.html
share/doc/styx/doc/xc-doc-new/memory.sgml
share/doc/styx/doc/xc-doc-new/mmg
share/doc/styx/doc/xc-doc-new/prj/ctoh.cth
share/doc/styx/doc/xc-doc-new/prj/project.dps
share/doc/styx/doc/xc-doc-new/prj/project.lst
share/doc/styx/doc/xc-doc-new/prj/project.nmk
share/doc/styx/doc/xc-doc-new/xm_new.c
share/doc/styx/doc/xc-doc-new/xm_new.s
share/doc/styx/doc/xmem_imp.htm
share/doc/styx/doc/xstdosx.htm
share/doc/styx/readme
share/doc/styx/tutorial01/calc.sty
share/doc/styx/tutorial01/calctut.c
share/doc/styx/tutorial01/gen/calc.abs
share/doc/styx/tutorial01/gen/calc_ant.c
share/doc/styx/tutorial01/gen/calc_int.c
share/doc/styx/tutorial01/gen/calc_lim.c
share/doc/styx/tutorial01/gen/calc_pim.c
share/doc/styx/tutorial01/inc/calc_ant.h
share/doc/styx/tutorial01/inc/calc_int.h
share/doc/styx/tutorial01/inc/calc_lim.h
share/doc/styx/tutorial01/inc/calc_pim.h
share/doc/styx/tutorial01/mx
share/doc/styx/tutorial01/readme
share/doc/styx/tutorial02/gen/pl0.abs
share/doc/styx/tutorial02/gen/pl0.cim
share/doc/styx/tutorial02/gen/pl0.lim
share/doc/styx/tutorial02/gen/pl0.pim
share/doc/styx/tutorial02/gen/pl0_ant.c
share/doc/styx/tutorial02/gen/pl0_cim.c
share/doc/styx/tutorial02/gen/pl0_int.c
share/doc/styx/tutorial02/gen/pl0_lim.c
share/doc/styx/tutorial02/gen/pl0_pim.c
share/doc/styx/tutorial02/inc/pl0_ant.h
share/doc/styx/tutorial02/inc/pl0_cim.h
share/doc/styx/tutorial02/inc/pl0_int.h
share/doc/styx/tutorial02/inc/pl0_lim.h
share/doc/styx/tutorial02/inc/pl0_pim.h
share/doc/styx/tutorial02/mx
share/doc/styx/tutorial02/pl0.c
share/doc/styx/tutorial02/pl0.sty
share/doc/styx/tutorial02/readme
share/doc/styx/tutorial02/t
share/doc/styx/tutorial02/testpl0.pl0
share/doc/styx/tutorial02/todo
share/doc/styx/tutorial03/gen/pl0.abs
share/doc/styx/tutorial03/gen/pl0.cim
share/doc/styx/tutorial03/gen/pl0.lim
share/doc/styx/tutorial03/gen/pl0.pim
share/doc/styx/tutorial03/gen/pl0_ant.c
share/doc/styx/tutorial03/gen/pl0_cim.c
share/doc/styx/tutorial03/gen/pl0_int.c
share/doc/styx/tutorial03/gen/pl0_lim.c
share/doc/styx/tutorial03/gen/pl0_pim.c
share/doc/styx/tutorial03/inc/pl0_ant.h
share/doc/styx/tutorial03/inc/pl0_cim.h
share/doc/styx/tutorial03/inc/pl0_int.h
share/doc/styx/tutorial03/inc/pl0_lim.h
share/doc/styx/tutorial03/inc/pl0_pim.h
share/doc/styx/tutorial03/mx
share/doc/styx/tutorial03/pl0.sty
share/doc/styx/tutorial03/pl0c.c
share/doc/styx/tutorial03/pl0r.c
share/doc/styx/tutorial03/readme
share/doc/styx/tutorial03/t
share/doc/styx/tutorial03/testpl0
share/doc/styx/tutorial03/testpl0.pl0
share/doc/styx/tutorial03/todo
share/doc/styx/tutorial04/calc
share/doc/styx/tutorial04/calc.cpp
share/doc/styx/tutorial04/calc.sty
share/doc/styx/tutorial04/gen/calc.abs
share/doc/styx/tutorial04/gen/calc.lim
share/doc/styx/tutorial04/gen/calc.pim
share/doc/styx/tutorial04/gen/calc_ant.c
share/doc/styx/tutorial04/gen/calc_int.c
share/doc/styx/tutorial04/gen/calc_lim.c
share/doc/styx/tutorial04/gen/calc_pim.c
share/doc/styx/tutorial04/inc/calc_ant.h
share/doc/styx/tutorial04/inc/calc_int.h
share/doc/styx/tutorial04/inc/calc_lim.h
share/doc/styx/tutorial04/inc/calc_pim.h
share/doc/styx/tutorial04/mx
share/doc/styx/tutorial04/pattern_file.txt
share/doc/styx/tutorial04/readme
share/doc/styx/tutorial04/t
@dirrm share/doc/styx/doc/xc-doc-new/inc
@dirrm share/doc/styx/doc/xc-doc-new/prj
@dirrm share/doc/styx/doc/xc-doc-new
@dirrm share/doc/styx/doc
@dirrm share/doc/styx/tutorial01/gen
@dirrm share/doc/styx/tutorial01/inc
@dirrm share/doc/styx/tutorial01/prj
@dirrm share/doc/styx/tutorial01
@dirrm share/doc/styx/tutorial02/gen
@dirrm share/doc/styx/tutorial02/inc
@dirrm share/doc/styx/tutorial02/prj
@dirrm share/doc/styx/tutorial02
@dirrm share/doc/styx/tutorial03/gen
@dirrm share/doc/styx/tutorial03/inc
@dirrm share/doc/styx/tutorial03/prj
@dirrm share/doc/styx/tutorial03
@dirrm share/doc/styx/tutorial04/gen
@dirrm share/doc/styx/tutorial04/inc
@dirrm share/doc/styx/tutorial04/prj
@dirrm share/doc/styx/tutorial04
@dirrm share/doc/styx