add jabber-jud 0.4
Jabber User Directory module PR: 37210 Submitted by: Sean Chittenden <sean@chittenden.org>
This commit is contained in:
parent
9f62a612e6
commit
aaae62c6e6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=57877
29
net-im/jabber-jud/Makefile
Normal file
29
net-im/jabber-jud/Makefile
Normal file
@ -0,0 +1,29 @@
|
||||
# New ports collection makefile for: jabber-jud
|
||||
# Date created: 14 Apr 2002
|
||||
# Whom: Sean Chittenden <sean@chittenden.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= jud
|
||||
PORTVERSION= 0.4
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://download.jabber.org/dists/1.4/final/
|
||||
PKGNAMEPREFIX= jabber-
|
||||
DIST_SUBDIR= jabber
|
||||
|
||||
MAINTAINER= sean@chittenden.org
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/sbin/jabberd:${PORTSDIR}/net/jabber
|
||||
|
||||
USE_GMAKE= yes
|
||||
|
||||
post-patch:
|
||||
@echo "${PREFIX}" > ${WRKSRC}/.prefix-freebsd
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/jud.so ${PREFIX}/lib/jabber/
|
||||
|
||||
post-install:
|
||||
@cat pkg-message
|
||||
|
||||
.include <bsd.port.mk>
|
1
net-im/jabber-jud/distinfo
Normal file
1
net-im/jabber-jud/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (jabber/jud-0.4.tar.gz) = a057e8dd5966fa0d26ded03697ba395a
|
12
net-im/jabber-jud/files/patch-aa
Normal file
12
net-im/jabber-jud/files/patch-aa
Normal file
@ -0,0 +1,12 @@
|
||||
--- Makefile.orig Sun Apr 14 21:28:26 2002
|
||||
+++ Makefile Sun Apr 14 21:53:11 2002
|
||||
@@ -1,6 +1,7 @@
|
||||
-include ../platform-settings
|
||||
+INCDIR= ${PREFIX}/include/jabber
|
||||
+include ${INCDIR}/platform-settings
|
||||
|
||||
-CFLAGS:=$(CFLAGS) -I../jabberd
|
||||
+CFLAGS:=$(CFLAGS) -I${INCDIR}
|
||||
|
||||
jud_OBJECTS=jud.o jud_reg.o jud_search.o
|
||||
|
1
net-im/jabber-jud/pkg-comment
Normal file
1
net-im/jabber-jud/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Jabber User Directory module
|
5
net-im/jabber-jud/pkg-descr
Normal file
5
net-im/jabber-jud/pkg-descr
Normal file
@ -0,0 +1,5 @@
|
||||
The Jabber server (jabberd) is a daemon for Jabber clients to connect
|
||||
and communicate with. JUD is allows clients to search for other users.
|
||||
|
||||
You can learn more about Jabber at:
|
||||
WWW: http://server.jabber.org/
|
32
net-im/jabber-jud/pkg-message
Normal file
32
net-im/jabber-jud/pkg-message
Normal file
@ -0,0 +1,32 @@
|
||||
To activate JUD for your Jabber server, add the following (around line 36 in
|
||||
the sample configuration file) to your configuration file
|
||||
(${LOCALBASE}/etc/jabber.xml):
|
||||
|
||||
|
||||
<!--
|
||||
If you want this service to be accessible from other servers,
|
||||
change 'jud.localhost' to the server's fully qualified domain name!
|
||||
Also note that ${LOCALBASE} should be changed to your local base
|
||||
(ex: /usr/local).
|
||||
-->
|
||||
<service id="jud">
|
||||
<host>jud.localhost</host>
|
||||
<load><jud>${LOCALBASE}/lib/jabber/jud.so</jud></load>
|
||||
<jud xmlns="jabber:config:jud">
|
||||
<vCard>
|
||||
<FN>Local Organization's User Directory</FN>
|
||||
<DESC>This service provides a simple user directory service.</DESC>
|
||||
<URL>http://foo.bar/</URL>
|
||||
</vCard>
|
||||
</jud>
|
||||
</service>
|
||||
|
||||
Add this section to the browse area of the jsm service to advertise it to
|
||||
your users (around line 245 of the sample config):
|
||||
|
||||
<service type="jud" jid="jud.localhost" name="My Organization's User Directory">
|
||||
<ns>jabber:iq:search</ns>
|
||||
<ns>jabber:iq:register</ns>
|
||||
</service>
|
||||
|
||||
Be sure to restart your server after reconfiguring.
|
1
net-im/jabber-jud/pkg-plist
Normal file
1
net-im/jabber-jud/pkg-plist
Normal file
@ -0,0 +1 @@
|
||||
lib/jabber/jud.so
|
@ -193,6 +193,7 @@
|
||||
SUBDIR += jabber
|
||||
SUBDIR += jabber-aim
|
||||
SUBDIR += jabber-conference
|
||||
SUBDIR += jabber-jud
|
||||
SUBDIR += jags
|
||||
SUBDIR += javadc
|
||||
SUBDIR += jift
|
||||
|
29
net/jabber-jud/Makefile
Normal file
29
net/jabber-jud/Makefile
Normal file
@ -0,0 +1,29 @@
|
||||
# New ports collection makefile for: jabber-jud
|
||||
# Date created: 14 Apr 2002
|
||||
# Whom: Sean Chittenden <sean@chittenden.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= jud
|
||||
PORTVERSION= 0.4
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://download.jabber.org/dists/1.4/final/
|
||||
PKGNAMEPREFIX= jabber-
|
||||
DIST_SUBDIR= jabber
|
||||
|
||||
MAINTAINER= sean@chittenden.org
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/sbin/jabberd:${PORTSDIR}/net/jabber
|
||||
|
||||
USE_GMAKE= yes
|
||||
|
||||
post-patch:
|
||||
@echo "${PREFIX}" > ${WRKSRC}/.prefix-freebsd
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/jud.so ${PREFIX}/lib/jabber/
|
||||
|
||||
post-install:
|
||||
@cat pkg-message
|
||||
|
||||
.include <bsd.port.mk>
|
1
net/jabber-jud/distinfo
Normal file
1
net/jabber-jud/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (jabber/jud-0.4.tar.gz) = a057e8dd5966fa0d26ded03697ba395a
|
12
net/jabber-jud/files/patch-aa
Normal file
12
net/jabber-jud/files/patch-aa
Normal file
@ -0,0 +1,12 @@
|
||||
--- Makefile.orig Sun Apr 14 21:28:26 2002
|
||||
+++ Makefile Sun Apr 14 21:53:11 2002
|
||||
@@ -1,6 +1,7 @@
|
||||
-include ../platform-settings
|
||||
+INCDIR= ${PREFIX}/include/jabber
|
||||
+include ${INCDIR}/platform-settings
|
||||
|
||||
-CFLAGS:=$(CFLAGS) -I../jabberd
|
||||
+CFLAGS:=$(CFLAGS) -I${INCDIR}
|
||||
|
||||
jud_OBJECTS=jud.o jud_reg.o jud_search.o
|
||||
|
1
net/jabber-jud/pkg-comment
Normal file
1
net/jabber-jud/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Jabber User Directory module
|
5
net/jabber-jud/pkg-descr
Normal file
5
net/jabber-jud/pkg-descr
Normal file
@ -0,0 +1,5 @@
|
||||
The Jabber server (jabberd) is a daemon for Jabber clients to connect
|
||||
and communicate with. JUD is allows clients to search for other users.
|
||||
|
||||
You can learn more about Jabber at:
|
||||
WWW: http://server.jabber.org/
|
32
net/jabber-jud/pkg-message
Normal file
32
net/jabber-jud/pkg-message
Normal file
@ -0,0 +1,32 @@
|
||||
To activate JUD for your Jabber server, add the following (around line 36 in
|
||||
the sample configuration file) to your configuration file
|
||||
(${LOCALBASE}/etc/jabber.xml):
|
||||
|
||||
|
||||
<!--
|
||||
If you want this service to be accessible from other servers,
|
||||
change 'jud.localhost' to the server's fully qualified domain name!
|
||||
Also note that ${LOCALBASE} should be changed to your local base
|
||||
(ex: /usr/local).
|
||||
-->
|
||||
<service id="jud">
|
||||
<host>jud.localhost</host>
|
||||
<load><jud>${LOCALBASE}/lib/jabber/jud.so</jud></load>
|
||||
<jud xmlns="jabber:config:jud">
|
||||
<vCard>
|
||||
<FN>Local Organization's User Directory</FN>
|
||||
<DESC>This service provides a simple user directory service.</DESC>
|
||||
<URL>http://foo.bar/</URL>
|
||||
</vCard>
|
||||
</jud>
|
||||
</service>
|
||||
|
||||
Add this section to the browse area of the jsm service to advertise it to
|
||||
your users (around line 245 of the sample config):
|
||||
|
||||
<service type="jud" jid="jud.localhost" name="My Organization's User Directory">
|
||||
<ns>jabber:iq:search</ns>
|
||||
<ns>jabber:iq:register</ns>
|
||||
</service>
|
||||
|
||||
Be sure to restart your server after reconfiguring.
|
1
net/jabber-jud/pkg-plist
Normal file
1
net/jabber-jud/pkg-plist
Normal file
@ -0,0 +1 @@
|
||||
lib/jabber/jud.so
|
Loading…
Reference in New Issue
Block a user