add jabber-aim 0.9.24c

Jabber User Directory module

PR:		37209
Submitted by:	Sean Chittenden <sean@chittenden.org>
This commit is contained in:
Ying-Chieh Liao 2002-04-19 04:22:50 +00:00
parent 99f743496c
commit 9f62a612e6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=57875
15 changed files with 277 additions and 0 deletions

View File

@ -0,0 +1,29 @@
# New ports collection makefile for: jabber-aim
# Date created: 14 Apr 2002
# Whom: Sean Chittenden <sean@chittenden.org>
#
# $FreeBSD$
PORTNAME= aim-transport
PORTVERSION= 0.9.24c
CATEGORIES= net
MASTER_SITES= http://download.jabber.org/dists/transports/aim-transport/
PKGNAMEPREFIX= jabber-
DIST_SUBDIR= jabber
MAINTAINER= sean@chittenden.org
BUILD_DEPENDS= ${LOCALBASE}/sbin/jabberd:${PORTSDIR}/net/jabber
USE_GMAKE= yes
USE_AUTOCONF= yes
CONFIGURE_ARGS+= --with-jabberd=${PREFIX}/include/jabber
do-install:
${INSTALL_DATA} ${WRKSRC}/src/aimtrans.so ${PREFIX}/lib/jabber/
post-install:
@cat pkg-message
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (jabber/aim-transport-0.9.24c.tar.gz) = a3c18654d41ebfaa3c74117004bf7d93

View File

@ -0,0 +1,41 @@
--- src/sessions.c Tue Nov 27 04:14:37 2001
+++ /usr/ports/distfiles/jabber/sessions.c.orig Wed Jan 30 09:07:47 2002
@@ -221,6 +221,29 @@
return 1;
}
+static int aim_icbmparaminfo(aim_session_t* sess, aim_frame_t* fr, ...)
+{
+ struct aim_icbmparameters *params;
+ va_list ap;
+
+ va_start(ap, fr);
+ params = va_arg(ap, struct aim_icbmparameters *);
+ va_end(ap);
+
+ /*
+ * Set these to your taste, or client medium. Setting minmsginterval
+ * higher is good for keeping yourself from getting flooded (esp
+ * if you're on a slow connection or something where that would be
+ * useful).
+ */
+ params->maxmsglen = 8000;
+ params->minmsginterval = 0; /* in milliseconds */
+
+ aim_seticbmparam(sess, params);
+
+ return 1;
+}
+
int at_conninitdone_admin(aim_session_t *sess,
aim_frame_t *command, ...)
{
@@ -411,6 +434,8 @@
AIM_CB_SPECIAL_CONNERR, at_parse_connerr, 0);
aim_conn_addhandler(sess, bosconn, 0x0001, 0x001f,
at_memrequest, 0);
+ aim_conn_addhandler(sess, bosconn, 0x0004, 0x0005,
+ aim_icbmparaminfo, 0);
am = pmalloco(s->p, sizeof(_at_mio));

View File

@ -0,0 +1 @@
Jabber User Directory module

View File

@ -0,0 +1,5 @@
The Jabber server (jabberd) is a daemon for Jabber clients to connect
and communicate with. JUD is allows clients to search for other users.
You can learn more about Jabber at:
WWW: http://server.jabber.org/

View File

@ -0,0 +1,60 @@
You can connect to ICQ using this transport, however you cannot
retrieve ICQ away status messages or user information, nor search for
users. A simple SMS sending hack is included, but for now responses do
not come through and no SMS sending confirmation is sent. For SMS,
send "SEND-SMS:number:text" to any ICQ user, for example
"SEND-SMS:+4917012345:Test".
To activate aim-transport, you will need to edit your jabber.xml to
tell jabberd to load this file, and let clients be aware of it's
availability. In the browse section of the jsm service you need to
add (uncomment out this block around line 248 of the sample
configuration):
<!--
* Don't forget to change aim.localhost to your hostname
* if you want to make this publicly available.
-->
<service type="aim" jid="aim.localhost" name="AIM Transport">
<ns>jabber:iq:gateway</ns>
<ns>jabber:iq:register</ns>
</service>
Next you need to add the lines to load in the transport and it's
configuration options. Please note that the following is
substantially different than what comes in the sample config
file. (near line 457):
<!--
* Don't forget to change aim.localhost to your hostname
* if you want to make this publicly available.
-->
<service id='aim.localhost'>
<load><aim_transport>${PREFIX}/lib/jabber/aimtrans.so</aim_transport></load>
<aimtrans xmlns='jabber:config:aimtrans'>
<!--
* This is the path to the aim binary neede by libfain for
* for providing access to AIM's servers
-->
<aimbinarydir>/path/to/aim_install</aimbinarydir>
<vCard>
<FN>AIM Transport</FN>
<DESC>An AIM Transport!</DESC>
<URL>http://foo.bar/</URL>
</vCard>
</aimtrans>
</service>
The most interesting of these is the <aimbinarydir/> flag. For
aimtransport to be able to work you need a valid directory from AIM
version 3.5.1670. It has to be that version. I would suggest
searching on Google. For legal reasons I can not distribute this
file.
The installer version that works for me is this with md5sum:
04eba0bd0ea5fe1756612e14663093aa /win/Install_AIM_3.5.1670.exe
After these changes everything should be running smoothly.

View File

@ -0,0 +1 @@
lib/jabber/aimtrans.so

View File

@ -191,6 +191,7 @@
SUBDIR += isc-dhcp3
SUBDIR += isic
SUBDIR += jabber
SUBDIR += jabber-aim
SUBDIR += jabber-conference
SUBDIR += jags
SUBDIR += javadc

29
net/jabber-aim/Makefile Normal file
View File

@ -0,0 +1,29 @@
# New ports collection makefile for: jabber-aim
# Date created: 14 Apr 2002
# Whom: Sean Chittenden <sean@chittenden.org>
#
# $FreeBSD$
PORTNAME= aim-transport
PORTVERSION= 0.9.24c
CATEGORIES= net
MASTER_SITES= http://download.jabber.org/dists/transports/aim-transport/
PKGNAMEPREFIX= jabber-
DIST_SUBDIR= jabber
MAINTAINER= sean@chittenden.org
BUILD_DEPENDS= ${LOCALBASE}/sbin/jabberd:${PORTSDIR}/net/jabber
USE_GMAKE= yes
USE_AUTOCONF= yes
CONFIGURE_ARGS+= --with-jabberd=${PREFIX}/include/jabber
do-install:
${INSTALL_DATA} ${WRKSRC}/src/aimtrans.so ${PREFIX}/lib/jabber/
post-install:
@cat pkg-message
.include <bsd.port.mk>

1
net/jabber-aim/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (jabber/aim-transport-0.9.24c.tar.gz) = a3c18654d41ebfaa3c74117004bf7d93

View File

@ -0,0 +1,41 @@
--- src/sessions.c Tue Nov 27 04:14:37 2001
+++ /usr/ports/distfiles/jabber/sessions.c.orig Wed Jan 30 09:07:47 2002
@@ -221,6 +221,29 @@
return 1;
}
+static int aim_icbmparaminfo(aim_session_t* sess, aim_frame_t* fr, ...)
+{
+ struct aim_icbmparameters *params;
+ va_list ap;
+
+ va_start(ap, fr);
+ params = va_arg(ap, struct aim_icbmparameters *);
+ va_end(ap);
+
+ /*
+ * Set these to your taste, or client medium. Setting minmsginterval
+ * higher is good for keeping yourself from getting flooded (esp
+ * if you're on a slow connection or something where that would be
+ * useful).
+ */
+ params->maxmsglen = 8000;
+ params->minmsginterval = 0; /* in milliseconds */
+
+ aim_seticbmparam(sess, params);
+
+ return 1;
+}
+
int at_conninitdone_admin(aim_session_t *sess,
aim_frame_t *command, ...)
{
@@ -411,6 +434,8 @@
AIM_CB_SPECIAL_CONNERR, at_parse_connerr, 0);
aim_conn_addhandler(sess, bosconn, 0x0001, 0x001f,
at_memrequest, 0);
+ aim_conn_addhandler(sess, bosconn, 0x0004, 0x0005,
+ aim_icbmparaminfo, 0);
am = pmalloco(s->p, sizeof(_at_mio));

View File

@ -0,0 +1 @@
Jabber User Directory module

5
net/jabber-aim/pkg-descr Normal file
View File

@ -0,0 +1,5 @@
The Jabber server (jabberd) is a daemon for Jabber clients to connect
and communicate with. JUD is allows clients to search for other users.
You can learn more about Jabber at:
WWW: http://server.jabber.org/

View File

@ -0,0 +1,60 @@
You can connect to ICQ using this transport, however you cannot
retrieve ICQ away status messages or user information, nor search for
users. A simple SMS sending hack is included, but for now responses do
not come through and no SMS sending confirmation is sent. For SMS,
send "SEND-SMS:number:text" to any ICQ user, for example
"SEND-SMS:+4917012345:Test".
To activate aim-transport, you will need to edit your jabber.xml to
tell jabberd to load this file, and let clients be aware of it's
availability. In the browse section of the jsm service you need to
add (uncomment out this block around line 248 of the sample
configuration):
<!--
* Don't forget to change aim.localhost to your hostname
* if you want to make this publicly available.
-->
<service type="aim" jid="aim.localhost" name="AIM Transport">
<ns>jabber:iq:gateway</ns>
<ns>jabber:iq:register</ns>
</service>
Next you need to add the lines to load in the transport and it's
configuration options. Please note that the following is
substantially different than what comes in the sample config
file. (near line 457):
<!--
* Don't forget to change aim.localhost to your hostname
* if you want to make this publicly available.
-->
<service id='aim.localhost'>
<load><aim_transport>${PREFIX}/lib/jabber/aimtrans.so</aim_transport></load>
<aimtrans xmlns='jabber:config:aimtrans'>
<!--
* This is the path to the aim binary neede by libfain for
* for providing access to AIM's servers
-->
<aimbinarydir>/path/to/aim_install</aimbinarydir>
<vCard>
<FN>AIM Transport</FN>
<DESC>An AIM Transport!</DESC>
<URL>http://foo.bar/</URL>
</vCard>
</aimtrans>
</service>
The most interesting of these is the <aimbinarydir/> flag. For
aimtransport to be able to work you need a valid directory from AIM
version 3.5.1670. It has to be that version. I would suggest
searching on Google. For legal reasons I can not distribute this
file.
The installer version that works for me is this with md5sum:
04eba0bd0ea5fe1756612e14663093aa /win/Install_AIM_3.5.1670.exe
After these changes everything should be running smoothly.

1
net/jabber-aim/pkg-plist Normal file
View File

@ -0,0 +1 @@
lib/jabber/aimtrans.so