Overall port clean up

CC/CFLAGS safeness

Submitted by:	Jeremy Norris <ishmael@home.com>
PR:		ports/22171
This commit is contained in:
Mario Sergio Fujikawa Ferreira 2000-10-28 13:05:25 +00:00
parent b121518905
commit a82e50a994
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=34354
10 changed files with 114 additions and 62 deletions

View File

@ -13,11 +13,19 @@ DISTNAME= ${PKGNAME}-src
MAINTAINER= ports@FreeBSD.org
USE_GMAKE= yes
MAN1= mpeg_encode.1
MANCOMPRESSED= yes
WRKSRC= ${WRKDIR}/mpeg_encode
WRKSRC= ${WRKDIR}/${PORTNAME}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mpeg_encode ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/docs/mpeg_encode.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
.for i in users-guide.ps template.param
${INSTALL_DATA} ${WRKSRC}/docs/${i} ${PREFIX}/share/doc/${PORTNAME}
.endfor
.endif
.include <bsd.port.mk>

View File

@ -13,31 +13,3 @@
#if !defined(sco) && !defined(sgi) && !defined(IRIX)
extern char* malloc();
#endif
--- ./libpnmrw.c~ Thu Aug 1 08:52:14 1996
+++ ./libpnmrw.c Thu Aug 1 08:51:26 1996
@@ -126,7 +126,9 @@
pm_perror( reason )
char* reason;
{
+#ifndef __FreeBSD__
extern char* sys_errlist[];
+#endif
extern int errno;
char* e;
--- Makefile~ Wed Aug 16 17:16:56 1995
+++ Makefile Thu Aug 1 09:00:04 1996
@@ -182,6 +182,13 @@
all: mpeg_encode
+install:
+ install -c mpeg_encode ${PREFIX}/bin
+ install -c -m 644 mpeg_encode.1 ${PREFIX}/man/man1
+ gzip -9nf ${PREFIX}/man/man1/mpeg_encode.1
+ mkdir -p ${PREFIX}/share/doc/mpeg_encode
+ install -c docs/users-guide.ps docs/template.param ${PREFIX}/share/doc/mpeg_encode
+
#########
# TESTS #
#########

View File

@ -0,0 +1,11 @@
--- ./libpnmrw.c~ Thu Aug 1 08:52:14 1996
+++ ./libpnmrw.c Thu Aug 1 08:51:26 1996
@@ -126,7 +126,9 @@
pm_perror( reason )
char* reason;
{
+#ifndef __FreeBSD__
extern char* sys_errlist[];
+#endif
extern int errno;
char* e;

View File

@ -0,0 +1,20 @@
--- Makefile~ Wed Aug 16 17:16:56 1995
+++ Makefile Fri Oct 20 19:20:05 2000
@@ -68,7 +68,7 @@
#####################################################################
# COMPILER # specify compiler; should be ANSI-compliant if possible #
#####################################################################
-CC = gcc
+CC ?= gcc
################################################
# MAKE # command to use for the "make" command #
@@ -96,7 +96,7 @@
#
# gcc
-CFLAGS = $(INCLUDEDIR) $(DEBUGFLAG) -Wall -Wmissing-prototypes $(PROFLAG) $(PROTOFLAG)
+CFLAGS += $(INCLUDEDIR) -Wall -Wmissing-prototypes $(PROFLAG) $(PROTOFLAG)
# gcc-strict
#CFLAGS = $(INCLUDEDIR) $(DEBUGFLAG) -pedantic -Wall -Waggregate-return -Wtraditional -Wshadow -Wpointer-arith -Wno-parentheses -Wwrite-strings -Wconversion -Wcast-qual -Wcast-align -Wnested-externs -Wuninitialized -Wmissing-prototypes $(PROFLAG) $(PROTOFLAG)

View File

@ -0,0 +1,15 @@
--- jpeg/Makefile.orig Fri Aug 4 18:27:00 1995
+++ jpeg/Makefile Fri Oct 20 19:05:22 2000
@@ -21,10 +21,10 @@
manext = 1
# The name of your C compiler:
-CC= gcc
+CC?= gcc
# You may need to adjust these cc options:
-CFLAGS= -O -I$(srcdir)
+CFLAGS+= -I$(srcdir)
# Generally, we recommend defining any configuration symbols in jconfig.h,
# NOT via -D switches here.
# However, any special defines for ansi2knr.c may be included here:

View File

@ -13,11 +13,19 @@ DISTNAME= ${PKGNAME}-src
MAINTAINER= ports@FreeBSD.org
USE_GMAKE= yes
MAN1= mpeg_encode.1
MANCOMPRESSED= yes
WRKSRC= ${WRKDIR}/mpeg_encode
WRKSRC= ${WRKDIR}/${PORTNAME}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mpeg_encode ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/docs/mpeg_encode.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
.for i in users-guide.ps template.param
${INSTALL_DATA} ${WRKSRC}/docs/${i} ${PREFIX}/share/doc/${PORTNAME}
.endfor
.endif
.include <bsd.port.mk>

View File

@ -13,31 +13,3 @@
#if !defined(sco) && !defined(sgi) && !defined(IRIX)
extern char* malloc();
#endif
--- ./libpnmrw.c~ Thu Aug 1 08:52:14 1996
+++ ./libpnmrw.c Thu Aug 1 08:51:26 1996
@@ -126,7 +126,9 @@
pm_perror( reason )
char* reason;
{
+#ifndef __FreeBSD__
extern char* sys_errlist[];
+#endif
extern int errno;
char* e;
--- Makefile~ Wed Aug 16 17:16:56 1995
+++ Makefile Thu Aug 1 09:00:04 1996
@@ -182,6 +182,13 @@
all: mpeg_encode
+install:
+ install -c mpeg_encode ${PREFIX}/bin
+ install -c -m 644 mpeg_encode.1 ${PREFIX}/man/man1
+ gzip -9nf ${PREFIX}/man/man1/mpeg_encode.1
+ mkdir -p ${PREFIX}/share/doc/mpeg_encode
+ install -c docs/users-guide.ps docs/template.param ${PREFIX}/share/doc/mpeg_encode
+
#########
# TESTS #
#########

View File

@ -0,0 +1,11 @@
--- ./libpnmrw.c~ Thu Aug 1 08:52:14 1996
+++ ./libpnmrw.c Thu Aug 1 08:51:26 1996
@@ -126,7 +126,9 @@
pm_perror( reason )
char* reason;
{
+#ifndef __FreeBSD__
extern char* sys_errlist[];
+#endif
extern int errno;
char* e;

View File

@ -0,0 +1,20 @@
--- Makefile~ Wed Aug 16 17:16:56 1995
+++ Makefile Fri Oct 20 19:20:05 2000
@@ -68,7 +68,7 @@
#####################################################################
# COMPILER # specify compiler; should be ANSI-compliant if possible #
#####################################################################
-CC = gcc
+CC ?= gcc
################################################
# MAKE # command to use for the "make" command #
@@ -96,7 +96,7 @@
#
# gcc
-CFLAGS = $(INCLUDEDIR) $(DEBUGFLAG) -Wall -Wmissing-prototypes $(PROFLAG) $(PROTOFLAG)
+CFLAGS += $(INCLUDEDIR) -Wall -Wmissing-prototypes $(PROFLAG) $(PROTOFLAG)
# gcc-strict
#CFLAGS = $(INCLUDEDIR) $(DEBUGFLAG) -pedantic -Wall -Waggregate-return -Wtraditional -Wshadow -Wpointer-arith -Wno-parentheses -Wwrite-strings -Wconversion -Wcast-qual -Wcast-align -Wnested-externs -Wuninitialized -Wmissing-prototypes $(PROFLAG) $(PROTOFLAG)

View File

@ -0,0 +1,15 @@
--- jpeg/Makefile.orig Fri Aug 4 18:27:00 1995
+++ jpeg/Makefile Fri Oct 20 19:05:22 2000
@@ -21,10 +21,10 @@
manext = 1
# The name of your C compiler:
-CC= gcc
+CC?= gcc
# You may need to adjust these cc options:
-CFLAGS= -O -I$(srcdir)
+CFLAGS+= -I$(srcdir)
# Generally, we recommend defining any configuration symbols in jconfig.h,
# NOT via -D switches here.
# However, any special defines for ansi2knr.c may be included here: