New Port: security/cksfv
Create or manipulate Simple File Verification (SFV) checksum files PR: 22075 Submitted by: Johann Visagie <johann@egenetics.com>
This commit is contained in:
parent
d391bfd2dd
commit
b121518905
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=34353
@ -12,6 +12,7 @@
|
||||
SUBDIR += cfs
|
||||
SUBDIR += checkpassword
|
||||
SUBDIR += chrootuid
|
||||
SUBDIR += cksfv
|
||||
SUBDIR += cops
|
||||
SUBDIR += crack
|
||||
SUBDIR += cyrus-sasl
|
||||
|
26
security/cksfv/Makefile
Normal file
26
security/cksfv/Makefile
Normal file
@ -0,0 +1,26 @@
|
||||
# New ports collection makefile for: cksfv
|
||||
# Date created: 18 October 2000
|
||||
# Whom: Johann Visagie <johann@egenetics.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= cksfv
|
||||
PORTVERSION= 1.1
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.fodder.org/cksfv/
|
||||
|
||||
MAINTAINER= johann@egenetics.com
|
||||
|
||||
BUILD_WRKSRC= ${WRKSRC}/src
|
||||
INSTALL_WRKSRC= ${BUILD_WRKSRC}
|
||||
USE_GMAKE= yes
|
||||
ALL_TARGET= cksfv
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@ ${MKDIR} ${PREFIX}/share/doc/cksfv
|
||||
@ ${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/cksfv
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
security/cksfv/distinfo
Normal file
1
security/cksfv/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (cksfv-1.1.tar.gz) = e32e3fc05b99ce8ff06af57df3f16952
|
20
security/cksfv/files/patch-src-Makefile
Normal file
20
security/cksfv/files/patch-src-Makefile
Normal file
@ -0,0 +1,20 @@
|
||||
--- src/Makefile.orig Mon May 22 23:57:05 2000
|
||||
+++ src/Makefile Wed Oct 18 10:14:25 2000
|
||||
@@ -17,14 +17,15 @@
|
||||
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
|
||||
|
||||
PROG= cksfv
|
||||
+CC?= gcc
|
||||
CFLAGS+= -Wall -Werror -O2
|
||||
SRCS= cksfv.c print.c crc32.c readsfv.c newsfv.c
|
||||
|
||||
cksfv: $(SRCS)
|
||||
- gcc $(CFLAGS) -o $(PROG) $(SRCS)
|
||||
+ $(CC) $(CFLAGS) -o $(PROG) $(SRCS)
|
||||
|
||||
install: cksfv
|
||||
- cp $(PROG) /usr/local/bin
|
||||
+ $(BSD_INSTALL_PROGRAM) $(PROG) $(PREFIX)/bin
|
||||
|
||||
clean:
|
||||
rm -f *.o *~ *.core $(PROG)
|
1
security/cksfv/pkg-comment
Normal file
1
security/cksfv/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Create or manipulate Simple File Verification (SFV) checksum files
|
13
security/cksfv/pkg-descr
Normal file
13
security/cksfv/pkg-descr
Normal file
@ -0,0 +1,13 @@
|
||||
The Simple File Verification (SFV) system is a file integrity verification
|
||||
system which is popular on some platforms. A software package may be
|
||||
accompanied by an SFV file (usually with extension .sfv) which contains
|
||||
CRC-32 checksums for all the files that comprise the package.
|
||||
|
||||
cksfv (Check SFV) can both create simple file verification (SFV) files, and
|
||||
test file integrity against existing SFV files.
|
||||
|
||||
Licence: GPL
|
||||
Author: Bryan Call <bc@fodder.org>
|
||||
WWW: http://www.fodder.org/cksfv/
|
||||
|
||||
-- Johann Visagie <johann@egenetics.com>
|
3
security/cksfv/pkg-plist
Normal file
3
security/cksfv/pkg-plist
Normal file
@ -0,0 +1,3 @@
|
||||
bin/cksfv
|
||||
share/doc/cksfv/README
|
||||
@dirrm share/doc/cksfv
|
Loading…
Reference in New Issue
Block a user