add cln, a Class Library for Numbers

This commit is contained in:
Ying-Chieh Liao 2001-02-11 09:32:40 +00:00
parent 9635aa5387
commit 992ac30075
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38201
8 changed files with 186 additions and 0 deletions

View File

@ -45,6 +45,7 @@
SUBDIR += cflow
SUBDIR += clanlib
SUBDIR += clig
SUBDIR += cln
SUBDIR += codecrusader
SUBDIR += codemedic
SUBDIR += commoncpp

29
devel/cln/Makefile Normal file
View File

@ -0,0 +1,29 @@
# ex:ts=8
# New ports collection makefile for: cln
# Date created: Fab 11, 2001
# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= cln
PORTVERSION= 1.1
CATEGORIES= devel math
MASTER_SITES= ftp://ftp.ilog.fr/pub/Users/haible/gnu/ \
ftp://ftp.santafe.edu/pub/gnu/ \
ftp://ftpthep.physik.uni-mainz.de/pub/gnu/
MAINTAINER= ijliao@FreeBSD.org
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datadir=${PREFIX}/share/cln --infodir=${PREFIX}/info \
--mandir=${PREFIX}/man
USE_GMAKE= yes
INSTALLS_SHLIB= yes
MAN1= cln-config.1
.include <bsd.port.mk>

1
devel/cln/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (cln-1.1.tar.gz) = 8054193072447a2a48da160ef03430ee

View File

@ -0,0 +1,19 @@
--- Makefile.in.orig Sun Feb 11 16:52:48 2001
+++ Makefile.in Sun Feb 11 17:03:58 2001
@@ -33,14 +33,13 @@
install : installdirs force
cd @subdir@; $(MAKE) install
- $(INSTALL_PROGRAM) cln-config $(DESTDIR)$(bindir)/cln-config
+ $(INSTALL) cln-config $(DESTDIR)$(bindir)/cln-config
$(INSTALL_DATA) cln-config.1 $(DESTDIR)$(mandir)/man1/cln-config.1
- $(INSTALL_DATA) cln.m4 $(DESTDIR)$(datadir)/aclocal/cln.m4
+ $(INSTALL_DATA) cln.m4 $(DESTDIR)$(prefix)/share/aclocal/cln.m4
installdirs : force
cd @subdir@; $(MAKE) installdirs
$(MKDIR) $(DESTDIR)$(mandir)/man1
- $(MKDIR) $(DESTDIR)$(datadir)/aclocal
$(MKDIR) $(DESTDIR)$(bindir)
uninstall : force

View File

@ -0,0 +1,10 @@
--- doc/Makefile.in.orig Sun Feb 11 17:11:56 2001
+++ doc/Makefile.in Sun Feb 11 17:24:01 2001
@@ -81,6 +81,7 @@
install : all installdirs force
$(INSTALL_DATA) $(srcdir)/$(PACKAGE).info $(DESTDIR)$(infodir)/$(PACKAGE).info
+ install-info $(srcdir)/$(PACKAGE).info $(DESTDIR)$(infodir)/dir
$(INSTALL_DATA) $(srcdir)/$(PACKAGE)_*.html $(DESTDIR)$(htmldir)
$(INSTALL_DATA) $(srcdir)/$(PACKAGE).dvi $(DESTDIR)$(dvidir)/$(PACKAGE).dvi

1
devel/cln/pkg-comment Normal file
View File

@ -0,0 +1 @@
Class Library for Numbers

20
devel/cln/pkg-descr Normal file
View File

@ -0,0 +1,20 @@
CLN is a library for computations with all kinds of numbers. It has a
rich set of number classes:
- Integers (with unlimited precision),
- Rational numbers,
- Floating-point numbers:
Short float,
Single float,
Double float,
Long float (with unlimited precision),
- Complex numbers,
- Modular integers (integers modulo a fixed integer),
- Univariate polynomials.
The subtypes of the complex numbers among these are exactly the types
of numbers known to the Common Lisp language. Therefore CLN can be used
for Common Lisp implementations, giving `CLN' another meaning: it
becomes an abbreviation of "Common Lisp Numbers".
WWW: http://clisp.cons.org/~haible/packages-cln.html

105
devel/cln/pkg-plist Normal file
View File

@ -0,0 +1,105 @@
bin/cln-config
share/aclocal/cln.m4
@unexec install-info --delete %D/info/cln.info %D/info/dir
info/cln.info
@exec install-info %D/info/cln.info %D/info/dir
include/cln/GV.h
include/cln/GV_complex.h
include/cln/GV_integer.h
include/cln/GV_modinteger.h
include/cln/GV_number.h
include/cln/GV_rational.h
include/cln/GV_real.h
include/cln/SV.h
include/cln/SV_complex.h
include/cln/SV_integer.h
include/cln/SV_number.h
include/cln/SV_rational.h
include/cln/SV_real.h
include/cln/SV_ringelt.h
include/cln/V.h
include/cln/abort.h
include/cln/cln.h
include/cln/complex.h
include/cln/complex_class.h
include/cln/complex_io.h
include/cln/complex_ring.h
include/cln/condition.h
include/cln/config.h
include/cln/dfloat.h
include/cln/dfloat_class.h
include/cln/dfloat_io.h
include/cln/ffloat.h
include/cln/ffloat_class.h
include/cln/ffloat_io.h
include/cln/float.h
include/cln/float_class.h
include/cln/float_io.h
include/cln/floatformat.h
include/cln/floatparam.h
include/cln/input.h
include/cln/integer.h
include/cln/integer_class.h
include/cln/integer_io.h
include/cln/integer_ring.h
include/cln/intparam.h
include/cln/io.h
include/cln/lfloat.h
include/cln/lfloat_class.h
include/cln/lfloat_io.h
include/cln/malloc.h
include/cln/modinteger.h
include/cln/modules.h
include/cln/null_ring.h
include/cln/number.h
include/cln/number_io.h
include/cln/numtheory.h
include/cln/object.h
include/cln/output.h
include/cln/proplist.h
include/cln/random.h
include/cln/rational.h
include/cln/rational_class.h
include/cln/rational_io.h
include/cln/rational_ring.h
include/cln/real.h
include/cln/real_class.h
include/cln/real_io.h
include/cln/real_ring.h
include/cln/ring.h
include/cln/sfloat.h
include/cln/sfloat_class.h
include/cln/sfloat_io.h
include/cln/string.h
include/cln/symbol.h
include/cln/timing.h
include/cln/types.h
include/cln/univpoly.h
include/cln/univpoly_complex.h
include/cln/univpoly_integer.h
include/cln/univpoly_modint.h
include/cln/univpoly_rational.h
include/cln/univpoly_real.h
include/cln/version.h
@dirrm include/cln
lib/libcln.a
lib/libcln.so
lib/libcln.so.1
share/cln/html/cln_1.html
share/cln/html/cln_10.html
share/cln/html/cln_11.html
share/cln/html/cln_12.html
share/cln/html/cln_13.html
share/cln/html/cln_2.html
share/cln/html/cln_3.html
share/cln/html/cln_4.html
share/cln/html/cln_5.html
share/cln/html/cln_6.html
share/cln/html/cln_7.html
share/cln/html/cln_8.html
share/cln/html/cln_9.html
share/cln/html/cln_toc.html
share/cln/dvi/cln.dvi
@dirrm share/cln/html
@dirrm share/cln/dvi
@dirrm share/cln