SCEPTRE (System for Circuit Evaluation and Prediction of Transient
Radiation Effects) is a general purpose circuit analysis program which provides all three major analyses, AC, DC, and transient analysis, on either linear or nonlinear networks. It employs a free-form input language and state variable methods to simulate problems of interest to electrical engineers. Requested-by: "Pedro F. Giffuni" <pfg1+@pitt.edu>
This commit is contained in:
parent
9c459f6dd4
commit
9635aa5387
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38200
@ -14,6 +14,7 @@
|
||||
SUBDIR += pcb
|
||||
SUBDIR += pisces
|
||||
SUBDIR += qcad
|
||||
SUBDIR += sceptre
|
||||
SUBDIR += sis
|
||||
SUBDIR += spice
|
||||
SUBDIR += tkgate
|
||||
|
26
cad/sceptre/Makefile
Normal file
26
cad/sceptre/Makefile
Normal file
@ -0,0 +1,26 @@
|
||||
# New ports collection makefile for: sceptre
|
||||
# Date created: 11 February 2001
|
||||
# Whom: grog
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= sceptre
|
||||
PORTVERSION= 00.317
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= ftp://novilux.fh-friedberg.de/pub/sceptre/
|
||||
|
||||
MAINTAINER= grog
|
||||
|
||||
BUILD_DEPENDS= f77:${PORTSDIR}/lang/f77
|
||||
|
||||
NO_WRKSUBDIR= YES
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/sceptre
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/doc_en.pdf ${PREFIX}/share/doc/sceptre/doc_en.pdf
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/doc_ger.pdf ${PREFIX}/share/doc/sceptre/doc_ger.pdf
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
cad/sceptre/distinfo
Normal file
1
cad/sceptre/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (sceptre-00.317.tar.gz) = 2ddec287e3819d2bd00f552336587976
|
19
cad/sceptre/files/patch-aa
Normal file
19
cad/sceptre/files/patch-aa
Normal file
@ -0,0 +1,19 @@
|
||||
--- x3/qqqcpu.f Mon Oct 4 03:53:42 1999
|
||||
+++ x3/qqqcpu.f Sun Feb 11 14:34:50 2001
|
||||
@@ -9,9 +9,14 @@
|
||||
data r0 /1d6/
|
||||
intrinsic ETime
|
||||
|
||||
- CALL ETime(RESULT, TARRAY)
|
||||
+C This appears not to be complete. The original code contained the
|
||||
+C following two code lines, which generate an "incorrect type" error.
|
||||
+C Since I don't have a description of ETIME, just carry out the sentiment
|
||||
+C of the comment above
|
||||
+C CALL ETime(RESULT, TARRAY)
|
||||
|
||||
- r2 = r0 - tarray(1)
|
||||
+C r2 = r0 - tarray(1)
|
||||
+ r2 = r0
|
||||
|
||||
RETURN
|
||||
|
41
cad/sceptre/files/patch-ab
Normal file
41
cad/sceptre/files/patch-ab
Normal file
@ -0,0 +1,41 @@
|
||||
--- Makefile~ Sun Nov 12 17:55:44 2000
|
||||
+++ Makefile Sun Feb 11 16:30:32 2001
|
||||
@@ -1,4 +1,4 @@
|
||||
-FC = g77
|
||||
+FC = f77
|
||||
FFLAGS = -fno-automatic -O
|
||||
BASEDIR = `pwd`
|
||||
INSTDIR = /usr/local
|
||||
@@ -13,19 +13,19 @@
|
||||
cd x1; ${MAKE} "FC=${FC}" "FFLAGS=${FFLAGS}"
|
||||
cd x2; ${MAKE} "FC=${FC}" "FFLAGS=${FFLAGS}"
|
||||
install:
|
||||
- install -s -m 755 x1/exec1 ${BINDIR}
|
||||
- install -m 644 x2/exec2.o ${LIBDIR}
|
||||
- install -m 644 x2/libx2.a ${LIBDIR}
|
||||
- install -s -m 755 x3/ngp_gnu ${BINDIR}
|
||||
- install -s -m 755 x3/asa ${BINDIR}
|
||||
- install -m 644 x3/libx3.a ${LIBDIR}
|
||||
- install -m 755 bin/sceptre ${BINDIR}
|
||||
- install -m 755 bin/sceptre.inst ${BINDIR}
|
||||
- install -m 755 bin/ngp ${BINDIR}
|
||||
- install -m 644 lib/usrlib.a ${LIBDIR}
|
||||
- install -m 644 lib/modellib.dat ${LIBDIR}
|
||||
- install -d ${ETCDIR}
|
||||
- install -m 644 etc/ngp.rc ${ETCDIR}
|
||||
+ install -c -s -m 755 x1/exec1 ${BINDIR}
|
||||
+ install -c -m 644 x2/exec2.o ${LIBDIR}
|
||||
+ install -c -m 644 x2/libx2.a ${LIBDIR}
|
||||
+ install -c -s -m 755 x3/ngp_gnu ${BINDIR}
|
||||
+ install -c -s -m 755 x3/asa ${BINDIR}
|
||||
+ install -c -m 644 x3/libx3.a ${LIBDIR}
|
||||
+ install -c -m 755 bin/sceptre ${BINDIR}
|
||||
+ install -c -m 755 bin/sceptre.inst ${BINDIR}
|
||||
+ install -c -m 755 bin/ngp ${BINDIR}
|
||||
+ install -c -m 644 lib/usrlib.a ${LIBDIR}
|
||||
+ install -c -m 644 lib/modellib.dat ${LIBDIR}
|
||||
+ install -c -d ${ETCDIR}
|
||||
+ install -c -m 644 etc/ngp.rc ${ETCDIR}
|
||||
@echo "installation finished"
|
||||
uninstall:
|
||||
@rm -fv ${BINDIR}/exec1
|
1
cad/sceptre/pkg-comment
Normal file
1
cad/sceptre/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
SCEPTRE is a general purpose circuit analysis program.
|
10
cad/sceptre/pkg-descr
Normal file
10
cad/sceptre/pkg-descr
Normal file
@ -0,0 +1,10 @@
|
||||
SCEPTRE (System for Circuit Evaluation and Prediction of Transient
|
||||
Radiation Effects) is a general purpose circuit analysis program which
|
||||
provides all three major analyses, AC, DC, and transient analysis, on
|
||||
either linear or nonlinear networks. It employs a free-form input
|
||||
language and state variable methods to simulate problems of interest
|
||||
to electrical engineers.
|
||||
|
||||
This package does not include online documentation. Documentation in
|
||||
PDF format, in English and German, is available in the directory
|
||||
work/sceptre*/doc.
|
3
cad/sceptre/pkg-message
Normal file
3
cad/sceptre/pkg-message
Normal file
@ -0,0 +1,3 @@
|
||||
This package does not include online documentation. You will find PDF
|
||||
documents in English and German in the directory
|
||||
/usr/local/share/doc/sceptre.
|
15
cad/sceptre/pkg-plist
Normal file
15
cad/sceptre/pkg-plist
Normal file
@ -0,0 +1,15 @@
|
||||
bin/exec1
|
||||
bin/ngp_gnu
|
||||
bin/asa
|
||||
bin/sceptre
|
||||
bin/sceptre.inst
|
||||
bin/ngp
|
||||
etc/ngp.rc
|
||||
lib/exec2.o
|
||||
lib/libx2.a
|
||||
lib/libx3.a
|
||||
lib/usrlib.a
|
||||
lib/modellib.dat
|
||||
share/doc/sceptre/doc_en.pdf
|
||||
share/doc/sceptre/doc_ger.pdf
|
||||
@dirrm share/doc/sceptre
|
Loading…
Reference in New Issue
Block a user