Add fluctuate 1.30, a program to fit population models.
This commit is contained in:
parent
cd0583a2a8
commit
52619bca7a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=45885
@ -11,6 +11,7 @@
|
||||
SUBDIR += fasta
|
||||
SUBDIR += fasta3
|
||||
SUBDIR += fastdnaml
|
||||
SUBDIR += fluctuate
|
||||
SUBDIR += gaussian98
|
||||
SUBDIR += genpak
|
||||
SUBDIR += gperiodic
|
||||
|
29
biology/fluctuate/Makefile
Normal file
29
biology/fluctuate/Makefile
Normal file
@ -0,0 +1,29 @@
|
||||
# New ports collection makefile for: fluctuate
|
||||
# Date created: 6 August 2001
|
||||
# Whom: Johann Visagie <wjv@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= fluctuate
|
||||
PORTVERSION= 1.30
|
||||
CATEGORIES= biology
|
||||
MASTER_SITES= ftp://evolution.genetics.washington.edu/pub/lamarc/
|
||||
DISTNAME= ${PORTNAME}
|
||||
EXTRACT_SUFX= .tar.Z
|
||||
|
||||
MAINTAINER= wjv@FreeBSD.org
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
ALL_TARGET= ${PORTNAME}
|
||||
|
||||
do-install:
|
||||
@ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@ ${MKDIR} ${DOCSDIR}
|
||||
@ ${INSTALL_DATA} ${WRKSRC}/*.doc ${DOCSDIR}/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
biology/fluctuate/distinfo
Normal file
1
biology/fluctuate/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (fluctuate.tar.Z) = 86619e6885fdf172b39dd8a7eb814bba
|
40
biology/fluctuate/files/patch-Makefile
Normal file
40
biology/fluctuate/files/patch-Makefile
Normal file
@ -0,0 +1,40 @@
|
||||
--- Makefile.orig Thu Sep 3 00:56:03 1998
|
||||
+++ Makefile Mon Aug 6 15:58:49 2001
|
||||
@@ -1,30 +1,28 @@
|
||||
LIBS = -lm
|
||||
BINDIR = ./bin
|
||||
-CFLAGS = -O
|
||||
-CC = cc $(CFLAGS)
|
||||
|
||||
fluctuate : fluctuate.o fluc_modellike.o getdata.o plot.o wrap.o \
|
||||
coal_modellike.o
|
||||
- $(CC) fluctuate.o fluc_modellike.o getdata.o plot.o wrap.o \
|
||||
+ $(CC) $(CFLAGS) fluctuate.o fluc_modellike.o getdata.o plot.o wrap.o \
|
||||
coal_modellike.o $(LIBS) -o fluctuate
|
||||
|
||||
clean :
|
||||
rm fluctuate.o fluc_modellike.o coal_modellike.o getdata.o plot.o
|
||||
|
||||
fluctuate.o : fluctuate.c
|
||||
- $(CC) -c fluctuate.c
|
||||
+ $(CC) $(CFLAGS) -c fluctuate.c
|
||||
|
||||
fluc_modellike.o : fluc_modellike.c
|
||||
- $(CC) -c fluc_modellike.c
|
||||
+ $(CC) $(CFLAGS) -c fluc_modellike.c
|
||||
|
||||
coal_modellike.o : coal_modellike.c
|
||||
- $(CC) -c coal_modellike.c
|
||||
+ $(CC) $(CFLAGS) -c coal_modellike.c
|
||||
|
||||
getdata.o : getdata.c
|
||||
- $(CC) -c getdata.c
|
||||
+ $(CC) $(CFLAGS) -c getdata.c
|
||||
|
||||
plot.o : plot.c
|
||||
- $(CC) -c plot.c
|
||||
+ $(CC) $(CFLAGS) -c plot.c
|
||||
|
||||
wrap.o : wrap.c
|
||||
- $(CC) -c wrap.c
|
||||
+ $(CC) $(CFLAGS) -c wrap.c
|
1
biology/fluctuate/pkg-comment
Normal file
1
biology/fluctuate/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A program to fit population models
|
13
biology/fluctuate/pkg-descr
Normal file
13
biology/fluctuate/pkg-descr
Normal file
@ -0,0 +1,13 @@
|
||||
Fluctuate fits the model which has a single population which has been growing
|
||||
(or shrinking) according to an exponential growth law. It estimates 4Nu and
|
||||
g, where N is the effective population size, u is the neutral mutation rate
|
||||
per site, and g is the growth rate of the population.
|
||||
|
||||
Fluctuate forms part of the Lamarc (Likelihood Analysis with Metropolis
|
||||
Algorithm using Random Coalescence) suite. See:
|
||||
|
||||
http://evolution.genetics.washington.edu/lamarc.html
|
||||
|
||||
WWW: http://evolution.genetics.washington.edu/lamarc/fluctuate.html
|
||||
|
||||
-- Johann Visagie <wjv@FreeBSD.org>
|
4
biology/fluctuate/pkg-plist
Normal file
4
biology/fluctuate/pkg-plist
Normal file
@ -0,0 +1,4 @@
|
||||
bin/fluctuate
|
||||
%%PORTDOCS%%share/doc/fluctuate/errors.doc
|
||||
%%PORTDOCS%%share/doc/fluctuate/fluctuate.doc
|
||||
%%PORTDOCS%%@dirrm share/doc/fluctuate
|
Loading…
Reference in New Issue
Block a user