Add coalesce 1.50, a program to fit population models.

This commit is contained in:
Johann Visagie 2001-08-06 14:41:58 +00:00
parent a4dc6fd25a
commit cd0583a2a8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=45884
7 changed files with 73 additions and 0 deletions

View File

@ -5,6 +5,7 @@
SUBDIR += biojava
SUBDIR += chemeq
SUBDIR += clustalw
SUBDIR += coalesce
SUBDIR += deft
SUBDIR += emboss
SUBDIR += fasta

29
biology/coalesce/Makefile Normal file
View File

@ -0,0 +1,29 @@
# New ports collection makefile for: coalesce
# Date created: 6 August 2001
# Whom: Johann Visagie <wjv@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= coalesce
PORTVERSION= 1.50
CATEGORIES= biology
MASTER_SITES= ftp://evolution.genetics.washington.edu/pub/lamarc/
DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .tar.Z
MAINTAINER= wjv@FreeBSD.org
NO_WRKSUBDIR= yes
ALL_TARGET= ${PORTNAME}
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
@ ${INSTALL_DATA} ${WRKSRC}/*.doc ${DOCSDIR}/
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (coalesce.tar.Z) = feea2925ac514e644c53c27c497f4081

View File

@ -0,0 +1,25 @@
--- Makefile.orig Thu Feb 29 18:00:09 1996
+++ Makefile Mon Aug 6 16:32:10 2001
@@ -1,20 +1,9 @@
LIBS = -lm
BINDIR = ./bin
-CFLAGS = -g
-CC = cc $(CFLAGS)
+CFLAGS += -g
DCC = gcc -g -DDMALLOC_FUNC_CHECK -ansi -pedantic
DLIBS = -lm -L/usr/local/lib -ldmalloc
-# -O
PROGS = coalesce fluctuate
coalesce : coalesce.c constants.h lamarc.h
- $(CC) coalesce.c $(LIBS) -o coalesce
-
-modellike.o : modellike.c
- $(CC) -c modellike.c
-
-fluctuate.o : fluctuate.c
- $(CC) -c fluctuate.c
-
-fluctuate : fluctuate.o modellike.o
- $(CC) fluctuate.o modellike.o $(LIBS) -o fluctuate
+ $(CC) $(CFLAGS) coalesce.c $(LIBS) -o coalesce

View File

@ -0,0 +1 @@
A program to fit population models

View File

@ -0,0 +1,12 @@
Coalesce fits the model which has a single population of constant size, and
estimates 4Nu, where N is the effective population size and u is the neutral
mutation rate per site
Coalesce forms part of the Lamarc (Likelihood Analysis with Metropolis
Algorithm using Random Coalescence) suite. See:
http://evolution.genetics.washington.edu/lamarc.html
WWW: http://evolution.genetics.washington.edu/lamarc/recombine.html
-- Johann Visagie <wjv@FreeBSD.org>

View File

@ -0,0 +1,4 @@
bin/coalesce
%%PORTDOCS%%share/doc/coalesce/coalesce.doc
%%PORTDOCS%%share/doc/coalesce/errors.doc
%%PORTDOCS%%@dirrm share/doc/coalesce