Adding xls2xml version 1.0.0.

A utility for converting MS Excel files to XML.

PR:		14705 (2 of 2)
Submitted by:	Maxim Sobolev <sobomax@altavista.net>
This commit is contained in:
Steve Price 1999-12-27 02:12:34 +00:00
parent 2236497d16
commit 17a34ce292
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24139
9 changed files with 77 additions and 0 deletions

View File

@ -72,6 +72,7 @@
SUBDIR += urlview
SUBDIR += wdiff
SUBDIR += word2x
SUBDIR += xls2xml
SUBDIR += xml4j
SUBDIR += xp
SUBDIR += xt

21
textproc/xls2xml/Makefile Normal file
View File

@ -0,0 +1,21 @@
# New ports collection makefile for: xls2xml
# Version required: 1.0.0
# Date created: 4 November 1999
# Whom: Maxim Sobolev <sobomax@altavista.net>
#
# $FreeBSD$
#
DISTNAME= xls2xml-1.0.0
CATEGORIES= textproc
MASTER_SITES= http://arturo.directmail.org/filters/archive/ \
http://homepages.go.com/~sobomax/filtersweb/
MAINTAINER= sobomax@altavista.net
LIB_DEPENDS= cole.2:${PORTSDIR}/textproc/cole \
xml.5:${PORTSDIR}/textproc/libxml
USE_LIBTOOL= yes
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (xls2xml-1.0.0.tar.gz) = 8eb70feef679244228cacf4aab695b38

View File

@ -0,0 +1,12 @@
--- rec/p.h.orig Sun Mar 28 01:07:00 1999
+++ rec/p.h Thu Nov 4 14:45:37 1999
@@ -20,6 +20,9 @@
Roberto Arturo Tena Sanchez <arturo@directmail.org>
*/
+#include <stdlib.h>
+#include "../pcommon.h"
+
int p06 (void);
int p09 (void);
int p0A (void);

View File

@ -0,0 +1,11 @@
--- formula.c.orig Thu Nov 4 15:01:23 1999
+++ formula.c Thu Nov 4 15:01:27 1999
@@ -642,7 +642,7 @@
new_record = malloc (sizeof (stack_record));
test (new_record != NULL, 10);
if (data == NULL)
- new_record->data == NULL;
+ new_record->data = NULL;
else
{
new_record->data = data;

View File

@ -0,0 +1,11 @@
--- formula.h.orig Thu Nov 4 14:52:58 1999
+++ formula.h Thu Nov 4 14:56:07 1999
@@ -25,6 +25,8 @@
#include <cole1compat.h>
#include <stdlib.h> /* FIXME: TEMP to call calloc */
+#include "xmlunicode.h"
+#include "pcommon.h"
int fil_parsed_formula2str (char ** result_string, U8 * parsed_expression,
int * volatile_function);

View File

@ -0,0 +1 @@
A utility for converting MS Excel files to XML

View File

@ -0,0 +1,7 @@
xls2xml is a free filter from Microsoft Excel to XML, and a free C library.
Using the program xls2xml, you can extract the content of a file generated
by Microsoft Excel and express its content using XML. A library written in
C which is able to do the same is provided too.
WWW: http://arturo.directmail.org/filtersweb/

View File

@ -0,0 +1,12 @@
bin/xls2xml
include/xls2xml/defines.h
include/xls2xml/p.h
include/xls2xml/param.h
include/xls2xml/xls2xml.h
include/xls2xml/xmldoc.h
lib/libxls2xml.a
lib/libxls2xml.so
lib/libxls2xml.so.1
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
@dirrm include/xls2xml