Adding cole version 2.0.1

A free C OLE library

PR:		14705 (1 of 2)
Submitted by:	Maxim Sobolev <sobomax@altavista.net>
This commit is contained in:
Steve Price 1999-12-27 02:10:03 +00:00
parent fed51b1c95
commit 2236497d16
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24138
7 changed files with 81 additions and 0 deletions

View File

@ -8,6 +8,7 @@
SUBDIR += catdoc
SUBDIR += cocoon
SUBDIR += code2html
SUBDIR += cole
SUBDIR += dict
SUBDIR += diffstat
SUBDIR += docbook

18
textproc/cole/Makefile Normal file
View File

@ -0,0 +1,18 @@
# New ports collection makefile for: cole
# Version required: 2.0.1
# Date created: 4 November 1999
# Whom: Maxim Sobolev <sobomax@altavista.net>
#
# $FreeBSD$
#
DISTNAME= cole-2.0.1
CATEGORIES= textproc
MASTER_SITES= http://arturo.directmail.org/filters/archive/ \
http://homepages.go.com/~sobomax/filtersweb/
MAINTAINER= sobomax@altavista.net
USE_LIBTOOL= yes
.include <bsd.port.mk>

1
textproc/cole/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (cole-2.0.1.tar.gz) = a4e3c3571704447181e2ce045e317d1b

View File

@ -0,0 +1,40 @@
--- oledecod.c.orig Thu Nov 4 14:11:11 1999
+++ oledecod.c Thu Nov 4 14:16:20 1999
@@ -39,7 +39,7 @@
#include <stdarg.h>
#include <stdlib.h>
#include <string.h>
-#include <malloc.h>
+#include <stdlib.h>
#include <ctype.h>
#include <sys/types.h>
#include <assert.h>
@@ -575,10 +575,12 @@
/* reorder subtrees, if there's any */
if (node->dir != 0xffffffffUL)
+ {
if (node->dir > num_of_pps || !pps_list[node->dir].name[0])
return 0;
else if (!reorder_pps_tree (&pps_list[node->dir], level + 1))
return 0;
+ }
/* reorder next-link subtree, saving the most next link visited */
if (node->next != 0xffffffffUL)
@@ -593,6 +595,7 @@
/* move the prev child to the next link and reorder it, if there's any */
if (node->previous != 0xffffffffUL)
+ {
if (node->previous > num_of_pps || !pps_list[node->previous].name[0])
return 0;
else
@@ -602,6 +605,7 @@
if (!reorder_pps_tree (&pps_list[*last_next_link_visited], level))
return 0;
}
+ }
return 1;
}

View File

@ -0,0 +1 @@
A free C OLE library

7
textproc/cole/pkg-descr Normal file
View File

@ -0,0 +1,7 @@
Cole is a free C OLE library. Using cole, you can access Microsoft' `Structured
Storage' files. The most popular Microsoft's programs generate `Structured
Storage' files, incluiding the Microsoft' suite for offices. StarDivision'
suite (StarOffice) generate `Structured Storage' files too. FlashPix file
format is `Structured Storage' too.
WWW: http://arturo.directmail.org/filtersweb/

13
textproc/cole/pkg-plist Normal file
View File

@ -0,0 +1,13 @@
bin/cole-config
bin/cole_extract
bin/cole_isfs
bin/cole_isfs_fast
bin/cole_tree
include/cole/cole.h
lib/libcole.a
lib/libcole.so
lib/libcole.so.2
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
share/aclocal/cole.m4
@dirrm include/cole