Add recombine 1.40, a program to fit population models across sites.

This commit is contained in:
Johann Visagie 2001-08-06 14:49:53 +00:00
parent 52619bca7a
commit 043c249d98
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=45886
7 changed files with 166 additions and 0 deletions

View File

@ -33,6 +33,7 @@
SUBDIR += psi88
SUBDIR += py-biopython
SUBDIR += rasmol
SUBDIR += recombine
SUBDIR += seaview
SUBDIR += sim4
SUBDIR += tinker

View File

@ -0,0 +1,29 @@
# New ports collection makefile for: recombine
# Date created: 6 August 2001
# Whom: Johann Visagie <wjv@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= recombine
PORTVERSION= 1.40
CATEGORIES= biology
MASTER_SITES= ftp://evolution.genetics.washington.edu/pub/lamarc/recombine/
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= wjv@FreeBSD.org
NO_WRKSUBDIR= yes
ALL_TARGET= ${PORTNAME}
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
@ ${INSTALL_SCRIPT} ${WRKSRC}/filetran ${PREFIX}/bin/
post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
@ ${INSTALL_DATA} ${WRKSRC}/*.doc ${DOCSDIR}/
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (recombine1.40.tar.gz) = 78f308f69c35610fbd31a091b8d17e2f

View File

@ -0,0 +1,117 @@
--- Makefile.orig Wed Oct 25 23:39:34 2000
+++ Makefile Mon Aug 6 16:13:02 2001
@@ -1,105 +1,37 @@
LIBS = -lm
BINDIR = ./bin
-#CFLAGS = -Wall -Wshadow -g
-CFLAGS = -O -Wall -Wshadow -g
-#CFLAGS = -fast -inline speed
-#CFLAGS = -O3 -arch host -fast
-CC = gcc $(CFLAGS)
-#CC = cc $(CFLAGS)
+CFLAGS += -g
DCC = gcc -g -Wall -DDMALLOC_FUNC_CHECK -ansi -pedantic
PLUSCC = g++ $(CFLAGS)
LIBS = -lm -L/usr/local/lib
DLIBS = -lm -L/usr/local/lib -ldmalloc
CGCC = checkergcc -g -Wall
CGLIBS = -lm
-# -O
PROGS = recombine
# The big banana
recombine : recombine.o jdrop.o rec_modellike.o jworld.o getdata.o \
traitlike.o getmsatdata.o
- $(CC) -o recombine recombine.o jdrop.o rec_modellike.o \
+ $(CC) $(CFLAGS) -o recombine recombine.o jdrop.o rec_modellike.o \
jworld.o getdata.o traitlike.o getmsatdata.o $(LIBS)
jworld.o : jworld.c
- $(CC) -c jworld.c
+ $(CC) $(CFLAGS) -c jworld.c
jdrop.o : jdrop.c
- $(CC) -c jdrop.c
+ $(CC) $(CFLAGS) -c jdrop.c
rec_modellike.o : rec_modellike.c
- $(CC) -c rec_modellike.c
+ $(CC) $(CFLAGS) -c rec_modellike.c
recombine.o : recombine.c
- $(CC) -c recombine.c
+ $(CC) $(CFLAGS) -c recombine.c
getdata.o : getdata.c
- $(CC) -c getdata.c
+ $(CC) $(CFLAGS) -c getdata.c
getmsatdata.o : getmsatdata.c
- $(CC) -c getmsatdata.c
+ $(CC) $(CFLAGS) -c getmsatdata.c
traitlike.o : traitlike.c
- $(CC) -c traitlike.c
-
-rectreedna : rectreedna.c
- $(CC) -o rectreedna rectreedna.c $(LIBS)
-
-hapdna : hapdna.c
- $(CC) -o hapdna hapdna.c $(LIBS)
-
-mhapdna : mhapdna.c
- $(CC) -o mhapdna mhapdna.c $(LIBS)
-
-drecombine.o : recombine.c
- $(CC) -o drecombine.o -c recombine.c
-
-djdrop.o : jdrop.c
- $(CC) -o djdrop.o -c jdrop.c
-
-drec_modellike.o : rec_modellike.c
- $(CC) -o drec_modellike.o -c rec_modellike.c
-
-djworld.o : jworld.c
- $(CC) -o djworld.o -c jworld.c
-
-dgetdata.o : getdata.c
- $(CC) -o dgetdata.o -c getdata.c
-
-dgetmsatdata.o : getmsatdata.c
- $(CC) -o dgetmsatdata.o -c getmsatdata.c
-
-drecombine: drecombine.o djdrop.o drec_modellike.o djworld.o dgetdata.o memdebug.o memalpha.o memfree.o \
- dgetmsatdata.o
- $(CC) drecombine.o djdrop.o drec_modellike.o djworld.o dgetdata.o memdebug.o memalpha.o memfree.o \
- dgetmsatdata.o $(LIBS) -o drecombine
-
-dclean:
- rm drecombine.o djdrop.o drec_modellike.o djworld.o dgetdata.o dgetmsatdata.o
-
-clean :
- rm -f *.o
-
-gentrees.o : gentrees.c
- $(CC) -c gentrees.c
-
-segtre_mig.o : segtre_mig.c
- $(CC) -c segtre_mig.c
-
-rectree : gentrees.o segtre_mig.o
- $(CC) gentrees.o segtre_mig.o $(LIBS) -o rectree
-
-jrectree : simrectree.c
- $(CC) simrectree.c $(LIBS) -o jrectree
-
-snp : snp.c
- $(CC) snp.c $(LIBS) -o snp
-
-panelmaker : panelmaker.c
- $(CC) panelmaker.c $(LIBS) -o panelmaker
-
-variance : variance.c
- $(CC) variance.c $(LIBS) -o variance
-
-distree : distree.c
- $(CC) distree.c $(LIBS) -o distree
+ $(CC) $(CFLAGS) -c traitlike.c

View File

@ -0,0 +1 @@
A program to fit population models across sites

View File

@ -0,0 +1,12 @@
Recombine fits a model which has a single population of constant size with a
single recombination rate across all sites. It can accomodate either plain
DNA or RNA data or SNP (single nucleotide polymorphism) data.
Recombine forms part of the Lamarc (Likelihood Analysis with Metropolis
Algorithm using Random Coalescence) suite. See:
http://evolution.genetics.washington.edu/lamarc.html
WWW: http://evolution.genetics.washington.edu/lamarc/recombine.html
-- Johann Visagie <wjv@FreeBSD.org>

View File

@ -0,0 +1,5 @@
bin/filetran
bin/recombine
%%PORTDOCS%%share/doc/recombine/rec_errors.doc
%%PORTDOCS%%share/doc/recombine/recombine.doc
%%PORTDOCS%%@dirrm share/doc/recombine