1
0
Fork 0
Commit Graph

26 Commits

Author SHA1 Message Date
Ailin Nemui cfd421a948 update meson requirement, add check for built files 2022-03-18 22:31:40 +01:00
Ailin Nemui b8736225cf good-bye and thanks, autotools 2022-02-19 21:44:10 +01:00
Ailin Nemui 7adf81f9b5 raise glib version requirement to 2.32 for g_hash_table_contains 2021-02-26 14:19:33 +01:00
ailin-nemui 01ecb879a6 Add support for building in Termux-Android in meson
- introduce cross perl
- workaround for the android linker
2020-06-02 10:38:01 +02:00
ailin-nemui 73f6964d4f
Explain Meson in INSTALL 2019-07-17 12:09:39 +00:00
Rodrigo Rebello 449b8a4589 Remove outdated information from INSTALL
Disabling SSL support is no longer an option.
2017-03-20 16:10:03 -03:00
Thomas Samson d02ef83d03 update INSTALL requirement: terminfo or ncurses for text frontend 2016-10-05 01:01:25 +02:00
ailin-nemui 5d9af40ea7 Update INSTALL 2016-08-29 23:25:26 +02:00
ailin-nemui 9ee4803770 remove curses terminal and ncurses macro 2016-08-04 10:02:28 +02:00
LemonBoy 70c7949cfe Update the configure script and INSTALL.
Now that HAVE_IPV6 is gone remove all the references from the
buildscript and documentation.
2016-01-27 14:42:50 +01:00
ailin-nemui 4af3a4731e continue head 2016-01-18 10:43:28 +01:00
ailin-nemui 77143aee7d remove mention of ./autogen.sh from releases INSTALL 2015-12-15 14:06:50 +01:00
Will Song 54153e6d88
revise INSTALL to be more clear regarding which script to use 2015-11-25 12:25:55 -06:00
Will Song c52e6ebc99
change ./configure to ./autogen.sh because ./configure does not exist in
a fresh clone of the repository
2015-11-25 11:55:18 -06:00
dequis 6f9fc5d523 INSTALL: mention local::lib for home directory installations
I had problems installing this and this file didn't have the answer.
So I'm adding what nei told me to do.
2015-09-27 02:15:14 -03:00
Emanuele Giaquinta e5ba2d35e4 We require perl-5.6.
git-svn-id: file:///var/www/svn.irssi.org/SVN/irssi/trunk@4986 dbcabf3a-b0e7-0310-adc4-f8d773084564
2009-01-15 10:34:46 +00:00
Emanuele Giaquinta e85534acf2 Merge README.cygwin in INSTALL.
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@4729 dbcabf3a-b0e7-0310-adc4-f8d773084564
2008-03-05 09:48:32 +00:00
Emanuele Giaquinta faebae7b64 Improve descriptions of configure options.
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@4728 dbcabf3a-b0e7-0310-adc4-f8d773084564
2008-03-05 09:38:15 +00:00
Emanuele Giaquinta 1a482a38d1 Move description of resolve_prefer_ipv6 in the manual.
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@4727 dbcabf3a-b0e7-0310-adc4-f8d773084564
2008-03-04 23:06:39 +00:00
Emanuele Giaquinta 255d9f1f47 Move documentation of configure options in INSTALL.
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@4725 dbcabf3a-b0e7-0310-adc4-f8d773084564
2008-03-04 20:09:13 +00:00
Emanuele Giaquinta 6f1adc2118 Reformat.
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@4724 dbcabf3a-b0e7-0310-adc4-f8d773084564
2008-03-04 19:11:45 +00:00
Emanuele Giaquinta 9159f2456e Document packages needed to build/run irssi.
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@4708 dbcabf3a-b0e7-0310-adc4-f8d773084564
2008-02-05 12:19:08 +00:00
Emanuele Giaquinta 4fb888ce80 Remove support for perl 5.004 and older.
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@4706 dbcabf3a-b0e7-0310-adc4-f8d773084564
2008-02-05 01:01:06 +00:00
Timo Sirainen 5972260d88 SSL detection changed to use pkg-config, fixed Redhat 9. Removed
--with-ssl-include etc. options, you can just CPPFLAGS/LIBS just fine for
that.


git-svn-id: http://svn.irssi.org/repos/irssi/trunk@3166 dbcabf3a-b0e7-0310-adc4-f8d773084564
2003-11-17 00:29:11 +00:00
Timo Sirainen 8c4a56a962 added some information about ipv6 resolving
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@2505 dbcabf3a-b0e7-0310-adc4-f8d773084564
2002-02-17 17:03:24 +00:00
Timo Sirainen 7ebe053ebf Added real installation instructions to INSTALL file.
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@2480 dbcabf3a-b0e7-0310-adc4-f8d773084564
2002-02-16 12:52:19 +00:00