1
0
mirror of https://github.com/irssi/irssi.git synced 2024-06-16 06:25:24 +00:00

raise glib version requirement to 2.32 for g_hash_table_contains

This commit is contained in:
Ailin Nemui 2021-01-28 21:25:53 +01:00
parent b47257048c
commit 7adf81f9b5
4 changed files with 4 additions and 4 deletions

View File

@ -5,7 +5,7 @@
To compile Irssi you need:
- meson-0.49 build system with ninja-1.5 or greater
- glib-2.28 or greater
- glib-2.32 or greater
- openssl (for ssl support)
- perl-5.6 or greater (for Perl support)
- terminfo or ncurses (for text frontend)

View File

@ -40,7 +40,7 @@ make && sudo make install
### Requirements
- [glib-2.28](https://wiki.gnome.org/Projects/GLib) or greater
- [glib-2.32](https://wiki.gnome.org/Projects/GLib) or greater
- [openssl](https://www.openssl.org/)
- [perl-5.6](https://www.perl.org/) or greater (for perl support)
- terminfo or ncurses (for text frontend)

View File

@ -273,7 +273,7 @@ for try in 1 2; do
echo "*** trying without -lgmodule"
glib_modules=
fi
AM_PATH_GLIB_2_0(2.28.0,,, $glib_modules)
AM_PATH_GLIB_2_0(2.32.0,,, $glib_modules)
if test "$GLIB_LIBS"; then
if test $glib_modules = gmodule; then
AC_DEFINE(HAVE_GMODULE)

View File

@ -166,7 +166,7 @@ message('*** Or alternatively install your distribution\'s package')
message('*** On Debian: sudo apt-get install libglib2.0-dev')
message('*** On Redhat: dnf install glib2-devel')
if not require_glib_internal
glib_dep = dependency('glib-2.0', version : '>=2.28', required : not want_glib_internal, static : want_static_dependency)
glib_dep = dependency('glib-2.0', version : '>=2.32', required : not want_glib_internal, static : want_static_dependency)
else
glib_dep = dependency('', required : false)
endif