ee6bb0cc76
* gnu/packages/patches/libxml2-CVE-2015-1819.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-8035.patch, gnu/packages/patches/libxml2-bug-737840.patch, gnu/packages/patches/libxml2-bug-738805.patch, gnu/packages/patches/libxml2-bug-746048.patch, gnu/packages/patches/libxml2-bug-747437.patch, gnu/packages/patches/libxml2-bug-751603.patch, gnu/packages/patches/libxml2-bug-751631.patch, gnu/packages/patches/libxml2-bug-754946.patch, gnu/packages/patches/libxml2-bug-754947.patch, gnu/packages/patches/libxml2-bug-755857.patch, gnu/packages/patches/libxml2-fix-catalog-corruption.patch, gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch, gnu/packages/patches/libxml2-node-sort-order-pt1.patch, gnu/packages/patches/libxml2-node-sort-order-pt2.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/xml.scm (libxml2)[source]: Add patches.
38 lines
1.0 KiB
Diff
38 lines
1.0 KiB
Diff
From 3eaedba1b64180668fdab7ad2eba549586017bf3 Mon Sep 17 00:00:00 2001
|
|
From: Nick Wellnhofer <wellnhofer@aevum.de>
|
|
Date: Sat, 11 Jul 2015 14:27:34 +0200
|
|
Subject: [PATCH] Fix previous change to node sort order
|
|
|
|
Commit ba58f23 broke comparison of nodes from different documents.
|
|
Thanks to Olli Pottonen for the report.
|
|
---
|
|
xpath.c | 8 ++++----
|
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/xpath.c b/xpath.c
|
|
index e9f5bf9..935fcff 100644
|
|
--- a/xpath.c
|
|
+++ b/xpath.c
|
|
@@ -361,14 +361,14 @@ turtle_comparison:
|
|
/*
|
|
* compute depth to root
|
|
*/
|
|
- for (depth2 = 0, cur = node2; cur != NULL; cur = cur->parent) {
|
|
- if (cur == node1)
|
|
+ for (depth2 = 0, cur = node2; cur->parent != NULL; cur = cur->parent) {
|
|
+ if (cur->parent == node1)
|
|
return(1);
|
|
depth2++;
|
|
}
|
|
root = cur;
|
|
- for (depth1 = 0, cur = node1; cur != NULL; cur = cur->parent) {
|
|
- if (cur == node2)
|
|
+ for (depth1 = 0, cur = node1; cur->parent != NULL; cur = cur->parent) {
|
|
+ if (cur->parent == node2)
|
|
return(-1);
|
|
depth1++;
|
|
}
|
|
--
|
|
2.6.3
|
|
|