ee6bb0cc76
* gnu/packages/patches/libxml2-CVE-2015-1819.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-8035.patch, gnu/packages/patches/libxml2-bug-737840.patch, gnu/packages/patches/libxml2-bug-738805.patch, gnu/packages/patches/libxml2-bug-746048.patch, gnu/packages/patches/libxml2-bug-747437.patch, gnu/packages/patches/libxml2-bug-751603.patch, gnu/packages/patches/libxml2-bug-751631.patch, gnu/packages/patches/libxml2-bug-754946.patch, gnu/packages/patches/libxml2-bug-754947.patch, gnu/packages/patches/libxml2-bug-755857.patch, gnu/packages/patches/libxml2-fix-catalog-corruption.patch, gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch, gnu/packages/patches/libxml2-node-sort-order-pt1.patch, gnu/packages/patches/libxml2-node-sort-order-pt2.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/xml.scm (libxml2)[source]: Add patches.
44 lines
1.5 KiB
Diff
44 lines
1.5 KiB
Diff
From cf77e60515045bdd66f2c59c69a06e603b470eae Mon Sep 17 00:00:00 2001
|
|
From: Gaurav Gupta <g.gupta@samsung.com>
|
|
Date: Wed, 30 Sep 2015 14:46:29 +0200
|
|
Subject: [PATCH] Add missing Null check in xmlParseExternalEntityPrivate
|
|
|
|
For https://bugzilla.gnome.org/show_bug.cgi?id=755857
|
|
|
|
a case where we check for NULL but not everywhere
|
|
---
|
|
parser.c | 10 ++++++----
|
|
1 file changed, 6 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/parser.c b/parser.c
|
|
index f1724a9..a65e4cc 100644
|
|
--- a/parser.c
|
|
+++ b/parser.c
|
|
@@ -13367,7 +13367,7 @@ xmlParseExternalEntityPrivate(xmlDocPtr doc, xmlParserCtxtPtr oldctxt,
|
|
/*
|
|
* Also record the size of the entity parsed
|
|
*/
|
|
- if (ctxt->input != NULL) {
|
|
+ if (ctxt->input != NULL && oldctxt != NULL) {
|
|
oldctxt->sizeentities += ctxt->input->consumed;
|
|
oldctxt->sizeentities += (ctxt->input->cur - ctxt->input->base);
|
|
}
|
|
@@ -13379,9 +13379,11 @@ xmlParseExternalEntityPrivate(xmlDocPtr doc, xmlParserCtxtPtr oldctxt,
|
|
|
|
if (sax != NULL)
|
|
ctxt->sax = oldsax;
|
|
- oldctxt->node_seq.maximum = ctxt->node_seq.maximum;
|
|
- oldctxt->node_seq.length = ctxt->node_seq.length;
|
|
- oldctxt->node_seq.buffer = ctxt->node_seq.buffer;
|
|
+ if (oldctxt != NULL) {
|
|
+ oldctxt->node_seq.maximum = ctxt->node_seq.maximum;
|
|
+ oldctxt->node_seq.length = ctxt->node_seq.length;
|
|
+ oldctxt->node_seq.buffer = ctxt->node_seq.buffer;
|
|
+ }
|
|
ctxt->node_seq.maximum = 0;
|
|
ctxt->node_seq.length = 0;
|
|
ctxt->node_seq.buffer = NULL;
|
|
--
|
|
2.6.3
|
|
|