This is followup to 665d6a59161769e10b52ffcbcd5cd2db22f32681. Fixes <https://bugs.gnu.org/27489>. * gnu/packages/base.scm (glibc-2.25-patched, glibc-2.24, glibc-2.23) (glibc-2.22): Add glibc-vectorized-strcspn-guards.patch to patches. Move a comment where it belongs. * gnu/packages/patches/glibc-CVE-2017-1000366-pt2.patch: Swap with ... * gnu/packages/patches/glibc-CVE-2017-1000366-pt3.patch: ... this. * gnu/packages/patches/glibc-vectorized-strcspn-guards.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Fix formatting.
24 lines
732 B
Diff
24 lines
732 B
Diff
Copied from Debian.
|
|
|
|
2017-06-14 Florian Weimer <fweimer@redhat.com>
|
|
|
|
* sysdeps/i386/i686/multiarch/strcspn-c.c: Add IS_IN (libc) guard.
|
|
* sysdeps/i386/i686/multiarch/varshift.c: Likewise.
|
|
|
|
--- a/sysdeps/i386/i686/multiarch/strcspn-c.c
|
|
+++ b/sysdeps/i386/i686/multiarch/strcspn-c.c
|
|
@@ -1,2 +1,4 @@
|
|
-#define __strcspn_sse2 __strcspn_ia32
|
|
-#include <sysdeps/x86_64/multiarch/strcspn-c.c>
|
|
+#if IS_IN (libc)
|
|
+# define __strcspn_sse2 __strcspn_ia32
|
|
+# include <sysdeps/x86_64/multiarch/strcspn-c.c>
|
|
+#endif
|
|
--- a/sysdeps/i386/i686/multiarch/varshift.c
|
|
+++ b/sysdeps/i386/i686/multiarch/varshift.c
|
|
@@ -1 +1,3 @@
|
|
-#include <sysdeps/x86_64/multiarch/varshift.c>
|
|
+#if IS_IN (libc)
|
|
+# include <sysdeps/x86_64/multiarch/varshift.c>
|
|
+#endif
|