ee6bb0cc76
* gnu/packages/patches/libxml2-CVE-2015-1819.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-8035.patch, gnu/packages/patches/libxml2-bug-737840.patch, gnu/packages/patches/libxml2-bug-738805.patch, gnu/packages/patches/libxml2-bug-746048.patch, gnu/packages/patches/libxml2-bug-747437.patch, gnu/packages/patches/libxml2-bug-751603.patch, gnu/packages/patches/libxml2-bug-751631.patch, gnu/packages/patches/libxml2-bug-754946.patch, gnu/packages/patches/libxml2-bug-754947.patch, gnu/packages/patches/libxml2-bug-755857.patch, gnu/packages/patches/libxml2-fix-catalog-corruption.patch, gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch, gnu/packages/patches/libxml2-node-sort-order-pt1.patch, gnu/packages/patches/libxml2-node-sort-order-pt2.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/xml.scm (libxml2)[source]: Add patches.
32 lines
1.1 KiB
Diff
32 lines
1.1 KiB
Diff
From 72a46a519ce7326d9a00f0b6a7f2a8e958cd1675 Mon Sep 17 00:00:00 2001
|
|
From: Daniel Veillard <veillard@redhat.com>
|
|
Date: Thu, 23 Oct 2014 11:35:36 +0800
|
|
Subject: [PATCH] Fix missing entities after CVE-2014-3660 fix
|
|
|
|
For https://bugzilla.gnome.org/show_bug.cgi?id=738805
|
|
|
|
The fix for CVE-2014-3660 introduced a regression in some case
|
|
where entity substitution is required and the entity is used
|
|
first in anotther entity referenced from an attribute value
|
|
---
|
|
parser.c | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/parser.c b/parser.c
|
|
index 67c9dfd..a8d1b67 100644
|
|
--- a/parser.c
|
|
+++ b/parser.c
|
|
@@ -7235,7 +7235,8 @@ xmlParseReference(xmlParserCtxtPtr ctxt) {
|
|
* far more secure as the parser will only process data coming from
|
|
* the document entity by default.
|
|
*/
|
|
- if ((ent->checked == 0) &&
|
|
+ if (((ent->checked == 0) ||
|
|
+ ((ent->children == NULL) && (ctxt->options & XML_PARSE_NOENT))) &&
|
|
((ent->etype != XML_EXTERNAL_GENERAL_PARSED_ENTITY) ||
|
|
(ctxt->options & (XML_PARSE_NOENT | XML_PARSE_DTDVALID)))) {
|
|
unsigned long oldnbent = ctxt->nbentities;
|
|
--
|
|
2.6.3
|
|
|