0ca1eb705d
* gnu/packages/patches/icecat-CVE-2015-4513-pt01.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt02.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt03.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt04.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt05.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt06.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt07.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt08.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt09.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt10.patch, gnu/packages/patches/icecat-CVE-2015-4513-pt11.patch, gnu/packages/patches/icecat-CVE-2015-7188.patch, gnu/packages/patches/icecat-CVE-2015-7189.patch, gnu/packages/patches/icecat-CVE-2015-7193.patch, gnu/packages/patches/icecat-CVE-2015-7194.patch, gnu/packages/patches/icecat-CVE-2015-7196.patch, gnu/packages/patches/icecat-CVE-2015-7197.patch, gnu/packages/patches/icecat-CVE-2015-7198.patch, gnu/packages/patches/icecat-CVE-2015-7199.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
28 lines
904 B
Diff
28 lines
904 B
Diff
From 3ed5c713015536b49dc88d3d4a36b60833ccd09a Mon Sep 17 00:00:00 2001
|
|
From: Jan de Mooij <jdemooij@mozilla.com>
|
|
Date: Tue, 25 Aug 2015 13:11:41 +0200
|
|
Subject: [PATCH] Bug 1140616 - Crash when _releaseobject is called on the
|
|
wrong thread. r=bsmedberg, a=sledru, a=lizzard
|
|
|
|
--HG--
|
|
extra : source : 6a513309283d06f56cebee8528cfcf134a74f3c4
|
|
---
|
|
dom/plugins/base/nsNPAPIPlugin.cpp | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/dom/plugins/base/nsNPAPIPlugin.cpp b/dom/plugins/base/nsNPAPIPlugin.cpp
|
|
index f0d07fa..9cd2e05 100644
|
|
--- a/dom/plugins/base/nsNPAPIPlugin.cpp
|
|
+++ b/dom/plugins/base/nsNPAPIPlugin.cpp
|
|
@@ -1413,6 +1413,7 @@ _releaseobject(NPObject* npobj)
|
|
{
|
|
if (!NS_IsMainThread()) {
|
|
NPN_PLUGIN_LOG(PLUGIN_LOG_ALWAYS,("NPN_releaseobject called from the wrong thread\n"));
|
|
+ MOZ_CRASH("NPN_releaseobject called from the wrong thread");
|
|
}
|
|
if (!npobj)
|
|
return;
|
|
--
|
|
2.5.0
|
|
|