800cdeef31
* Makefile.am (nobase_dist_guilemodule_DATA): Keep only $(MODULES). (patchdir): New variable. (dist_patch_DATA): New variable. Patch files formerly in $(nobase_dist_guilemodule_DATA). (.scm.go): Define `DISTRO_PATCH_DIRECTORY' and `DISTRO_INSTALLED_PATCH_DIRECTORY'. (TESTS_ENVIRONMENT): Define `DISTRO_PATCH_DIRECTORY'. * distro.scm (%patch-directory): New variable. (search-patch): New procedure. * distro/base.scm: Use `search-patch' instead of `(search-path %load-path ...)'. * distro/findutils-absolute-paths.patch, distro/guile-1.8-cpp-4.5.patch, distro/m4-readlink-EINVAL.patch, distro/m4-s_isdir.patch, distro/make-impure-dirs.patch: Move to `distro/patches'.
19 lines
722 B
Diff
19 lines
722 B
Diff
Newer Linux kernels would return EINVAL instead of ENOENT.
|
|
The patch below, taken from Gnulib, allows the test to pass when
|
|
these Linux versions are in use:
|
|
https://lists.gnu.org/archive/html/bug-gnulib/2011-03/msg00308.html .
|
|
|
|
diff --git a/tests/test-readlink.h b/tests/test-readlink.h
|
|
index 08d5662..7247fc4 100644
|
|
--- a/tests/test-readlink.h
|
|
+++ b/tests/test-readlink.h
|
|
@@ -38,7 +38,7 @@ test_readlink (ssize_t (*func) (char const *, char *, size_t), bool print)
|
|
ASSERT (errno == ENOENT);
|
|
errno = 0;
|
|
ASSERT (func ("", buf, sizeof buf) == -1);
|
|
- ASSERT (errno == ENOENT);
|
|
+ ASSERT (errno == ENOENT || errno == EINVAL);
|
|
errno = 0;
|
|
ASSERT (func (".", buf, sizeof buf) == -1);
|
|
ASSERT (errno == EINVAL);
|