ba583bd2ce
* gnu/packages/tor.scm (torsocks): Update to 2.0.0. [source]: Fetch from git.torproject.org. Use 'torsocks-dns-test.patch'. [arguments, native-inputs]: New fields. [license]: Change to GPL2. * gnu/packages/patches/torsocks-dns-test.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
19 lines
564 B
Diff
19 lines
564 B
Diff
Skip DNS tests that rely on the ability to look up arbitary
|
|
host names.
|
|
|
|
--- torsocks/tests/test_dns.c 2015-11-10 18:30:53.955941984 +0100
|
|
+++ torsocks/tests/test_dns.c 2015-11-10 18:31:02.199941892 +0100
|
|
@@ -134,11 +134,8 @@ static void test_getaddrinfo(const struc
|
|
int main(int argc, char **argv)
|
|
{
|
|
/* Libtap call for the number of tests planned. */
|
|
- plan_tests(NUM_TESTS);
|
|
+ plan_tests(1);
|
|
|
|
- test_getaddrinfo(&tor_check);
|
|
- test_gethostbyname(&tor_dir_auth1);
|
|
- test_gethostbyaddr(&tor_dir_auth2);
|
|
test_getaddrinfo(&tor_localhost);
|
|
|
|
return 0;
|