266b39fc26
* gnunet/packages/gnunet.scm (gnunet): New variable. * gnu/package/patches/gnunet-fix-scheduler.patch: New file. * gnu/package/patches/gnunet-fix-tests.patch: New file. * gnu-system.am (dist_patch_DATA): Add the above two patch files. Co-authored-by: Andreas Enge <andreas@enge.fr> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
14 lines
435 B
Diff
14 lines
435 B
Diff
Index: src/util/scheduler.c
|
|
===================================================================
|
|
--- src/util/scheduler.c (revision 31745)
|
|
+++ src/util/scheduler.c (working copy)
|
|
@@ -1599,7 +1599,7 @@
|
|
int real_fd;
|
|
|
|
GNUNET_DISK_internal_file_handle_ (fd, &real_fd, sizeof (int));
|
|
- GNUNET_assert (real_fd > 0);
|
|
+ GNUNET_assert (real_fd >= 0);
|
|
return add_without_sets (
|
|
delay, priority,
|
|
on_read ? real_fd : -1,
|