bc0b89bb3e
* gnu/packages/xorg.scm (xf86-video-openchrome): Add patch for build failure with glibc-2.20. Fixes bug #18740. * gnu/packages/patches/xf86-video-openchrome-includes.patch: New file. * gnu-system.am (dist_patch_DATA): Register patch.
36 lines
1.3 KiB
Diff
36 lines
1.3 KiB
Diff
This follows the same rationale as xf86-input-synaptics-glibc-2.20.patch
|
|
to allow building with glibc-2.20.
|
|
diff -u -r xf86-video-openchrome-0.2.906.old/src/via_3d.h xf86-video-openchrome-0.2.906/src/via_3d.h
|
|
--- xf86-video-openchrome-0.2.906.old/src/via_3d.h 2014-11-23 14:04:58.000000000 +0100
|
|
+++ xf86-video-openchrome-0.2.906/src/via_3d.h 2014-11-23 14:18:37.000000000 +0100
|
|
@@ -24,6 +24,7 @@
|
|
#ifndef VIA_3D_H
|
|
#define VIA_3D_H
|
|
|
|
+#include "xorg-server.h"
|
|
#include "xf86.h"
|
|
#include "via_dmabuffer.h"
|
|
|
|
diff -u -r xf86-video-openchrome-0.2.906.old/src/via_driver.h xf86-video-openchrome-0.2.906/src/via_driver.h
|
|
--- xf86-video-openchrome-0.2.906.old/src/via_driver.h 2014-11-23 14:04:58.000000000 +0100
|
|
+++ xf86-video-openchrome-0.2.906/src/via_driver.h 2014-11-23 14:21:43.000000000 +0100
|
|
@@ -35,6 +35,7 @@
|
|
#endif
|
|
|
|
#include "vgaHW.h"
|
|
+#include "xorg-server.h"
|
|
#include "xf86.h"
|
|
|
|
#if GET_ABI_MAJOR(ABI_VIDEODRV_VERSION) < 6
|
|
diff -u -r xf86-video-openchrome-0.2.906.old/src/via_timing.h xf86-video-openchrome-0.2.906/src/via_timing.h
|
|
--- xf86-video-openchrome-0.2.906.old/src/via_timing.h 2014-11-23 14:04:58.000000000 +0100
|
|
+++ xf86-video-openchrome-0.2.906/src/via_timing.h 2014-11-23 14:20:50.000000000 +0100
|
|
@@ -25,6 +25,7 @@
|
|
#ifndef _TIMING_H_
|
|
#define _TIMING_H_
|
|
|
|
+#include "xorg-server.h"
|
|
#include "xf86.h"
|
|
|
|
/* Aspect ratio not CVT standard */
|