f956d661ad
* gnu/packages/patches/libwmf-CAN-2004-0941.patch, gnu/packages/patches/libwmf-CVE-2007-0455.patch, gnu/packages/patches/libwmf-CVE-2007-2756.patch, gnu/packages/patches/libwmf-CVE-2007-3472.patch, gnu/packages/patches/libwmf-CVE-2007-3473.patch, gnu/packages/patches/libwmf-CVE-2007-3477.patch, gnu/packages/patches/libwmf-CVE-2009-3546.patch: New files. * gnu/packages/patches/libwmf-CVE-2015-0848+4588+4695+4696.patch: Delete file. Replace with ... * gnu/packages/patches/libwmf-CVE-2015-0848+CVE-2015-4588.patch, gnu/packages/patches/libwmf-CVE-2015-4695.patch, gnu/packages/patches/libwmf-CVE-2015-4696.patch: ... these new files. * gnu-system.am (dist_patch_DATA): Adjust accordingly. * gnu/packages/image.scm (libwmf)[source]: Adjust set of patches.
28 lines
591 B
Diff
28 lines
591 B
Diff
Copied from Fedora.
|
|
|
|
http://pkgs.fedoraproject.org/cgit/libwmf.git/tree/libwmf-0.2.8.4-CVE-2015-4696.patch
|
|
|
|
--- libwmf-0.2.8.4/src/player/meta.h
|
|
+++ libwmf-0.2.8.4/src/player/meta.h
|
|
@@ -2585,6 +2585,8 @@
|
|
polyrect.BR[i] = clip->rects[i].BR;
|
|
}
|
|
|
|
+ if (FR->region_clip) FR->region_clip (API,&polyrect);
|
|
+
|
|
wmf_free (API,polyrect.TL);
|
|
wmf_free (API,polyrect.BR);
|
|
}
|
|
@@ -2593,9 +2595,10 @@
|
|
polyrect.BR = 0;
|
|
|
|
polyrect.count = 0;
|
|
+
|
|
+ if (FR->region_clip) FR->region_clip (API,&polyrect);
|
|
}
|
|
|
|
- if (FR->region_clip) FR->region_clip (API,&polyrect);
|
|
|
|
return (changed);
|
|
}
|