f956d661ad
* gnu/packages/patches/libwmf-CAN-2004-0941.patch, gnu/packages/patches/libwmf-CVE-2007-0455.patch, gnu/packages/patches/libwmf-CVE-2007-2756.patch, gnu/packages/patches/libwmf-CVE-2007-3472.patch, gnu/packages/patches/libwmf-CVE-2007-3473.patch, gnu/packages/patches/libwmf-CVE-2007-3477.patch, gnu/packages/patches/libwmf-CVE-2009-3546.patch: New files. * gnu/packages/patches/libwmf-CVE-2015-0848+4588+4695+4696.patch: Delete file. Replace with ... * gnu/packages/patches/libwmf-CVE-2015-0848+CVE-2015-4588.patch, gnu/packages/patches/libwmf-CVE-2015-4695.patch, gnu/packages/patches/libwmf-CVE-2015-4696.patch: ... these new files. * gnu-system.am (dist_patch_DATA): Adjust accordingly. * gnu/packages/image.scm (libwmf)[source]: Adjust set of patches.
61 lines
1.9 KiB
Diff
61 lines
1.9 KiB
Diff
Copied from Fedora.
|
|
|
|
http://pkgs.fedoraproject.org/cgit/libwmf.git/tree/libwmf-0.2.8.4-CVE-2015-4695.patch
|
|
|
|
--- libwmf-0.2.8.4/src/player/meta.h
|
|
+++ libwmf-0.2.8.4/src/player/meta.h
|
|
@@ -1565,7 +1565,7 @@ static int meta_rgn_create (wmfAPI* API,
|
|
objects = P->objects;
|
|
|
|
i = 0;
|
|
- while (objects[i].type && (i < NUM_OBJECTS (API))) i++;
|
|
+ while ((i < NUM_OBJECTS (API)) && objects[i].type) i++;
|
|
|
|
if (i == NUM_OBJECTS (API))
|
|
{ WMF_ERROR (API,"Object out of range!");
|
|
@@ -2142,7 +2142,7 @@ static int meta_dib_brush (wmfAPI* API,w
|
|
objects = P->objects;
|
|
|
|
i = 0;
|
|
- while (objects[i].type && (i < NUM_OBJECTS (API))) i++;
|
|
+ while ((i < NUM_OBJECTS (API)) && objects[i].type) i++;
|
|
|
|
if (i == NUM_OBJECTS (API))
|
|
{ WMF_ERROR (API,"Object out of range!");
|
|
@@ -3067,7 +3067,7 @@ static int meta_pen_create (wmfAPI* API,
|
|
objects = P->objects;
|
|
|
|
i = 0;
|
|
- while (objects[i].type && (i < NUM_OBJECTS (API))) i++;
|
|
+ while ((i < NUM_OBJECTS (API)) && objects[i].type) i++;
|
|
|
|
if (i == NUM_OBJECTS (API))
|
|
{ WMF_ERROR (API,"Object out of range!");
|
|
@@ -3181,7 +3181,7 @@ static int meta_brush_create (wmfAPI* AP
|
|
objects = P->objects;
|
|
|
|
i = 0;
|
|
- while (objects[i].type && (i < NUM_OBJECTS (API))) i++;
|
|
+ while ((i < NUM_OBJECTS (API)) && objects[i].type) i++;
|
|
|
|
if (i == NUM_OBJECTS (API))
|
|
{ WMF_ERROR (API,"Object out of range!");
|
|
@@ -3288,7 +3288,7 @@ static int meta_font_create (wmfAPI* API
|
|
objects = P->objects;
|
|
|
|
i = 0;
|
|
- while (objects[i].type && (i < NUM_OBJECTS (API))) i++;
|
|
+ while ((i < NUM_OBJECTS (API)) && objects[i].type) i++;
|
|
|
|
if (i == NUM_OBJECTS (API))
|
|
{ WMF_ERROR (API,"Object out of range!");
|
|
@@ -3396,7 +3396,7 @@ static int meta_palette_create (wmfAPI*
|
|
objects = P->objects;
|
|
|
|
i = 0;
|
|
- while (objects[i].type && (i < NUM_OBJECTS (API))) i++;
|
|
+ while ((i < NUM_OBJECTS (API)) && objects[i].type) i++;
|
|
|
|
if (i == NUM_OBJECTS (API))
|
|
{ WMF_ERROR (API,"Object out of range!");
|