98d9182205
* gnu/packages/patches/icecat-CVE-2016-2818-pt1.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt2.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt3.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt4.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt5.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt6.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt7.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt8.patch, gnu/packages/patches/icecat-CVE-2016-2818-pt9.patch, gnu/packages/patches/icecat-CVE-2016-2819.patch, gnu/packages/patches/icecat-CVE-2016-2821.patch, gnu/packages/patches/icecat-CVE-2016-2824.patch, gnu/packages/patches/icecat-CVE-2016-2828.patch, gnu/packages/patches/icecat-CVE-2016-2831.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
18 lines
734 B
Diff
18 lines
734 B
Diff
changeset: 312067:380ddd689680
|
|
user: Timothy Nikkel <tnikkel@gmail.com>
|
|
Date: Tue May 10 22:58:26 2016 -0500
|
|
summary: Bug 1261752. Part 1. r=mats a=ritu
|
|
|
|
diff -r 02df988a56ae -r 380ddd689680 view/nsViewManager.cpp
|
|
--- a/view/nsViewManager.cpp Thu May 26 10:06:15 2016 -0700
|
|
+++ b/view/nsViewManager.cpp Tue May 10 22:58:26 2016 -0500
|
|
@@ -416,7 +416,7 @@
|
|
if (aWidget->NeedsPaint()) {
|
|
// If an ancestor widget was hidden and then shown, we could
|
|
// have a delayed resize to handle.
|
|
- for (nsViewManager *vm = this; vm;
|
|
+ for (RefPtr<nsViewManager> vm = this; vm;
|
|
vm = vm->mRootView->GetParent()
|
|
? vm->mRootView->GetParent()->GetViewManager()
|
|
: nullptr) {
|