7c6058c082
* gnu/packages/games.scm (higan): Use semi-official repository at GitLab (using hotfix tag 098b which is equivalent to official release 098). Add a patch to remove the build flag -march=native. Set profile to balanced. * gnu/packages/patches/higan-remove-march-native-flag.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
14 lines
369 B
Diff
14 lines
369 B
Diff
Remove -march=native from build flags.
|
|
|
|
--- a/higan/GNUmakefile
|
|
+++ b/higan/GNUmakefile
|
|
@@ -32,7 +32,7 @@ ifeq ($(platform),windows)
|
|
else ifeq ($(platform),macosx)
|
|
flags += -march=native
|
|
else ifneq ($(filter $(platform),linux bsd),)
|
|
- flags += -march=native -fopenmp
|
|
+ flags += -fopenmp
|
|
link += -fopenmp
|
|
link += -Wl,-export-dynamic
|
|
link += -lX11 -lXext
|