8e28d22c91
* gnu/packages/patches/libtiff-CVE-2012-4564.patch, gnu/packages/patches/libtiff-CVE-2013-1960.patch, gnu/packages/patches/libtiff-CVE-2013-1961.patch, gnu/packages/patches/libtiff-CVE-2013-4231.patch, gnu/packages/patches/libtiff-CVE-2013-4232.patch, gnu/packages/patches/libtiff-CVE-2013-4243.patch, gnu/packages/patches/libtiff-CVE-2013-4244.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt1.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt2.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt3.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt4.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt1.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt2.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt3.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt4.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt5.patch, gnu/packages/patches/libtiff-CVE-2014-8129.patch, gnu/packages/patches/libtiff-CVE-2014-9330.patch, gnu/packages/patches/libtiff-CVE-2014-9655.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/image.scm (libtiff)[source]: Add patches.
21 lines
690 B
Diff
21 lines
690 B
Diff
Copied from Debian
|
|
|
|
Description: use after free in tiff2pdf
|
|
Bug: http://bugzilla.maptools.org/show_bug.cgi?id=2449
|
|
Bug-Debian: http://bugs.debian.org/719303
|
|
|
|
Index: tiff-4.0.3/tools/tiff2pdf.c
|
|
===================================================================
|
|
--- tiff-4.0.3.orig/tools/tiff2pdf.c 2013-08-22 11:46:37.292847242 -0400
|
|
+++ tiff-4.0.3/tools/tiff2pdf.c 2013-08-22 11:46:37.292847242 -0400
|
|
@@ -2461,7 +2461,8 @@
|
|
(unsigned long) t2p->tiff_datasize,
|
|
TIFFFileName(input));
|
|
t2p->t2p_error = T2P_ERR_ERROR;
|
|
- _TIFFfree(buffer);
|
|
+ _TIFFfree(buffer);
|
|
+ return(0);
|
|
} else {
|
|
buffer=samplebuffer;
|
|
t2p->tiff_datasize *= t2p->tiff_samplesperpixel;
|