8e28d22c91
* gnu/packages/patches/libtiff-CVE-2012-4564.patch, gnu/packages/patches/libtiff-CVE-2013-1960.patch, gnu/packages/patches/libtiff-CVE-2013-1961.patch, gnu/packages/patches/libtiff-CVE-2013-4231.patch, gnu/packages/patches/libtiff-CVE-2013-4232.patch, gnu/packages/patches/libtiff-CVE-2013-4243.patch, gnu/packages/patches/libtiff-CVE-2013-4244.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt1.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt2.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt3.patch, gnu/packages/patches/libtiff-CVE-2014-8127-pt4.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt1.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt2.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt3.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt4.patch, gnu/packages/patches/libtiff-CVE-2014-8128-pt5.patch, gnu/packages/patches/libtiff-CVE-2014-8129.patch, gnu/packages/patches/libtiff-CVE-2014-9330.patch, gnu/packages/patches/libtiff-CVE-2014-9655.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/image.scm (libtiff)[source]: Add patches.
40 lines
1.3 KiB
Diff
40 lines
1.3 KiB
Diff
Copied from Debian
|
|
|
|
Index: tiff/tools/gif2tiff.c
|
|
===================================================================
|
|
--- tiff.orig/tools/gif2tiff.c
|
|
+++ tiff/tools/gif2tiff.c
|
|
@@ -280,6 +280,10 @@ readgifimage(char* mode)
|
|
fprintf(stderr, "no colormap present for image\n");
|
|
return (0);
|
|
}
|
|
+ if (width == 0 || height == 0) {
|
|
+ fprintf(stderr, "Invalid value of width or height\n");
|
|
+ return(0);
|
|
+ }
|
|
if ((raster = (unsigned char*) _TIFFmalloc(width*height+EXTRAFUDGE)) == NULL) {
|
|
fprintf(stderr, "not enough memory for image\n");
|
|
return (0);
|
|
@@ -404,6 +408,10 @@ process(register int code, unsigned char
|
|
fprintf(stderr, "bad input: code=%d is larger than clear=%d\n",code, clear);
|
|
return 0;
|
|
}
|
|
+ if (*fill >= raster + width*height) {
|
|
+ fprintf(stderr, "raster full before eoi code\n");
|
|
+ return 0;
|
|
+ }
|
|
*(*fill)++ = suffix[code];
|
|
firstchar = oldcode = code;
|
|
return 1;
|
|
@@ -434,6 +442,10 @@ process(register int code, unsigned char
|
|
}
|
|
oldcode = incode;
|
|
do {
|
|
+ if (*fill >= raster + width*height) {
|
|
+ fprintf(stderr, "raster full before eoi code\n");
|
|
+ return 0;
|
|
+ }
|
|
*(*fill)++ = *--stackp;
|
|
} while (stackp > stack);
|
|
return 1;
|