4e3a7d8461
While at it, adjust patches for -p1 patch flag. * gnu/packages/patches/python-fix-tests.patch: Delete file. Move contents ... * gnu/packages/patches/python-3-fix-tests.patch: ... here. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/python.scm (python-3.7)[source](patches): Remove obsolete. [source](patch-flags): Remove. * gnu/packages/patches/python-3-deterministic-build-info.patch, gnu/packages/patches/python-3-search-paths.patch: Adjust for `patch -p1`.
18 lines
444 B
Diff
18 lines
444 B
Diff
Always provide the same date and time in 'Py_GetBuildInfo'.
|
|
This is the information shown at the REPL and in 'sys.version'.
|
|
We cannot pass it in CPPFLAGS due to whitespace in the DATE string.
|
|
|
|
--- a/Modules/getbuildinfo.c
|
|
+++ b/Modules/getbuildinfo.c
|
|
@@ -4,6 +4,10 @@
|
|
#include <stdio.h>
|
|
#endif
|
|
|
|
+/* Deterministic date and time. */
|
|
+#define DATE "Jan 1 1970"
|
|
+#define TIME "00:00:01"
|
|
+
|
|
#ifndef DATE
|
|
#ifdef __DATE__
|
|
#define DATE __DATE__
|