d9b1567a07
* gnu/packages/haskell-xyz.scm (ghc-pandoc): Update to 2.7.3. [source]: Add patches to fix tests. [arguments]: Remove '#:phases'. [inputs]: Remove 'ghc-deepseq-generics', 'ghc-old-locale', and 'ghc-yaml'; add 'ghc-hslua-module-system', 'ghc-hsyaml', 'ghc-ipynb', and 'ghc-unicode-transforms'. [native-inputs]: Add 'ghc-tasty-lua'. * gnu/packages/patches/ghc-pandoc-fix-html-tests.patch: New file. * gnu/packages/patches/ghc-pandoc-fix-latex-test.patch: New file. * gnu/local.mk: Add them.
93 lines
3.7 KiB
Diff
93 lines
3.7 KiB
Diff
This patch is taken from upstream. It fixes two HTML tests that are broken
|
|
due to using a Skylighting version greater than or equal to 0.8.2.
|
|
|
|
From 968d2046a3cb6db661673be580660ac402753c34 Mon Sep 17 00:00:00 2001
|
|
From: John MacFarlane <jgm@berkeley.edu>
|
|
Date: Sun, 14 Jul 2019 10:48:14 -0700
|
|
Subject: [PATCH] Update test for new skylighting.
|
|
|
|
---
|
|
test/lhs-test.html | 13 ++++++-------
|
|
test/lhs-test.html+lhs | 13 ++++++-------
|
|
2 files changed, 12 insertions(+), 14 deletions(-)
|
|
|
|
diff --git a/test/lhs-test.html b/test/lhs-test.html
|
|
index 6685555f4..446dd3d95 100644
|
|
--- a/test/lhs-test.html
|
|
+++ b/test/lhs-test.html
|
|
@@ -12,19 +12,18 @@
|
|
div.column{display: inline-block; vertical-align: top; width: 50%;}
|
|
</style>
|
|
<style>
|
|
-code.sourceCode > span { display: inline-block; line-height: 1.25; }
|
|
+pre > code.sourceCode { white-space: pre; position: relative; }
|
|
+pre > code.sourceCode > span { display: inline-block; line-height: 1.25; }
|
|
+pre > code.sourceCode > span:empty { height: 1.2em; }
|
|
code.sourceCode > span { color: inherit; text-decoration: inherit; }
|
|
-code.sourceCode > span:empty { height: 1.2em; }
|
|
-.sourceCode { overflow: visible; }
|
|
-code.sourceCode { white-space: pre; position: relative; }
|
|
div.sourceCode { margin: 1em 0; }
|
|
pre.sourceCode { margin: 0; }
|
|
@media screen {
|
|
div.sourceCode { overflow: auto; }
|
|
}
|
|
@media print {
|
|
-code.sourceCode { white-space: pre-wrap; }
|
|
-code.sourceCode > span { text-indent: -5em; padding-left: 5em; }
|
|
+pre > code.sourceCode { white-space: pre-wrap; }
|
|
+pre > code.sourceCode > span { text-indent: -5em; padding-left: 5em; }
|
|
}
|
|
pre.numberSource code
|
|
{ counter-reset: source-line 0; }
|
|
@@ -44,7 +43,7 @@ pre.numberSource { margin-left: 3em; border-left: 1px solid #aaaaaa; padding-le
|
|
div.sourceCode
|
|
{ }
|
|
@media screen {
|
|
-code.sourceCode > span > a:first-child::before { text-decoration: underline; }
|
|
+pre > code.sourceCode > span > a:first-child::before { text-decoration: underline; }
|
|
}
|
|
code span.al { color: #ff0000; font-weight: bold; } /* Alert */
|
|
code span.an { color: #60a0b0; font-weight: bold; font-style: italic; } /* Annotation */
|
|
diff --git a/test/lhs-test.html+lhs b/test/lhs-test.html+lhs
|
|
index e57dfc105..a5cdb0245 100644
|
|
--- a/test/lhs-test.html+lhs
|
|
+++ b/test/lhs-test.html+lhs
|
|
@@ -12,19 +12,18 @@
|
|
div.column{display: inline-block; vertical-align: top; width: 50%;}
|
|
</style>
|
|
<style>
|
|
-code.sourceCode > span { display: inline-block; line-height: 1.25; }
|
|
+pre > code.sourceCode { white-space: pre; position: relative; }
|
|
+pre > code.sourceCode > span { display: inline-block; line-height: 1.25; }
|
|
+pre > code.sourceCode > span:empty { height: 1.2em; }
|
|
code.sourceCode > span { color: inherit; text-decoration: inherit; }
|
|
-code.sourceCode > span:empty { height: 1.2em; }
|
|
-.sourceCode { overflow: visible; }
|
|
-code.sourceCode { white-space: pre; position: relative; }
|
|
div.sourceCode { margin: 1em 0; }
|
|
pre.sourceCode { margin: 0; }
|
|
@media screen {
|
|
div.sourceCode { overflow: auto; }
|
|
}
|
|
@media print {
|
|
-code.sourceCode { white-space: pre-wrap; }
|
|
-code.sourceCode > span { text-indent: -5em; padding-left: 5em; }
|
|
+pre > code.sourceCode { white-space: pre-wrap; }
|
|
+pre > code.sourceCode > span { text-indent: -5em; padding-left: 5em; }
|
|
}
|
|
pre.numberSource code
|
|
{ counter-reset: source-line 0; }
|
|
@@ -44,7 +43,7 @@ pre.numberSource { margin-left: 3em; border-left: 1px solid #aaaaaa; padding-le
|
|
div.sourceCode
|
|
{ }
|
|
@media screen {
|
|
-code.sourceCode > span > a:first-child::before { text-decoration: underline; }
|
|
+pre > code.sourceCode > span > a:first-child::before { text-decoration: underline; }
|
|
}
|
|
code span.al { color: #ff0000; font-weight: bold; } /* Alert */
|
|
code span.an { color: #60a0b0; font-weight: bold; font-style: italic; } /* Annotation */
|
|
--
|
|
2.23.0
|
|
|