1bef37ee2e
This reduces the number of references of the output from 54 to 31, removing references notably to gcc, expat, glib:bin, ld-wrapper-0, texinfo, pkg-config, make, gawk, binutils, etc. Reported by David Thompson. * gnu/packages/patches/emacs-exec-path.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/emacs.scm (emacs)[source]: Use it.
19 lines
630 B
Diff
19 lines
630 B
Diff
Do not capture the build-time value of $PATH in the 'emacs' executable
|
|
since this can noticeably increase the size of the closure of Emacs
|
|
with things like GCC being referenced.
|
|
|
|
--- a/lisp/loadup.el
|
|
+++ b/lisp/loadup.el
|
|
@@ -64,6 +64,11 @@
|
|
(expand-file-name "textmodes" dir)
|
|
(expand-file-name "vc" dir)))))
|
|
|
|
+;; Reset 'exec-path' so we don't capture the build-time $PATH in the
|
|
+;; 'emacs' executable.
|
|
+(setq-default exec-path nil)
|
|
+(setq exec-path nil)
|
|
+
|
|
(if (eq t purify-flag)
|
|
;; Hash consing saved around 11% of pure space in my tests.
|
|
(setq purify-flag (make-hash-table :test 'equal :size 70000)))
|