1badc85068
* gnu/packages/patches/ceph-skip-unittest_blockdev.patch: Adjust for 13.2.2. * gnu/packages/patches/ceph-rocksdb-compat.patch: Delete file. * gnu/packages/patches/ceph-detect-rocksdb.patch, gnu/packages/patches/ceph-volume-respect-PATH.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/storage.scm (ceph): Update to 13.2.2. [source]: Don't remove src/dpdk, which has been moved to src/spdk/dpdk and is purged elsewhere. Drop bundled rapidjson. Adjust patch list. [arguments]: Add "-DWITH_MGR_DASHBOARD_FRONTEND=OFF" and "-DWITH_SPDK=OFF" to #:configure-flags. Drop obsolete "-DWITH_EMBEDDED". Add workaround for <https://bugs.gnu.org/30756>. Remove obsolete test substitution. Rework 'wrap-python-script' to be less verbose and wrap more scripts. [native-inputs]: Add GCC-7. [inputs]: Add OATH-TOOLKIT, RAPIDJSON and PYTHON2-SIX.
23 lines
719 B
Diff
23 lines
719 B
Diff
Look for required tools in $PATH instead of just a handful locations.
|
|
|
|
diff --git a/src/ceph-volume/ceph_volume/util/system.py b/src/ceph-volume/ceph_volume/util/system.py
|
|
index b637f023a4..14516e1c65 100644
|
|
--- a/src/ceph-volume/ceph_volume/util/system.py
|
|
+++ b/src/ceph-volume/ceph_volume/util/system.py
|
|
@@ -33,14 +33,7 @@ def generate_uuid():
|
|
|
|
def which(executable):
|
|
"""find the location of an executable"""
|
|
- locations = (
|
|
- '/usr/local/bin',
|
|
- '/bin',
|
|
- '/usr/bin',
|
|
- '/usr/local/sbin',
|
|
- '/usr/sbin',
|
|
- '/sbin',
|
|
- )
|
|
+ locations = os.getenv('PATH').split(':')
|
|
|
|
for location in locations:
|
|
executable_path = os.path.join(location, executable)
|