e2cf93aaa8
* gnu/packages/rust-apps.scm (rust-cargo-edit): Update to 0.12.2. [source]: Add patch. [cargo-inputs]: Add rust-clap-cargo-0.12, rust-home-0.5, rust-toml-0.7. Replace rust-clap-3 with 4, rust-crates-index-0.18 with 0.19, rust-git2-0.14 with 0.17, rust-toml-edit-0.14 with 0.19. Remove rust-dirs-next-2, rust-ureq-2. [cargo-development-inputs]: Replace rust-predicates-2 with 3, rust-snapbox-0.2 with 0.4, rust-trycmd-0.13 with 0.14. [inputs]: Replace libgit2-1.4 with 1.6. * gnu/packages/patches/rust-cargo-edit-remove-ureq.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I71ac74de44e322eb9f5233262b3a989395b592ff
34 lines
1.0 KiB
Diff
34 lines
1.0 KiB
Diff
This is modeled after the upstream commit which removes ureq as a dependency.
|
|
|
|
diff --git a/Cargo.toml b/Cargo.toml
|
|
index 5a787e1..27171c7 100644
|
|
--- a/Cargo.toml
|
|
+++ b/Cargo.toml
|
|
@@ -201,26 +201,3 @@ test-external-apis = []
|
|
upgrade = ["cli"]
|
|
vendored-libgit2 = ["git2/vendored-libgit2"]
|
|
vendored-openssl = ["git2/vendored-openssl"]
|
|
-
|
|
-[target."cfg(any(target_arch = \"x86_64\", target_arch = \"arm\", target_arch = \"x86\", target_arch = \"aarch64\"))".dependencies.ureq]
|
|
-version = "2.7.1"
|
|
-features = [
|
|
- "tls",
|
|
- "json",
|
|
- "socks",
|
|
- "socks-proxy",
|
|
-]
|
|
-default-features = false
|
|
-
|
|
-[target."cfg(not(any(target_arch = \"x86_64\", target_arch = \"arm\", target_arch = \"x86\", target_arch = \"aarch64\")))".dependencies.native-tls]
|
|
-version = "^0.2"
|
|
-
|
|
-[target."cfg(not(any(target_arch = \"x86_64\", target_arch = \"arm\", target_arch = \"x86\", target_arch = \"aarch64\")))".dependencies.ureq]
|
|
-version = "2.7.1"
|
|
-features = [
|
|
- "native-tls",
|
|
- "json",
|
|
- "socks",
|
|
- "socks-proxy",
|
|
-]
|
|
-default-features = false
|