690b8901c3
* gnu/packages/llvm.scm (%llvm-patches): Add patch for llvm-14. * gnu/packages/patches/clang-runtime-14-glibc-2.36-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: Ib5350be48f6580d00cb9b70435931abf0444c664
51 lines
2.2 KiB
Diff
51 lines
2.2 KiB
Diff
This commit is from upstream and is included in the llvm-15 release
|
||
|
||
commit b379129c4beb3f26223288627a1291739f33af02
|
||
Author: Fangrui Song <i@maskray.me>
|
||
Date: Mon Jul 11 11:38:28 2022 -0700
|
||
|
||
[sanitizer] Remove #include <linux/fs.h> to resolve fsconfig_command/mount_attr conflict with glibc 2.36
|
||
|
||
It is generally not a good idea to mix usage of glibc headers and Linux UAPI
|
||
headers (https://sourceware.org/glibc/wiki/Synchronizing_Headers). In glibc
|
||
since 7eae6a91e9b1670330c9f15730082c91c0b1d570 (milestone: 2.36), sys/mount.h
|
||
defines `fsconfig_command` which conflicts with linux/mount.h:
|
||
|
||
.../usr/include/linux/mount.h:95:6: error: redeclaration of ‘enum fsconfig_command’
|
||
|
||
Remove #include <linux/fs.h> which pulls in linux/mount.h. Expand its 4 macros manually.
|
||
|
||
Fix https://github.com/llvm/llvm-project/issues/56421
|
||
|
||
Reviewed By: #sanitizers, vitalybuka, zatrazz
|
||
|
||
Differential Revision: https://reviews.llvm.org/D129471
|
||
|
||
diff --git a/compiler-rt/lib/sanitizer_common/sanitizer_platform_limits_posix.cpp b/compiler-rt/lib/sanitizer_common/sanitizer_platform_limits_posix.cpp
|
||
index 4bd425435d56..81740bf4ab39 100644
|
||
--- a/compiler-rt/lib/sanitizer_common/sanitizer_platform_limits_posix.cpp
|
||
+++ b/compiler-rt/lib/sanitizer_common/sanitizer_platform_limits_posix.cpp
|
||
@@ -73,7 +73,6 @@
|
||
#include <sys/vt.h>
|
||
#include <linux/cdrom.h>
|
||
#include <linux/fd.h>
|
||
-#include <linux/fs.h>
|
||
#include <linux/hdreg.h>
|
||
#include <linux/input.h>
|
||
#include <linux/ioctl.h>
|
||
@@ -876,10 +875,10 @@ unsigned struct_ElfW_Phdr_sz = sizeof(Elf_Phdr);
|
||
unsigned IOCTL_EVIOCGPROP = IOCTL_NOT_PRESENT;
|
||
unsigned IOCTL_EVIOCSKEYCODE_V2 = IOCTL_NOT_PRESENT;
|
||
#endif
|
||
- unsigned IOCTL_FS_IOC_GETFLAGS = FS_IOC_GETFLAGS;
|
||
- unsigned IOCTL_FS_IOC_GETVERSION = FS_IOC_GETVERSION;
|
||
- unsigned IOCTL_FS_IOC_SETFLAGS = FS_IOC_SETFLAGS;
|
||
- unsigned IOCTL_FS_IOC_SETVERSION = FS_IOC_SETVERSION;
|
||
+ unsigned IOCTL_FS_IOC_GETFLAGS = _IOR('f', 1, long);
|
||
+ unsigned IOCTL_FS_IOC_GETVERSION = _IOR('v', 1, long);
|
||
+ unsigned IOCTL_FS_IOC_SETFLAGS = _IOW('f', 2, long);
|
||
+ unsigned IOCTL_FS_IOC_SETVERSION = _IOW('v', 2, long);
|
||
unsigned IOCTL_GIO_CMAP = GIO_CMAP;
|
||
unsigned IOCTL_GIO_FONT = GIO_FONT;
|
||
unsigned IOCTL_GIO_UNIMAP = GIO_UNIMAP;
|